]> git.pld-linux.org Git - packages/amanda.git/blob - amanda.spec
- pass more command paths (mail,lpr,dump,restore,xfsdump,xfsrestore)
[packages/amanda.git] / amanda.spec
1 #
2 # Conditional build:
3 %bcond_with     xfs     # with support for xfsdump
4 #
5 Summary:        A network-capable tape backup solution
6 Summary(pl):    Sieciowo zorientowany system tworzenia kopii zapasowych
7 Name:           amanda
8 Version:        2.4.5
9 Release:        4
10 License:        BSD
11 Group:          Networking/Utilities
12 Source0:        http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
13 # Source0-md5:  1960b7875424e412d042bc92a1548d7f
14 Source1:        %{name}-srv.crontab
15 Source2:        %{name}.inetd
16 Source3:        %{name}idx.inetd
17 Source4:        amidxtape.inetd
18 Source5:        %{name}.conf
19 Patch0:         %{name}-no_libnsl.patch
20 Patch1:         %{name}-ac25x.patch
21 Patch2:         %{name}-chg-zd-mtx-sh.patch
22 Patch3:         %{name}-tar.patch
23 URL:            http://www.amanda.org/
24 BuildRequires:  autoconf >= 2.53
25 BuildRequires:  automake
26 BuildRequires:  cpio
27 BuildRequires:  dump
28 BuildRequires:  flex
29 BuildRequires:  libtool
30 BuildRequires:  readline-devel >= 4.2
31 BuildRequires:  rpmbuild(macros) >= 1.202
32 BuildRequires:  tar
33 %{?with_xfs:BuildRequires:      xfsdump}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _localstatedir  /var/lib
37 %define         _libexecdir     %{_libdir}/amanda
38
39 %description
40 AMANDA, the Advanced Maryland Automatic Network Disk Archiver, is a
41 backup system that allows the administrator of a LAN to set up a
42 single master backup server to back up multiple hosts to a single
43 large capacity tape drive. AMANDA uses native dump and/or GNU tar
44 facilities and can back up a large number of workstations running
45 multiple versions of Unix. Newer versions of AMANDA (including this
46 version) can use SAMBA to back up Microsoft(TM) Windows95/NT hosts.
47 The amanda package contains the core AMANDA programs and will need to
48 be installed on both AMANDA clients and AMANDA servers. Note that you
49 will have to install the amanda-client and amanda-server packages as
50 well.
51
52 %description -l pl
53 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
54 zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
55 hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
56 Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
57 Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
58 podstawowe pliki programu i powinien byæ zainstalowany zarówno na
59 serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
60 amanda-client i amanda-server!
61
62 %package libs
63 Summary:        Amanda shared libraries
64 Summary(pl):    Biblioteki wspó³dzielone pakietu amanda
65 Group:          Networking/Utilities
66 Requires(postun):       /sbin/ldconfig
67 Requires(postun):       /usr/sbin/groupdel
68 Requires(postun):       /usr/sbin/userdel
69 Requires(pre):  /bin/id
70 Requires(pre):  /usr/bin/getgid
71 Requires(pre):  /usr/sbin/groupadd
72 Requires(pre):  /usr/sbin/useradd
73 Provides:       group(amanda)
74 Provides:       user(amanda)
75
76 %description libs
77 Amanda shared libraries.
78
79 %description libs -l pl
80 Biblioteki wspó³dzielone pakietu amanda.
81
82 %package client
83 Summary:        The client side of Amanda
84 Summary(pl):    Klient Amandy
85 Group:          Networking/Utilities
86 Requires(post,postun):  /sbin/ldconfig
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       rc-inetd
89 Conflicts:      tar < 1.13
90
91 %description client
92 The Amanda-client package should be installed on any machine that will
93 be backed up by AMANDA (including the server if it also needs to be
94 backed up). You will also need to install the amanda package to each
95 AMANDA client. It requires at least one of dump and GNU tar installed.
96
97 %description client -l pl
98 Ten pakiet powinien byæ zainstalowany ma maszynach, z których
99 zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
100 najmniej jednego z pakietów dump i GNU tar.
101
102 %package server
103 Summary:        The server side of Amanda
104 Summary(pl):    Serwer Amandy
105 Group:          Networking/Utilities
106 Requires(post,postun):  /sbin/ldconfig
107 Requires:       %{name}-libs = %{version}-%{release}
108 Requires:       /etc/cron.d
109 Requires:       crondaemon
110 Requires:       gnuplot
111 Requires:       mt-st
112 Requires:       mtx
113 Requires:       rc-inetd
114 Obsoletes:      amanda
115
116 %description server
117 The amanda-server package should be installed on the AMANDA server,
118 the machine attached to the device (such as a tape drive) where
119 backups will be written. You will also need to install the amanda
120 package to the AMANDA server. And, if the server is also to be backed
121 up, the server also needs to have the amanda-client package installed.
122
123 %description server -l pl
124 Ten pakiet powinien byæ zainstalowany na maszynach, na których bêd±
125 magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
126 typu streamer).
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132 %patch2 -p1
133 %patch3 -p1
134
135 # kill libtool.m4 copy
136 head -n 1039 acinclude.m4 > acinc.tmp
137 mv -f acinc.tmp acinclude.m4
138
139 %build
140 %{__libtoolize}
141 %{__aclocal}
142 %{__autoconf}
143 %{__automake}
144 %configure \
145         GNUPLOT=/usr/bin/gnuplot \
146         MAILER=/bin/mail \
147         PRINT=/usr/bin/lpr \
148         DUMP=/sbin/dump \
149         RESTORE=/sbin/restore \
150         XFSDUMP=/sbin/xfsdump \
151         XFSRESTORE=/sbin/xfsrestore \
152         --disable-static \
153         --enable-shared \
154         --with-index-server=localhost \
155         --with-user=amanda \
156         --with-group=amanda \
157         --with-tape-device=/dev/null \
158         --with-ftape-rawdevice=/dev/null \
159         --with-changer-device=/dev/null \
160         --with-fqdn \
161         --with-smbclient=%{_bindir}/smbclient \
162         --with-bsd-security \
163         --with-buffered-dump \
164         --with-amandahosts \
165         --with-debugging=%{_localstatedir}/amanda/debug \
166         --with-gnutar-listdir=%{_localstatedir}/amanda/gnutar-lists \
167         --with-tmpdir=/var/tmp
168
169 %{__make}
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{amanda,cron.d,sysconfig/rc-inetd} \
174         $RPM_BUILD_ROOT%{_localstatedir}/amanda/gnutar-lists \
175         $RPM_BUILD_ROOT%{_mandir}/man1
176
177 %{__make} install \
178         DESTDIR=$RPM_BUILD_ROOT \
179         SETUID_GROUP=`id -g`
180
181 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amanda-srv
182 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE2} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amanda
183 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE3} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amandaidx
184 sed -e 's|/usr/lib|%{_libdir}|' %{SOURCE4} >$RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/amidxtape
185
186 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/amanda
187 install example/*.ps $RPM_BUILD_ROOT%{_localstatedir}/amanda
188 touch $RPM_BUILD_ROOT%{_localstatedir}/amanda/.amandahosts
189
190 > $RPM_BUILD_ROOT%{_sysconfdir}/amandates
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %triggerpostun -- amanda-libs < 2.4.2p2-3
196 /usr/sbin/chsh -s /bin/sh amanda
197
198 %triggerpostun -- amanda-libs < 2.4.2p2-12
199 /usr/sbin/usermod -G disk amanda
200
201 %pre libs
202 %groupadd -P %{name}-libs -g 80 amanda
203 %useradd -P %{name}-libs -u 80 -G disk -d /var/lib/amanda -s /bin/sh -c "Amanda Backup user" -g amanda amanda
204
205 %post   libs -p /sbin/ldconfig
206
207 %postun libs
208 /sbin/ldconfig
209 if [ "$1" = "0" ]; then
210         %userremove amanda
211         %groupremove amanda
212 fi
213
214 %post client
215 /sbin/ldconfig
216 if [ -f /var/lock/subsys/rc-inetd ]; then
217         /etc/rc.d/init.d/rc-inetd restart 1>&2
218 else
219         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
220 fi
221
222 %postun client
223 /sbin/ldconfig
224 if [ -f /var/lock/subsys/rc-inetd ]; then
225         /etc/rc.d/init.d/rc-inetd restart
226 fi
227
228 %post server
229 /sbin/ldconfig
230 if [ -f /var/lock/subsys/rc-inetd ]; then
231         /etc/rc.d/init.d/rc-inetd restart 1>&2
232 else
233         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
234 fi
235 if [ "$1" = "1" ]; then
236         echo "Don't forget to edit /etc/cron.d/amanda-srv." 1>&2
237 fi
238
239 %postun server
240 /sbin/ldconfig
241 if [ -f /var/lock/subsys/rc-inetd ]; then
242         /etc/rc.d/init.d/rc-inetd restart
243 fi
244
245 %files libs
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libamanda*.so
248 %attr(755,root,root) %{_libdir}/libamtape*.so
249 %dir %{_libexecdir}
250 %attr(770,root,amanda) %dir %{_localstatedir}/amanda
251 %attr(640,root,amanda) %config(noreplace) %verify(not md5 mtime size) %{_localstatedir}/amanda/.amandahosts
252
253 %files server
254 %defattr(644,root,root,755)
255 %doc docs/*
256 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amidxtape
257 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amandaidx
258
259 %attr(750,root,amanda) %dir %{_sysconfdir}/amanda
260 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,amanda) %{_sysconfdir}/amanda/*
261
262 %attr(664,root,amanda) %{_localstatedir}/amanda/*.ps
263
264 %config(noreplace) %attr(640,root,root) /etc/cron.d/amanda-srv
265
266 %attr(755,root,root) %{_libdir}/libamserver*.so
267 %attr(755,root,root) %{_libexecdir}/amindexd
268 %attr(755,root,root) %{_libexecdir}/amtrmidx
269 %attr(755,root,root) %{_libexecdir}/driver
270 %attr(4754,root,amanda) %{_libexecdir}/dumper
271 %attr(4754,root,amanda) %{_libexecdir}/planner
272 %attr(755,root,root) %{_libexecdir}/amcat.awk
273 %attr(755,root,root) %{_libexecdir}/amcleanupdisk
274 %attr(755,root,root) %{_libexecdir}/amidxtaped
275 %attr(755,root,root) %{_libexecdir}/amlogroll
276 %attr(755,root,root) %{_libexecdir}/amplot.awk
277 %attr(755,root,root) %{_libexecdir}/amplot.g
278 %attr(755,root,root) %{_libexecdir}/amplot.gp
279 %attr(755,root,root) %{_libexecdir}/amtrmlog
280 %attr(755,root,root) %{_libexecdir}/chg-chio
281 %attr(755,root,root) %{_libexecdir}/chg-chs
282 %attr(755,root,root) %{_libexecdir}/chg-disk
283 %attr(755,root,root) %{_libexecdir}/chg-iomega
284 %attr(755,root,root) %{_libexecdir}/chg-juke
285 %attr(755,root,root) %{_libexecdir}/chg-manual
286 %attr(755,root,root) %{_libexecdir}/chg-mcutil
287 %attr(755,root,root) %{_libexecdir}/chg-mtx
288 %attr(755,root,root) %{_libexecdir}/chg-multi
289 %attr(755,root,root) %{_libexecdir}/chg-null
290 %attr(755,root,root) %{_libexecdir}/chg-rait
291 %attr(755,root,root) %{_libexecdir}/chg-rth
292 %attr(755,root,root) %{_libexecdir}/chg-scsi
293 %attr(755,root,root) %{_libexecdir}/chg-zd-mtx
294 %attr(755,root,root) %{_libexecdir}/taper
295 %attr(755,root,root) %{_sbindir}/amadmin
296 %attr(4754,root,amanda) %{_sbindir}/amcheck
297 %attr(755,root,root) %{_sbindir}/amcheckdb
298 %attr(755,root,root) %{_sbindir}/amcleanup
299 %attr(755,root,root) %{_sbindir}/amdump
300 %attr(755,root,root) %{_sbindir}/amflush
301 %attr(755,root,root) %{_sbindir}/amgetconf
302 %attr(755,root,root) %{_sbindir}/amlabel
303 %attr(755,root,root) %{_sbindir}/amoverview
304 %attr(755,root,root) %{_sbindir}/amplot
305 %attr(755,root,root) %{_sbindir}/amreport
306 %attr(755,root,root) %{_sbindir}/amrmtape
307 %attr(755,root,root) %{_sbindir}/amstatus
308 %attr(755,root,root) %{_sbindir}/amtape
309 %attr(755,root,root) %{_sbindir}/amtapetype
310 %attr(755,root,root) %{_sbindir}/amtoc
311 %attr(755,root,root) %{_sbindir}/amverify
312 %attr(755,root,root) %{_sbindir}/amverifyrun
313 %{_mandir}/man8/amadmin.8*
314 %{_mandir}/man8/amanda.8*
315 %{_mandir}/man8/amcheck.8*
316 %{_mandir}/man8/amcheckdb.8*
317 %{_mandir}/man8/amcleanup.8*
318 %{_mandir}/man8/amdump.8*
319 %{_mandir}/man8/amflush.8*
320 %{_mandir}/man8/amgetconf.8*
321 %{_mandir}/man8/amlabel.8*
322 %{_mandir}/man8/amoverview.8*
323 %{_mandir}/man8/amplot.8*
324 %{_mandir}/man8/amreport.8*
325 %{_mandir}/man8/amrmtape.8*
326 %{_mandir}/man8/amstatus.8*
327 %{_mandir}/man8/amtape.8*
328 %{_mandir}/man8/amtapetype.8*
329 %{_mandir}/man8/amtoc.8*
330 %{_mandir}/man8/amverify.8*
331 %{_mandir}/man8/amverifyrun.8*
332
333 %files client
334 %defattr(644,root,root,755)
335 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/amanda
336 %attr(664,root,amanda) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/amandates
337 %attr(755,root,root) %{_libdir}/libamclient*.so
338 %attr(755,root,root) %{_libexecdir}/versionsuffix
339 %attr(755,root,root) %{_libexecdir}/amandad
340 %attr(4754,root,amanda) %{_libexecdir}/amqde
341 %attr(4754,root,amanda) %{_libexecdir}/calcsize
342 %attr(4754,root,amanda) %{_libexecdir}/killpgrp
343 %attr(755,root,root) %{_libexecdir}/patch-system
344 %attr(4754,root,amanda) %{_libexecdir}/rundump
345 %attr(4754,root,amanda) %{_libexecdir}/runtar
346 %attr(4754,root,amanda) %{_libexecdir}/selfcheck
347 %attr(755,root,root) %{_libexecdir}/sendbackup
348 %attr(755,root,root) %{_libexecdir}/sendsize
349 %attr(755,root,root) %{_sbindir}/amdd
350 %attr(755,root,root) %{_sbindir}/ammt
351 %attr(755,root,root) %{_sbindir}/amrecover
352 %attr(755,root,root) %{_sbindir}/amrestore
353 %attr(770,root,amanda) %dir %{_localstatedir}/amanda/gnutar-lists
354 %{_mandir}/man8/amdd.8*
355 %{_mandir}/man8/ammt.8*
356 %{_mandir}/man8/amrecover.8*
357 %{_mandir}/man8/amrestore.8*
This page took 0.045982 seconds and 4 git commands to generate.