]> git.pld-linux.org Git - packages/alex.git/blob - alex.spec
- release 1
[packages/alex.git] / alex.spec
1 Summary:        A lexical analyser generator for Haskell
2 Name:           alex
3 Version:        2.0
4 Release:        1
5 License:        BSD-like w/o adv. clause
6 Group:          Development/Tools
7 Source0:        http://www.haskell.org/alex/dist/%{name}-%{version}-src.tar.bz2
8 # Source0-md5:  14ff6abf21d81763b15afe151add9091
9 Patch0:         %{name}-DESTDIR.patch
10 URL:            http://www.haskell.org/alex/
11 BuildRequires:  ghc >= 5.04
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Alex is a tool for generating lexical analysers in Haskell,
16 given a description of the tokens to be recognised in the form
17 of regular expressions.
18 It is similar to the tool lex or flex for C/C++.
19
20 %prep
21 %setup -q
22 %patch0 -p1
23
24 %build
25 %configure
26 %{__make}
27 %{__make} ps -C alex/doc
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
32
33 %{__make} install \
34         DESTDIR=$RPM_BUILD_ROOT
35
36 cp -a alex/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc alex/{ANNOUNCE,LICENSE,README} alex/doc/alex.{ps,dvi}
44 %attr(755,root,root) %{_bindir}/*
45 %{_libdir}/%{name}-%{version}/A*
46 %attr(755,root,root) %{_libdir}/%{name}-%{version}/alex.bin
47 %{_examplesdir}/%{name}-%{version}
This page took 0.041455 seconds and 3 git commands to generate.