]> git.pld-linux.org Git - packages/accelio.git/blob - accelio.spec
- updated to 1.6
[packages/accelio.git] / accelio.spec
1 # TODO:
2 # - kernel modules (BR: OFED kernel headers)
3 #
4 # Conditional build:
5 %bcond_without  fio             # FIO module
6 %bcond_with     kernel          # kernel modules
7 %bcond_without  static_libs     # static libraries
8 #
9 Summary:        Open Source I/O, Message and RPC Acceleration library
10 Summary(pl.UTF-8):      Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
11 Name:           accelio
12 Version:        1.6
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 Source0:        https://github.com/accelio/accelio/archive/v%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  0f6634e03ff1bf2e9b83e554202d093f
18 Patch0:         %{name}-fio.patch
19 Patch1:         %{name}-sse.patch
20 URL:            http://www.accelio.org/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake >= 1:1.11
23 %{?with_fio:BuildRequires:      fio-devel >= 2.8}
24 BuildRequires:  libaio-devel
25 BuildRequires:  libevent-devel >= 2
26 BuildRequires:  libibverbs-devel
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  numactl-devel
29 BuildRequires:  sed >= 4.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Accelio provides an easy-to-use, reliable, scalable, and high
34 performance data/message delivery middleware that maximizes the
35 efficiency of modern CPU and NIC hardware and that reduces
36 time-to-market of new scale-out applications.
37
38 %description -l pl.UTF-8
39 Accelio dostarcza łatwą w użyciu, wiarygodną, skalowalną i szybką
40 warstwę pośrednią przekazującą dane i komunikaty, maksymalizującą
41 wydajność współczesnych CPU i NIC, zmniejszającą czas potrzebny
42 na wytworzenie nowych aplikacji.
43
44 %package devel
45 Summary:        Header files for Accelio libraries
46 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Accelio
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for Accelio libraries.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe bibliotek Accelio.
55
56 %package static
57 Summary:        Static Accelio libraries
58 Summary(pl.UTF-8):      Statyczne biblioteki Accelio
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static Accelio libraries.
64
65 %description static -l pl.UTF-8
66 Statyczne biblioteki Accelio.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72
73 %{__sed} -i -e 's/-Werror //' configure.ac
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 for d in src/kernel/xio examples/kernel/hello_world examples/kernel/hello_world_mt tests/kernel/hello_test examples/raio/kernel/nbdx ; do
81 cd $d
82 %{__autoconf}
83 cd -
84 done
85 %configure \
86         %{?with_fio:FIO_ROOT=%{_includedir}/fio} \
87         --disable-silent-rules \
88         %{!?with_static_libs:--disable-static} \
89         %{?with_fio:--enable-fio-build} \
90         %{?with_kernel:--enable-kernel-module}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # fio module, .la is useless
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libraio_fio.la
101 # test program
102 %{__rm} $RPM_BUILD_ROOT%{_bindir}/event_loop_tests
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS COPYING ChangeLog NEWS README README.md
113 %attr(755,root,root) %{_bindir}/raio_client
114 %attr(755,root,root) %{_bindir}/raio_server
115 %attr(755,root,root) %{_bindir}/reg_basic_mt
116 %attr(755,root,root) %{_bindir}/xio_*
117 %attr(755,root,root) %{_bindir}/xioclntd
118 %attr(755,root,root) %{_bindir}/xiosrvd
119 %attr(755,root,root) %{_libdir}/libraio.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libraio.so.0
121 %if %{with fio}
122 %attr(755,root,root) %{_libdir}/libraio_fio.so
123 %endif
124 %attr(755,root,root) %{_libdir}/libxio.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libxio.so.0
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libraio.so
130 %attr(755,root,root) %{_libdir}/libxio.so
131 %{_libdir}/libraio.la
132 %{_libdir}/libxio.la
133 %{_includedir}/libraio.h
134 %{_includedir}/libxio.h
135 %{_includedir}/xio_base.h
136 %{_includedir}/xio_predefs.h
137 %{_includedir}/xio_user.h
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/libraio.a
143 %{_libdir}/libxio.a
144 %endif
This page took 0.077773 seconds and 3 git commands to generate.