]> git.pld-linux.org Git - packages/accelio.git/blob - accelio.spec
- adjusted fio patch for fio 3+ (with nanosecond precision); release 4
[packages/accelio.git] / accelio.spec
1 # TODO:
2 # - kernel modules (BR: OFED kernel headers)
3 #
4 # Conditional build:
5 %bcond_without  fio             # FIO module
6 %bcond_with     kernel          # kernel modules
7 %bcond_without  static_libs     # static libraries
8 #
9 Summary:        Open Source I/O, Message and RPC Acceleration library
10 Summary(pl.UTF-8):      Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
11 Name:           accelio
12 Version:        1.7
13 Release:        4
14 License:        BSD
15 Group:          Libraries
16 #Source0Download: https://github.com/accelio/accelio/releases
17 Source0:        https://github.com/accelio/accelio/archive/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  b363e15ea8f7dac2179a610c1393a624
19 Patch0:         %{name}-fio.patch
20 Patch1:         %{name}-sse.patch
21 URL:            http://www.accelio.org/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake >= 1:1.11
24 %{?with_fio:BuildRequires:      fio-devel >= 3}
25 BuildRequires:  libaio-devel
26 BuildRequires:  libevent-devel >= 2
27 BuildRequires:  libibverbs-devel
28 BuildRequires:  libtool >= 2:2
29 BuildRequires:  numactl-devel
30 BuildRequires:  sed >= 4.0
31 Conflicts:      fio < 3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Accelio provides an easy-to-use, reliable, scalable, and high
36 performance data/message delivery middleware that maximizes the
37 efficiency of modern CPU and NIC hardware and that reduces
38 time-to-market of new scale-out applications.
39
40 %description -l pl.UTF-8
41 Accelio dostarcza łatwą w użyciu, wiarygodną, skalowalną i szybką
42 warstwę pośrednią przekazującą dane i komunikaty, maksymalizującą
43 wydajność współczesnych CPU i NIC, zmniejszającą czas potrzebny
44 na wytworzenie nowych aplikacji.
45
46 %package devel
47 Summary:        Header files for Accelio libraries
48 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Accelio
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for Accelio libraries.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe bibliotek Accelio.
57
58 %package static
59 Summary:        Static Accelio libraries
60 Summary(pl.UTF-8):      Statyczne biblioteki Accelio
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static Accelio libraries.
66
67 %description static -l pl.UTF-8
68 Statyczne biblioteki Accelio.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74
75 %{__sed} -i -e 's/-Werror //' configure.ac
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__automake}
82 for d in src/kernel/xio examples/kernel/hello_world examples/kernel/hello_world_mt tests/kernel/hello_test examples/raio/kernel/nbdx ; do
83 cd $d
84 %{__autoconf}
85 cd -
86 done
87 %configure \
88         %{?with_fio:FIO_ROOT=%{_includedir}/fio} \
89         --disable-silent-rules \
90         %{!?with_static_libs:--disable-static} \
91         %{?with_fio:--enable-fio-build} \
92         %{?with_kernel:--enable-kernel-module}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # fio module, .la is useless
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libraio_fio.la
103 # test program
104 %{__rm} $RPM_BUILD_ROOT%{_bindir}/event_loop_tests
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING ChangeLog NEWS README README.md
115 %attr(755,root,root) %{_bindir}/raio_client
116 %attr(755,root,root) %{_bindir}/raio_server
117 %attr(755,root,root) %{_bindir}/reg_basic_mt
118 %attr(755,root,root) %{_bindir}/xio_*
119 %attr(755,root,root) %{_bindir}/xioclntd
120 %attr(755,root,root) %{_bindir}/xiosrvd
121 %attr(755,root,root) %{_libdir}/libraio.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libraio.so.0
123 %if %{with fio}
124 %attr(755,root,root) %{_libdir}/libraio_fio.so
125 %endif
126 %attr(755,root,root) %{_libdir}/libxio.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libxio.so.0
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libraio.so
132 %attr(755,root,root) %{_libdir}/libxio.so
133 %{_libdir}/libraio.la
134 %{_libdir}/libxio.la
135 %{_includedir}/libraio.h
136 %{_includedir}/libxio.h
137 %{_includedir}/xio_base.h
138 %{_includedir}/xio_predefs.h
139 %{_includedir}/xio_user.h
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libraio.a
145 %{_libdir}/libxio.a
146 %endif
This page took 0.091987 seconds and 3 git commands to generate.