]> git.pld-linux.org Git - packages/Zope.git/blob - Zope.spec
- more Requires()
[packages/Zope.git] / Zope.spec
1 Summary:        An application server and portal toolkit for building Web sites
2 Summary(es):    Un servidor de aplicaciones y un conjunto de herramientas para la construcción de sitios Web
3 Summary(pl):    Serwer aplikacji i toolkit portalowy do tworzenia serwisów WWW
4 Summary(pt_BR): Um servidor de aplicações e um conjunto de ferramentas para construção de sites Web
5 Name:           Zope
6 Version:        2.6.0
7 Release:        3
8 License:        Zope Public License (ZPL)
9 Group:          Networking/Daemons
10 Source0:        http://www.zope.org/Products/%{name}/%{version}/%{name}-%{version}-src.tgz
11 Source1:        http://www.zope.org/Documentation/Guides/ZCMG/ZCMG.html.tgz
12 Source2:        http://www.zope.org/Documentation/Guides/DTML/DTML.html.tgz
13 Source3:        http://www.zope.org/Documentation/Guides/ZSQL/ZSQL.html.tgz
14 Source4:        http://www.zope.org/Documentation/Guides/%{name}-ProductTutorial.tar.gz
15 Source5:        http://www.zope.org/Documentation/Guides/ZDG/ZDG.html.tgz
16 Source6:        http://www.zope.org/Documentation/Guides/ZAG/ZAG.html.tgz
17 # note: above documentation is deprecated, zope.org suggests using ZopeBook:
18 #Source1:       http://www.zope.org/Members/michel/ZB/ZopeBook.tgz
19 Source7:        %{name}.init
20 Source8:        %{name}-zserver.sh
21 URL:            http://www.zope.org/
22 PreReq:         rc-scripts
23 Requires(pre):  /usr/bin/getgid
24 Requires(pre):  /bin/id
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(postun):       /usr/sbin/userdel
29 Requires(postun):       /usr/sbin/groupdel
30 Requires:       python >= 2.2
31 Requires:       python-modules >= 2.2
32 BuildRequires:  python-devel >= 2.2
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
36 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
37 %define python_libdir      %{python_prefix}/lib/python%{python_version}
38 %define python_includedir  %{python_prefix}/include/python%{python_version}
39 %define python_sitedir     %{python_libdir}/site-packages
40 %define python_configdir   %{python_libdir}/config
41
42 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
43 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
44
45 %description
46 The Z Object Programming Environment (Zope) is a free, Open Source
47 Python-based application server for building high-performance, dynamic
48 web sites, using a powerful and simple scripting object model and
49 high-performance, integrated object database.
50
51 %description -l es
52 Zope es una aplicación basada en Python, Open Source[tm], para la
53 construcción de sitios dinámicos, usa un modelo de escritura de
54 guiones poderoso y sencillo. Para instalar la aplicación Zope, instale
55 ese paquete y después, Zope-server, para un servidor HTTP integrado
56 simple, Zope-pcgi, para uso con el servidor Apache. Si desea instalar
57 solamente algunas partes de la aplicación Zope, están diponibles otros
58 subpaquetes, usted debe instalar éstos en vez de ese RPM.
59
60 %description -l pl
61 Zope (Z Object Programming Environment - Obiektowe ¦rodowisko
62 Programistyczne Z) jest opartym o Pythona serwerem aplikacji do
63 tworzenia wysoko wydajnych, dynamicznych serwisów WWW, przy u¿yciu
64 u¿ytecznego i prostego modelu obiektowego skryptów oraz wysoko
65 wydajnej zintegrowanej obiektowej bazy danych.
66
67 %description -l pt_BR
68 Zope é uma aplicação baseada em Python, Open Source[tm], para
69 construção de sites dinâmicos, usando um modelo de scripting poderoso
70 e simples Para instalar o Zope, instale esse pacote e depois, ou o
71 Zope-server, para um servidor HTTP integrado simples, ou Zope-pcgi,
72 para uso com o Apache. Se você quiser instalar apenas algumas partes
73 do Zope, outros sub-pacotes estão disponíveis, e você deveria instalar
74 eles ao invés desse RPM.
75
76 %prep
77 %setup -q -n %{name}-%{version}-src -a4
78 mkdir ZopeContentManagersGuide GuideToDTML GuideToZSQL ZopeDevelopersGuide ZopeAdminGuide
79 tar xzf %{SOURCE1} -C ZopeContentManagersGuide
80 tar xzf %{SOURCE2} -C GuideToDTML
81 tar xzf %{SOURCE3} -C GuideToZSQL
82 tar xzf %{SOURCE5} -C ZopeDevelopersGuide
83 tar xzf %{SOURCE6} -C ZopeAdminGuide
84
85 %build
86 perl -pi -e "s|data_dir\s+=\s+.*?join\(INSTANCE_HOME, 'var'\)|data_dir=INSTANCE_HOME|" lib/python/Globals.py
87 python wo_pcgi.py
88
89 find lib/python -type f -and \( -name 'Setup' -or -name '.cvsignore' \) -exec rm -f \{\} \;
90 find -type f -and \( -name '*.c' -or -name '*.h' -or -name 'Makefile*' \) -exec rm -f \{\} \;
91 rm -f ZServer/medusa/monitor_client_win32.py
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/zope} \
96             $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/log,/var/lib/zope}
97
98 cp -a lib/python/* $RPM_BUILD_ROOT%{_libdir}/zope
99 cp -a ZServer/ utilities/ import/ $RPM_BUILD_ROOT%{_libdir}/zope
100 find $RPM_BUILD_ROOT%{_libdir}/zope -type f -name '*.py' -or -name '*.txt' | xargs -r rm -f
101 cp -a ZServer/medusa/test/* $RPM_BUILD_ROOT%{_libdir}/zope/ZServer/medusa/test/
102
103 install zpasswd.py $RPM_BUILD_ROOT%{_bindir}/zpasswd
104 install z2.py $RPM_BUILD_ROOT%{_libdir}/zope
105 install %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}/zope-zserver
106 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zope
107 install var/Data.fs $RPM_BUILD_ROOT/var/lib/zope/Data.fs
108
109 touch $RPM_BUILD_ROOT/var/log/zope
110
111 python $RPM_BUILD_ROOT%{_bindir}/zpasswd -u zope -p zope -d localhost $RPM_BUILD_ROOT/var/lib/zope/access
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %pre
117 if [ -z "`getgid zope`" ]; then
118         echo "Making group zope"
119         /usr/sbin/groupadd -r -f zope
120 fi
121
122 if [ -z "`id -u zope 2>/dev/null`" ]; then
123         echo "Making user zope"
124         /usr/sbin/useradd -r -d /var/lib/zope -s /bin/false -c "Zope User" -g zope zope
125 fi
126
127 %post
128 /sbin/chkconfig --add zope
129 if [ -f /var/lock/subsys/zope ]; then
130         /etc/rc.d/init.d/zope restart >&2
131 else
132         echo "Run \"/etc/rc.d/init.d/zope start\" to start Zope." >&2
133 fi
134
135 %preun
136 if [ "$1" = "0" ]; then
137         if [ -f /var/lock/subsys/zope ]; then
138                 /etc/rc.d/init.d/zope stop
139         fi
140         /sbin/chkconfig --del zope
141 fi
142
143 %postun
144 if [ "$1" = "0" ] ; then
145         echo "Removing user zope"
146         /usr/sbin/userdel zope >/dev/null 2>&1 || :
147         echo "Removing group zope"
148         /usr/sbin/groupdel zope >/dev/null 2>&1 || :    
149 fi
150
151 %files
152 %defattr(644,root,root,755)
153 %attr(755,root,root) /etc/rc.d/init.d/zope
154 %attr(755,root,root) %{_bindir}/*
155 %attr(755,root,root) %{_sbindir}/*
156 %{_libdir}/zope
157 %attr(1771,root,zope) %dir /var/lib/zope
158 %attr(660,root,zope) %config(noreplace) %verify(not md5 size mtime) /var/lib/zope/*
159 %doc *.txt doc/*.txt ZopeContentManagersGuide GuideToZSQL Tutorial ZopeDevelopersGuide ZopeAdminGuide
This page took 0.051258 seconds and 4 git commands to generate.