]> git.pld-linux.org Git - packages/Zope-archetypes.git/blob - Zope-archetypes.spec
- fixed License, cleanups/simplifications
[packages/Zope-archetypes.git] / Zope-archetypes.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         zope_subname    archetypes
4
5 Summary:        Archetypes - a framework for developing new content types in Plone
6 Summary(pl):    Archetypes - nowe ¶rodowisko pracy dla twórców serwisów Plone
7 Name:           Zope-%{zope_subname}
8 Version:        1.0.1
9 Release:        2
10 License:        GPL
11 Group:          Development/Tools
12 Source0:        http://dl.sourceforge.net/%{zope_subname}/%{zope_subname}-%{version}.tgz
13 # Source0-md5:  53f3ccf5a88ce3a91b50e8a82165c2de
14 URL:            http://dreamcatcher.homeunix.org/
15 %pyrequires_eq  python-modules
16 Requires:       CMF
17 Requires:       Plone
18 Requires:       Zope
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         product_dir     /usr/lib/zope/Products
23
24 %description
25 Archetypes is a framework for developing new content types in
26 Plone. The power of Archetypes is, first, in automatically generating
27 forms; second, in providing a library of stock field types, form
28 widgets, and field validators; third, in easily integrating custom
29 fields, widgets, and validators; and fourth, in automating
30 transformations of rich content.
31
32 %description -l pl
33 Archetypes jest nowym ¶rodowiskiem pracy dla twórców serwisów
34 Plone. Si³± Archetypes s± automatycznie generowane formularze,
35 zarz±dzalne biblioteki pól typów, kontrolek i korektorów pól, a tak¿e
36 ³atwa integracja zaawansowanych mo¿liwo¶ci z w/w typami. Posiada
37 równie¿ bogat± automatykê.
38
39 %prep
40 %setup -q -c
41
42 rm -f %{zope_subname}-%{version}/ArchGenXML/.cvsignore
43
44 %build
45 install -d docs/{ArchExample,ArchGenXML,Archetypes,generator,validation}
46 cd %{zope_subname}-%{version}
47 mv -f *.pdf ../docs
48 mv -f ArchExample/ChangeLog ../docs/ArchExample
49 mv -f ArchGenXML/README ../docs/ArchGenXML
50 mv -f Archetypes/{docs/*,AUTHORS,ChangeLog,README.txt,TODO.txt} ../docs/Archetypes
51 rm -rf Archetypes/docs
52 mv -f generator/{ChangeLog,README} ../docs/generator
53 mv -f validation/{ChangeLog,README} ../docs/validation
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{product_dir}
58
59 # should {Archetypes,validation}/tests and */version.txt be installed or not?
60 cp -af %{zope_subname}-%{version}/* $RPM_BUILD_ROOT%{product_dir}
61
62 %py_comp $RPM_BUILD_ROOT%{product_dir}
63 %py_ocomp $RPM_BUILD_ROOT%{product_dir}
64
65 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
66 rm -rf $RPM_BUILD_ROOT%{product_dir}/docs
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 if [ -f /var/lock/subsys/zope ]; then
73         /etc/rc.d/init.d/zope restart >&2
74 fi
75
76 %postun
77 if [ -f /var/lock/subsys/zope ]; then
78         /etc/rc.d/init.d/zope restart >&2
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc docs/*
84 %{product_dir}/ArchExample
85 %{product_dir}/ArchGenXML
86 %{product_dir}/Archetypes
87 %{product_dir}/generator
88 %{product_dir}/validation
This page took 0.076947 seconds and 4 git commands to generate.