]> git.pld-linux.org Git - packages/Zope-ZWiki.git/blob - Zope-ZWiki.spec
- cosmetics
[packages/Zope-ZWiki.git] / Zope-ZWiki.spec
1
2 # WARNING: This version make error connection refused on Zope 2.7.0b3!
3 #
4 %include        /usr/lib/rpm/macros.python
5 %define         zope_subname    ZWiki
6 Summary:        Zope product which allows you to build wiki webs in Zope
7 Summary(pl):    Produkt Zope umo¿liwiaj±cy budowanie stron WWW typu wiki
8 Name:           Zope-%{zope_subname}
9 %define         sub_ver rc2
10 Version:        0.25.0
11 Release:        1.%{sub_ver}.1
12 License:        GPL
13 Group:          Development/Tools
14 Source0:        http://zwiki.org/releases/%{zope_subname}-%{version}%{sub_ver}.tgz
15 # Source0-md5:  a1533c6d82c578a6cb19d9ca91d98dda
16 URL:            http://zwiki.org/FrontPage/
17 Requires(post,postun):  /usr/sbin/installzopeproduct
18 %pyrequires_eq  python-modules
19 Requires:       Zope
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ZWiki is a Zope product which allows you to build wiki webs in Zope.
25
26 %description -l pl
27 ZWiki to produkt Zope umo¿liwiaj±cy budowanie stron WWW typu wiki.
28
29 %prep
30 %setup -q -n %{zope_subname}
31
32 %build
33 mkdir docs
34 mv -f {CHANGES.txt,README.txt} docs
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
39 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
40
41 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
42 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
43
44 # find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
45 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 /usr/sbin/installzopeproduct %{_datadir}/%{name} %{zope_subname}
52 if [ -f /var/lock/subsys/zope ]; then
53         /etc/rc.d/init.d/zope restart >&2
54 fi
55
56 %postun
57 if [ "$1" = "0" ]; then
58         /usr/sbin/installzopeproduct -d %{zope_subname}
59         if [ -f /var/lock/subsys/zope ]; then
60                 /etc/rc.d/init.d/zope restart >&2
61         fi
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc docs/*
67 %{_datadir}/%{name}
This page took 0.032034 seconds and 4 git commands to generate.