]> git.pld-linux.org Git - packages/Zope-Formulator.git/blob - Zope-Formulator.spec
- pl translations, cosmetics
[packages/Zope-Formulator.git] / Zope-Formulator.spec
1
2 %define prod_name Formulator
3
4 Summary:        Zope framework that eases the creation and validation of web forms
5 Summary(pl):    Dodatek do Zope u³atwiaj±cy tworzenie i sprawdzanie poprawno¶ci formularzy WWW
6 Name:           Zope-%{prod_name}
7 Version:        1.0.1
8 Release:        1
9 License:        BSD-style
10 Group:          Development/Languages/Python
11 Group(de):      Entwicklung/Sprachen/Python
12 Group(pl):      Programowanie/Jêzyki/Python
13 Source0:        http://www.zope.org/Members/faassen/%{prod_name}/%{prod_name}-%{version}.tgz
14 URL:            http://www.zope.org/Members/faassen/%{prod_name}
15 Requires:       Zope
16 BuildRequires:  python >= 2.1
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
21 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
22
23 %define zope_dir           %{_libdir}/zope
24 %define zope_productsdir   %{zope_dir}/Products         
25
26 %description
27 %{prod_name} is a tool to help with the creation and validation of web                            
28 forms. Form fields are stored as objects in Zope, in a special Form folder.
29
30 %description -l pl
31 %{prod_name} jest narzêdziem pomagaj±cym przy tworzeniu i sprawdzaniu
32 poprawno¶ci formularzy WW. Pola formularza s± zapisywane jako obiekty
33 w Zope, w specjalnym folderze Form.
34
35 %prep
36 %setup -q -n %{prod_name}
37
38 %build
39 %{python_compile}
40 %{python_compile_opt}
41
42 find . -name \*.py | xargs -r rm -f
43 gzip -9nf *.txt
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
48
49 cp -a . $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
50 rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.gz
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc *.gz 
58 %{zope_productsdir}/%{prod_name}
This page took 0.065577 seconds and 4 git commands to generate.