]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
- upgraded to version 2.0RC4
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1
2 %include        /usr/lib/rpm/macros.python
3 %define         zope_subname    CMFPlone
4 Summary:        Free and open source Content Management System based on Zope and CMF
5 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
6 Name:           Zope-%{zope_subname}
7 Version:        2.0
8 %define         sub_ver RC4
9 Release:        5.%{sub_ver}.1
10 License:        Zope Public License (ZPL), GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
13 # Source0-md5:  a51e9d58c83911552c4620ab111a197a
14 URL:            http://www.plone.org/
15 %pyrequires_eq  python-modules
16 Requires:       Zope-CMF >= 1.4
17 Requires:       Zope >= 2.6.2
18 Requires:       Zope-BTreeFolder2
19 Requires:       Zope-CMFQuickInstallerTool
20 Requires:       Zope-ExternalEditor
21 Requires:       Zope-Formulator >= 1.6.1
22 Requires:       Zope-GroupUserFolder >= 2.0
23 Requires(post,postun):  /usr/sbin/installzopeproduct
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      Plone
27 Conflicts:      CMF
28
29 %description
30 Plone is a free, open source Content Management System. The focus of
31 Plone is to provide value at every level of an organization. It comes
32 with a workflow engine, pre-configured security and roles, a set of
33 content types and multi-lingual support. There are many developers,
34 writers and testers from all over the world, contributing to Plone
35 everyday. Plone is based on the Content Management Framework.
36
37 %description -l pl
38 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
39 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
40 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
41 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
42 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
43 Pythonem.
44
45 %prep
46 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
47 # remove dirs - additional packages!
48 # ExternalEditor
49 rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder}
50 find . -type d -name debian | xargs rm -rf
51
52 %build
53 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n docs/PlacelessTranslationService
54 mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
55 mv -f CMFPlone/docs/* docs/CMFPlone
56 mv -f CMFPlone/i18n/ChangeLog docs/i18n
57 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
58 rm -rf CMFPlone/LICENSE.GPL
59 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
60 rm -rf CMFPlone/docs
61 mv -f PlacelessTranslationService/{COPYING.txt,NEWS.txt} docs/PlacelessTranslationService
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
66 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
67
68 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
69 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
70
71 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService; do
78         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
79 done
80 if [ -f /var/lock/subsys/zope ]; then
81         /etc/rc.d/init.d/zope restart >&2
82 fi
83
84 %postun
85 if [ "$1" = "0" ]; then
86         for p in CMFPlone CMFActionIcons CMFFormController PlacelessTranslationService; do
87                 /usr/sbin/installzopeproduct -d $p
88         done
89         if [ -f /var/lock/subsys/zope ]; then
90                 /etc/rc.d/init.d/zope restart >&2
91         fi
92 fi
93
94 %files
95 %defattr(644,root,root,755)
96 %doc docs/*
97 %{_datadir}/%{name}
This page took 0.097164 seconds and 3 git commands to generate.