]> git.pld-linux.org Git - packages/X11-driver-firegl.git/blob - X11-driver-firegl.spec
- added using depmod macro
[packages/X11-driver-firegl.git] / X11-driver-firegl.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel
4 #
5 # TODO:
6 # - kernel modules (SMP)
7
8 Summary:        Linux Drivers for ATI graphics accelerators
9 Summary(pl):    Sterowniki do akceleratorów graficznych ATI
10 Name:           XFree86-driver-firegl
11 Version:        2.9.13
12 Release:        2
13 License:        ATI Binary
14 Vendor:         ATI
15 Group:          X11/XFree86
16 URL:            http://www.ati.com/support/drivers/linux/radeon-linux.html
17 #Source0:       http://pdownload.mii.instacontent.net/ati/drivers/fglrx-glc22-4.2.0-%{version}.i586.rpm
18 Source0:        http://www.schneider-digital.de/download/ati/glx1_linux_X4.3.zip
19 # Source0-md5:  a4bc85bb0f68e988abd2b5cd8cd9252f
20 Patch0:         firegl-panel.patch
21 BuildRequires:  cpio
22 %{!?_without_dist_kernel:BuildRequires:         kernel-headers >= 2.2.0 }
23 BuildRequires:  rpm-utils
24 BuildRequires:  rpmbuild(macros) >= 1.118
25 Requires:       XFree86-Xserver
26 Requires:       XFree86-libs >= 4.2.0
27 Requires:       XFree86-modules >= 4.2.0
28 Requires:       kernel-video-firegl = %{version}
29 Provides:       XFree86-OpenGL-core
30 Conflicts:      XFree86-OpenGL-devel <= 4.2.0-3
31 ExclusiveArch:  i586 i686 athlon
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33 Obsoletes:      Mesa
34 Obsoletes:      XFree86-OpenGL-core
35
36 %define         _noautoreqdep   libGL.so.1.2
37
38 %define         _prefix         /usr/X11R6
39 %define         _mandir         %{_prefix}/man
40
41 %description
42 Display driver files for the ATI Radeon 8500, 9700, Mobility M9 and
43 the FireGL 8700/8800, E1, Z1/X1 graphics accelerators. This package
44 provides 2D display drivers and hardware accelerated OpenGL.
45
46 %description -l pl
47 Sterowniki do kart graficznych ATI Radeon 8500, 9700, Mobility M9 oraz
48 graficznych akceleratorów FireGL 8700/8800, E1, Z1/X1. Pakiet
49 dostarcza sterowniki obs³uguj±ce wy¶wietlanie 2D oraz sprzêtowo
50 akcelerowany OpenGL.
51
52 %package -n kernel-video-firegl
53 Summary:        ATI kernel module for FireGL support
54 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
55 Release:        %{release}@%{_kernel_ver_str}
56 License:        ATI
57 Vendor:         ATI
58 Group:          Base/Kernel
59 %{!?_without_dist_kernel:%requires_releq_kernel_up}
60 PreReq:         modutils >= 2.3.18-2
61 Requires(post,postun):  /sbin/depmod
62
63 %description -n kernel-video-firegl
64 ATI kernel module for FireGL support.
65
66 %description -n kernel-video-firegl -l pl
67 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
68
69 %prep
70 %setup -q -c -T
71 unzip %{SOURCE0}
72 mv Xfree4.3/Xfree4.3.0_%{version}_2/* .
73 rpm2cpio fglrx-glc22-4.3.0-%{version}.i586.rpm | cpio -i -d
74 bzip2 -d -v usr/X11R6/bin/*.bz2
75 mkdir panel_src
76 tar -xzf usr/src/fglrx_panel_sources.tgz -C panel_src
77 %patch0 -p1
78
79 %build
80 cd lib/modules/fglrx/build_mod/
81 cp make.sh make.sh.org && rm -f make.sh
82 sed -e 's#gcc#%{kgcc}#g' -e 's#`id -u` -ne 0#`id -u` -ne `id -u`#g' make.sh.org > make.sh
83 chmod 755 make.sh
84 ./make.sh
85 cd ../../../../panel_src
86 %{__make} MK_QTDIR=/usr \
87         LIBQT_DYN=qt-mt
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/X11/extensions} \
92         $RPM_BUILD_ROOT{/lib/modules/%{_kernel_ver}/misc/,/usr/lib}
93
94 install lib/modules/fglrx/build_mod/fglrx.o             $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/
95
96 install usr/X11R6/bin/{fgl_glxgears,fglrxconfig,fglrxinfo} $RPM_BUILD_ROOT%{_bindir}
97 install panel_src/{fireglcontrol.qt3.gcc3.3,fireglcontrol} $RPM_BUILD_ROOT%{_bindir}
98 cp -r usr/X11R6/lib/* $RPM_BUILD_ROOT%{_libdir}/
99
100 cd $RPM_BUILD_ROOT%{_libdir}
101 ln -s libGL.so.* libGL.so
102 ln -s %{_libdir}/libGL.so $RPM_BUILD_ROOT/usr/lib/libGL.so
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %post   -n kernel-video-firegl
111 %depmod %{_kernel_ver}
112
113 %postun -n kernel-video-firegl
114 %depmod %{_kernel_ver}
115
116 %files
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/*
119 %attr(755,root,root) /usr/lib/lib*.so*
120 %attr(755,root,root) %{_libdir}/lib*.so*
121 %attr(755,root,root) %{_libdir}/modules/*/*.so
122 %attr(755,root,root) %{_libdir}/modules/*/*.o
123 %attr(644,root,root) %{_libdir}/modules/*/*.a
124
125 %files -n kernel-video-firegl
126 %defattr(644,root,root,755)
127 /lib/modules/%{_kernel_ver}/misc/*.o*
This page took 0.083039 seconds and 4 git commands to generate.