]> git.pld-linux.org Git - packages/SDL_net.git/blob - SDL_net.spec
- completly rewrited in PLD style.
[packages/SDL_net.git] / SDL_net.spec
1 Summary:        Simple DirectMedia Layer - network
2 Name:           SDL_net
3 Version:        1.1.1
4 Release:        1
5 License:        LGPL
6 Group:          Libraries
7 Source0:        http://www.libsdl.org/projects/SDL_net/src/%{name}-%{version}.tar.gz
8 URL:            http://www.devolution.com/~slouken/SDL/projects/SDL_net/
9 BuildRequires:  SDL-devel >= 1.0.1
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 This is an example portable network library for use with SDL. Note
14 that this isn't necessarily how you would want to write a chat
15 program, but it demonstrates how to use the basic features of the
16 network and GUI libraries.
17
18 %package devel
19 Summary:        Header files and more to develop SDL_net applications
20 Group:          Development/Libraries
21 Group(fr):      Development/Librairies
22 Group(pl):      Programowanie/Biblioteki
23 Requires:       %{name} = %{version}
24 Requires:       SDL-devel
25
26 %description devel
27 Header files and more to develop SDL_net applications.
28
29 %package static
30 Summary:        Statis SDL_net libraries
31 Group:          Development/Libraries
32 Group(fr):      Development/Librairies
33 Group(pl):      Programowanie/Biblioteki
34 Requires:       %{name}-devel = %{version}
35
36 %description static
37 Statis SDL_net libraries.
38
39 %prep
40 %setup -q 
41
42 %build
43 LDFLAGS="-s"; export LDFLAGS
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install DESTDIR=$RPM_BUILD_ROOT
51
52 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
53
54 gzip -9nf README
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post   -p /sbin/ldconfig
60 %postun -p /sbin/ldconfig
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README COPYING
65 %attr(755,root,root) %{_libdir}/lib*.so.*.*
66
67 %files devel
68 %defattr(644,root,root,755)
69 %doc *.gz
70 %attr(755,root,root) %{_libdir}/lib*.so
71 %attr(755,root,root) %{_libdir}/lib*.la
72 %{_includedir}/SDL/*
73
74 %files static
75 %defattr(644,root,root,755)
76 %{_libdir}/lib*.a
This page took 0.091699 seconds and 4 git commands to generate.