]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- pass --with-qt-libraries
[packages/QtCurve.git] / QtCurve.spec
1 #
2 # ToDo:
3 #  - include /usr/share/themes/QtCurve/mozilla somewhere
4 #
5 # Conditional build:
6 %bcond_with     gtk     # build GTK styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 #
9 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
10 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
11 Name:           QtCurve
12 Version:        0.38
13 Release:        1
14 License:        GPL
15 Group:          Themes
16 Source0:        http://www.cpdrummond.freeuk.com/%{name}-%{version}.tar.gz
17 # Source0-md5:  1e9145e20e2df5a1f572767d158f66d5
18 URL:            http://www.kde-look.org/content/show.php?content=40492
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_gtk:BuildRequires:      gtk+-devel}
22 %{?with_gtk2:BuildRequires:     gtk+2-devel}
23 BuildRequires:  kdelibs-devel >= 3.1
24 BuildRequires:  pkgconfig
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 A free and corrected port of Red Hat's GTK+/Qt theme.
29
30 %description -l pl
31 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
32
33 %package -n kde-style-QtCurve
34 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
35 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
36 Group:          Themes
37 Requires:       kdelibs >= 3.1
38
39 %description -n kde-style-QtCurve
40 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
41
42 %description -n kde-style-QtCurve -l pl
43 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
44 Wersja pod KDE.
45
46 %package -n gtk-theme-QtCurve
47 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
48 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
49 Group:          Themes
50 Requires:       theme-QtCurve-common = %{version}-%{release}
51
52 %description -n gtk-theme-QtCurve
53 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
54
55 %description -n gtk-theme-QtCurve -l pl
56 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
57 Wersja pod GTK+.
58
59 %package -n gtk2-theme-QtCurve
60 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
61 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
62 Group:          Themes
63 Requires:       theme-QtCurve-common = %{version}-%{release}
64
65 %description -n gtk2-theme-QtCurve
66 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
67
68 %description -n gtk2-theme-QtCurve -l pl
69 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
70 Wersja pod GTK+2.
71
72 %package -n theme-QtCurve-common
73 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
74 Summary(pl):    Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
75 Group:          Themes
76 Obsoletes:      theme-bluecurve-common
77 Obsoletes:      gtk2-theme-bluecurve
78 Obsoletes:      gtk-theme-bluecurve
79 Obsoletes:      kde-style-bluecurve
80 Obsoletes:      kde-theme-bluecurve
81
82 %description -n theme-QtCurve-common
83 A free and corrected port of Red Hat's GTK+/Qt theme.
84 Documentation and common files package.
85
86 %description -n theme-QtCurve-common -l pl
87 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
88 Pakiet z dokumentacja i plikami wspó³dzielonymi.
89
90 %prep
91 %setup -q
92
93 %build
94 cp /usr/share/automake/config.sub admin
95
96 %{__make} -f admin/Makefile.common cvs
97 %configure \
98         --with-qt-libraries=%{_libdir}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files -n kde-style-QtCurve
114 %defattr(644,root,root,755)
115 %{_libdir}/kde3/kstyle_qtcurve_config.la
116 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
117 %{_libdir}/kde3/plugins/styles/*.la
118 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
119 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
120 %{_datadir}/apps/qtcurve
121
122 %if %{with gtk}
123 %files -n gtk-theme-QtCurve
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
126 %{_datadir}/themes/QtCurve*/gtk
127 %endif
128
129 %if %{with gtk2}
130 %files -n gtk2-theme-QtCurve
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
133 %{_datadir}/themes/QtCurve*/gtk-2.0
134 %endif
135
136 %files -n theme-QtCurve-common
137 %defattr(644,root,root,755)
138 %doc ChangeLog README TODO
139 %dir %{_datadir}/themes/QtCurve*
This page took 0.037444 seconds and 4 git commands to generate.