]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- updated to 0.68.1
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 # - kde4
3 # - gtk1 no longer updated. drop after dropping last gtk+ 1.x app
4 #
5 # Conditional build:
6 %bcond_without  gtk     # don't build GTK+ styles
7 %bcond_without  gtk2    # don't build GTK+2 styles
8 %bcond_without  kde     # don't build KDE styles
9 #
10 %define         ver             0.68.1
11 %define         kde_ver         0.68.1
12 %define         gtk2_ver        0.68.1
13 %define         gtk1_ver        0.42.2
14 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
15 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16 Name:           QtCurve
17 Version:        %{ver}
18 Release:        1
19 License:        GPL
20 Group:          Themes
21 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22 # Source0-md5:  2451c8e624f8e07bfaf5584f4208c9d7
23 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24 # Source1-md5:  c7c2324e05aa09ecb26d1f9cc81a5e4a
25 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
27 Patch0:         %{name}-Gtk1-lib64.patch
28 URL:            http://www.kde-look.org/content/show.php?content=40492
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  cmake
32 %{?with_gtk:BuildRequires:      gtk+-devel}
33 %{?with_gtk2:BuildRequires:     gtk+2-devel}
34 %{?with_kde:BuildRequires:      kdelibs-devel >= 3.1}
35 BuildRequires:  libtool
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.293
38 BuildRequires:  sed > 4.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A free and corrected port of Red Hat's GTK+/Qt theme.
43
44 %description -l pl.UTF-8
45 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
46
47 %package -n kde-style-QtCurve
48 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
49 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
50 Version:        %{kde_ver}
51 Group:          Themes
52 Requires:       kdelibs >= 3.1
53
54 %description -n kde-style-QtCurve
55 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
56
57 %description -n kde-style-QtCurve -l pl.UTF-8
58 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
59 Wersja pod KDE.
60
61 %package -n gtk-theme-QtCurve
62 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
63 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
64 Version:        %{gtk1_ver}
65 Group:          Themes
66 Requires:       theme-QtCurve-common = %{ver}-%{release}
67
68 %description -n gtk-theme-QtCurve
69 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
70
71 %description -n gtk-theme-QtCurve -l pl.UTF-8
72 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
73 Wersja pod GTK+.
74
75 %package -n gtk2-theme-QtCurve
76 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
77 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
78 Version:        %{gtk2_ver}
79 Group:          Themes
80 Requires:       theme-QtCurve-common = %{ver}-%{release}
81
82 %description -n gtk2-theme-QtCurve
83 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
84
85 %description -n gtk2-theme-QtCurve -l pl.UTF-8
86 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
87 Wersja pod GTK+2.
88
89 %package -n theme-QtCurve-common
90 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
91 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
92 Version:        %{ver}
93 Group:          Themes
94 Obsoletes:      gtk-theme-bluecurve
95 Obsoletes:      gtk2-theme-bluecurve
96 Obsoletes:      kde-style-bluecurve
97 Obsoletes:      kde-theme-bluecurve
98 Obsoletes:      theme-bluecurve-common
99
100 %description -n theme-QtCurve-common
101 A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
102 and common files package.
103
104 %description -n theme-QtCurve-common -l pl.UTF-8
105 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
106 Pakiet z dokumentacja i plikami współdzielonymi.
107
108 %prep
109 %setup -q -c -D %{?with_kde:-a0} %{?with_gtk2:-a1} %{?with_gtk:-a2}
110
111 %if %{with gtk}
112 %if "%{_lib}" == "lib64"
113 cd %{name}-Gtk1-%{gtk1_ver}
114 %patch0 -p1
115 cd -
116 %endif
117 %endif
118
119
120 %build
121 %if %{with kde}
122 cd %{name}-KDE3-%{kde_ver}
123 %cmake \
124         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
125         .
126
127 %{__make}
128 cd -
129 %endif
130
131 %if %{with gtk}
132 cd %{name}-Gtk1-%{gtk1_ver}
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure
139 %{__make}
140 cd -
141 %endif
142
143 %if %{with gtk2}
144 cd %{name}-Gtk2-%{gtk2_ver}
145 %cmake \
146         -DQTC_ADD_EVENT_FILTER=true \
147         -DQTC_MODIFY_MOZILLA=true \
148         -DQTC_MODIFY_MOZILLA_USER_JS=true \
149         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
150         .
151
152 %{__make}
153 cd -
154 %endif
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 %if %{with kde}
160 %{__make} -C %{name}-KDE3-%{kde_ver} install \
161         DESTDIR=$RPM_BUILD_ROOT
162 %endif
163
164 %if %{with gtk}
165 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
166         DESTDIR=$RPM_BUILD_ROOT
167 %endif
168
169 %if %{with gtk2}
170 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
174 %endif
175
176 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %if %{with kde}
182 %files -n kde-style-QtCurve
183 %defattr(644,root,root,755)
184 %{_libdir}/kde3/kstyle_qtcurve_config.la
185 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
186 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
187 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
188 %{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
189 %{_datadir}/apps/QtCurve
190 %endif
191
192 %if %{with gtk}
193 %files -n gtk-theme-QtCurve
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
196 %{_datadir}/themes/QtCurve/gtk
197 %endif
198
199 %if %{with gtk2}
200 %files -n gtk2-theme-QtCurve
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
203 %dir %{_datadir}/themes/QtCurve/gtk-2.0
204 %{_datadir}/themes/QtCurve/gtk-2.0/gtkrc
205 %{_datadir}/themes/QtCurve/gtk-2.0/icons3
206 %{_datadir}/themes/QtCurve/gtk-2.0/icons4
207 %attr(755,root,root) %{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
208 %dir %{_datadir}/themes/QtCurve/mozilla
209 %{_datadir}/themes/QtCurve/mozilla/QtCurve.css
210 %{_datadir}/themes/QtCurve/mozilla/QtCurve-KDEButtonOrder.css
211 %{_datadir}/themes/QtCurve/mozilla/preferences-rev.xml
212 %endif
213
214 %files -n theme-QtCurve-common
215 %defattr(644,root,root,755)
216 %doc %{name}-KDE3-%{kde_ver}/ChangeLog
217 %doc %{name}-KDE3-%{kde_ver}/README
218 %doc %{name}-KDE3-%{kde_ver}/TODO
219 %dir %{_datadir}/themes/QtCurve
This page took 0.122665 seconds and 4 git commands to generate.