]> git.pld-linux.org Git - packages/QtCurve.git/blob - QtCurve.spec
- use shell constructs instead of subshells in mozilla mailto.sh wrapper
[packages/QtCurve.git] / QtCurve.spec
1 # TODO:
2 # - kde4
3 # - gtk1 no longer updated. drop?
4 # - include /usr/share/themes/QtCurve/mozilla somewhere
5 # - unpackaged:
6 #
7 # Conditional build:
8 %bcond_with     gtk     # build GTK styles
9 %bcond_without  gtk2    # don't build GTK+2 styles
10 #
11 %define         kde_ver         0.55.1
12 %define         gtk2_ver        0.55.1
13 %define         gtk1_ver        0.42.2
14 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
15 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16 Name:           QtCurve
17 Version:        0.55.1
18 Release:        1
19 License:        GPL
20 Group:          Themes
21 Source0:        http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22 # Source0-md5:  1ba394626a40e8926966739500dbf87d
23 Source1:        http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24 # Source1-md5:  0d5eeb45990c3ecf060daa68a2ed2e6f
25 Source2:        http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26 # Source2-md5:  8219f58493ca4e65a8fe61ee76eca522
27 Patch0:         %{name}-Gtk2-userjs.patch
28 Patch1:         %{name}-Gtk2-mailto.patch
29 URL:            http://www.kde-look.org/content/show.php?content=40492
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  cmake
33 %{?with_gtk:BuildRequires:      gtk+-devel}
34 %{?with_gtk2:BuildRequires:     gtk+2-devel}
35 BuildRequires:  kdelibs-devel >= 3.1
36 BuildRequires:  libtool
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 1.293
39 BuildRequires:  sed > 4.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 A free and corrected port of Red Hat's GTK+/Qt theme.
44
45 %description -l pl.UTF-8
46 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
47
48 %package -n kde-style-QtCurve
49 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
50 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
51 Group:          Themes
52 Requires:       kdelibs >= 3.1
53
54 %description -n kde-style-QtCurve
55 A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
56
57 %description -n kde-style-QtCurve -l pl.UTF-8
58 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
59 Wersja pod KDE.
60
61 %package -n gtk-theme-QtCurve
62 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
63 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
64 Group:          Themes
65 Requires:       theme-QtCurve-common = %{version}-%{release}
66
67 %description -n gtk-theme-QtCurve
68 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
69
70 %description -n gtk-theme-QtCurve -l pl.UTF-8
71 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
72 Wersja pod GTK+.
73
74 %package -n gtk2-theme-QtCurve
75 Summary:        A free and corrected port of Red Hat's GTK+/Qt theme
76 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
77 Group:          Themes
78 Requires:       theme-QtCurve-common = %{version}-%{release}
79
80 %description -n gtk2-theme-QtCurve
81 A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
82
83 %description -n gtk2-theme-QtCurve -l pl.UTF-8
84 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
85 Wersja pod GTK+2.
86
87 %package -n theme-QtCurve-common
88 Summary:        A free and corrected port of Redhats GTK+/Qt theme - common
89 Summary(pl.UTF-8):      Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
90 Group:          Themes
91 Obsoletes:      gtk-theme-bluecurve
92 Obsoletes:      gtk2-theme-bluecurve
93 Obsoletes:      kde-style-bluecurve
94 Obsoletes:      kde-theme-bluecurve
95 Obsoletes:      theme-bluecurve-common
96
97 %description -n theme-QtCurve-common
98 A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
99 and common files package.
100
101 %description -n theme-QtCurve-common -l pl.UTF-8
102 Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
103 Pakiet z dokumentacja i plikami współdzielonymi.
104
105 %prep
106 %setup -q -c %{?with_gtk2:-a1} %{?with_gtk:-a2}
107 %if %{with gtk2}
108 cd %{name}-Gtk2-%{gtk2_ver}
109 %patch0 -p1
110 %patch1 -p0
111 cd -
112 %endif
113
114 %build
115 cd %{name}-KDE3-%{kde_ver}
116 %cmake \
117         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
118         .
119 %{__make}
120 cd -
121
122 %if %{with gtk}
123 cd %{name}-Gtk1-%{gtk1_ver}
124 %{__libtoolize}
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure
130 %{__make}
131 cd -
132 %endif
133
134 %if %{with gtk2}
135 cd %{name}-Gtk2-%{gtk2_ver}
136 %cmake \
137         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
138         .
139 %{__make}
140 cd -
141 %endif
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} -C %{name}-KDE3-%{kde_ver} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %if %{with gtk}
150 %{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
151         DESTDIR=$RPM_BUILD_ROOT
152 %endif
153
154 %if %{with gtk2}
155 %{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
156         DESTDIR=$RPM_BUILD_ROOT
157 %endif
158
159 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %files -n kde-style-QtCurve
165 %defattr(644,root,root,755)
166 %{_libdir}/kde3/kstyle_qtcurve_config.la
167 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
168 #%{_libdir}/kde3/plugins/styles/*.la
169 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
170 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
171 %{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
172 %{_datadir}/apps/QtCurve
173
174 %if %{with gtk}
175 %files -n gtk-theme-QtCurve
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
178 %{_datadir}/themes/QtCurve/gtk
179 %endif
180
181 %if %{with gtk2}
182 %files -n gtk2-theme-QtCurve
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
185 %{_datadir}/themes/QtCurve/gtk-2.0
186 %{_datadir}/themes/QtCurve/mozilla
187 %endif
188
189 %files -n theme-QtCurve-common
190 %defattr(644,root,root,755)
191 %doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
192 %dir %{_datadir}/themes/QtCurve
This page took 0.059838 seconds and 4 git commands to generate.