]> git.pld-linux.org Git - packages/OpenThreads.git/blob - OpenThreads.spec
- spaces -> tabs
[packages/OpenThreads.git] / OpenThreads.spec
1 %define         devel   3
2 Summary:        A minimal & complete Object-Oriented (OO) thread interface
3 Summary(pl):    Minimalny ale kompletny interfejs w±tków w programowaniu OO
4 Name:           OpenThreads
5 Version:        1.2
6 Release:        0.%{devel}.2
7 License:        LGPL
8 Group:          Libraries
9 # version from OSG_OP_OT-0.9.6-2.tar.gz needed to build new OpenSceneGraph
10 # Source0:      http://dl.sourceforge.net/openthreads/%{name}-v%{version}dev%{devel}-osg0.9.5.tar.gz
11 Source0:        OpenThreads-v%{version}dev%{devel}.tar.gz
12 # Source0-md5:  0a1c190e358459aa4a2f1018dc397be5
13 Patch0:         %{name}-soname.patch
14 URL:            http://openthreads.sourceforge.net/
15 BuildRequires:  libstdc++-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This library is intended to provide a minimal & complete
20 Object-Oriented (OO) thread interface for C++ programmers. It is
21 loosely modeled on the Java thread API, and the POSIX Threads
22 standards.
23
24 %description -l pl
25 Biblioteka jest przeznaczona do udostêpniania minimalnego ale pe³nego
26 interfejsu obiektowo zorientowanych (OO) w±tków dla programistów C++.
27 Bazuje na modelu API w±tków w Javie oraz na standardzie w±tków POSIX.
28
29 %package devel
30 Summary:        OpenThreads devel files
31 Summary(pl):    Biblioteki programistyczne OpenThreads
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libstdc++-devel
35
36 %description devel
37 OpenThreads devel files.
38
39 %description devel -l pl
40 Biblioteki programistyczne OpenThreads.
41
42 %prep
43 %setup -q -n %{name}
44 %patch0 -p0
45
46 %build
47 %{__make} \
48         CXX="%{__cxx} %{rpmcflags} -fPIC"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         INST_LOCATION=$RPM_BUILD_ROOT%{_prefix}
55 if [ "%{_libdir}" == "%{_prefix}/lib64" ]; then
56         mv $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
57 fi
58 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_libdir}/lib%{name}.so.*.*
69
70 %files devel
71 %defattr(644,root,root,755)
72 %doc AUTHORS.txt ChangeLog README.txt TODO.txt
73 %attr(755,root,root) %{_libdir}/lib%{name}.so
74 %{_includedir}/%{name}
This page took 0.073416 seconds and 4 git commands to generate.