]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- call automake too
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  alsa    # without ALSA support
5 %bcond_with     arts    # with aRts support
6 %bcond_without  esd     # without esd support
7 %bcond_without  mmx     # don't use MMX
8 #
9 %ifnarch %{ix86} %{x8664}
10 %undefine       with_mmx
11 %endif
12 %ifarch i386 i486
13 %undefine       with_mmx
14 %endif
15 Summary:        Open Audio Library
16 Summary(pl):    Otwarta Biblioteka D¼wiêku
17 Name:           OpenAL
18 Version:        0.0.8
19 Release:        1
20 License:        LGPL
21 Group:          Libraries
22 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
23 # Source0-md5:  641cf53761f35ee979f3e888614797a0
24 URL:            http://www.openal.org/
25 BuildRequires:  SDL-devel
26 %{?with_alsa:BuildRequires:     alsa-lib-devel}
27 %{?with_arts:BuildRequires:     artsc-devel}
28 BuildRequires:  autoconf >= 2.56
29 BuildRequires:  automake
30 %{?with_esd:BuildRequires:      esound-devel}
31 %if %{with mmx}
32 # MMX code triggers ICE in gcc 3.3.x
33 BuildRequires:  gcc >= 5:3.4.0
34 %endif
35 BuildRequires:  libtool
36 BuildRequires:  libvorbis-devel
37 %ifarch %{ix86}
38 %{?with_mmx:BuildRequires:      nasm}
39 %endif
40 BuildRequires:  pkgconfig
41 BuildRequires:  smpeg-devel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %if %{with mmx}
45 %define         specflags_ia32  -mmmx
46 %else
47 %define         specflags_ia32  -U__MMX__
48 %endif
49
50 %description
51 OpenAL, the Open Audio Library, is a joint effort to create an open,
52 vendor-neutral, cross-platform API for interactive, primarily
53 spatialized audio. OpenAL's primary audience are application
54 developers and desktop users that rely on portable standards like
55 OpenGL, for games and other multimedia applications. OpenAL is already
56 supported by a number of hardware vendors and developers.
57
58 %description -l pl
59 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
60 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
61 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
62 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
63 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
64 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
65 dostarczycieli sprzêtu i programistów.
66
67 %package devel
68 Summary:        Headers for OpenAL
69 Summary(pl):    Pliki nag³ówkowe do OpenAL
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description devel
74 Header files for OpenAL-based programs.
75
76 %description devel -l pl
77 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
78 OpenAL.
79
80 %package static
81 Summary:        OpenAL static library
82 Summary(pl):    Statyczna biblioteka OpenAL
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 OpenAL static library.
88
89 %description static -l pl
90 Biblioteka OpenAL do konsolidacji statycznej.
91
92 %prep
93 %setup -q -n openal-%{version}
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I admin/autotools/m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
103         --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
104         --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
105         --enable-sdl --enable-sdl-dlopen \
106         --enable-capture \
107         --enable-linux \
108         --enable-null \
109 %ifarch amd64 x86_64 athlon i686 i586
110         --enable-optim-generic \
111 %endif
112         --enable-waveout \
113         --enable-vorbis --enable-vorbis-dlopen \
114         --enable-mp3 --enable-mp3-dlopen \
115         --with-gcc="%{__cc}"
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc ChangeLog NOTES TODO
134 %attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc common/specification/OpenAL1-1Spec.pdf
139 %attr(755,root,root) %{_bindir}/openal-config
140 %attr(755,root,root) %{_libdir}/libopenal.so
141 %{_libdir}/libopenal.la
142 %{_includedir}/AL
143 %{_pkgconfigdir}/openal.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libopenal.a
This page took 0.072861 seconds and 4 git commands to generate.