]> git.pld-linux.org Git - packages/GLM.git/blob - GLM.spec
- pl
[packages/GLM.git] / GLM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 %bcond_with     p7zip           # plain p7zip (compatible with both rpm4/rpm5)
5 #
6 Summary:        OpenGL Mathematics (GLM) - C++ mathematics library for GLSL
7 Summary(pl.UTF-8):      OpenGL Mathematics (GLM) - biblioteka matematyczna C++ dla GLSL
8 Name:           GLM
9 Version:        0.9.4.4
10 Release:        1
11 License:        MIT
12 Group:          Development/Libraries
13 Source0:        http://downloads.sourceforge.net/ogl-math/glm-%{version}.7z
14 # Source0-md5:  1c5a626c025dff9664b08d8f39c7e11b
15 URL:            http://glm.g-truc.net/
16 BuildRequires:  cmake
17 %if %{with p7zip}
18 BuildRequires:  p7zip
19 %else
20 BuildRequires:  p7zip-standalone
21 BuildRequires:  rpm-build >= 5
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 OpenGL Mathematics (GLM) is a C++ mathematics library for graphics
27 software based on the OpenGL Shading Language (GLSL) specification.
28
29 GLM is a header only library, there is nothing to build,
30 just include it.
31
32 %description -l pl.UTF-8
33 OpenGL Mathematics (GLM) to biblioteka matematyczna C++ dla programów
34 graficznych opartych na specyfikacji OpenGL Shading Language (GLSL).
35
36 %prep
37 %if %{with p7zip}
38 %setup -q -c -T -n glm-%{version}
39 7z x %{SOURCE0} -o..
40 %else
41 %setup -q -n glm-%{version}
42 %endif
43
44 %build
45 mkdir build
46 cd build
47 %cmake .. \
48         -DGLM_TEST_ENABLE:BOOL=%{!?with_tests:OFF}%{?with_tests:ON}
49
50 %{?with_tests:%{__make}}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 #install -d $RPM_BUILD_ROOT
55
56 %{__make} -C build install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc readme.txt doc/glm.pdf
65 %attr(755,root,root) %{_includedir}/glm
This page took 0.027561 seconds and 4 git commands to generate.