]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
- added header "Conditional build:"
[packages/GConf2.git] / GConf2.spec
1 # Conditional build:
2 %bcond_without  static_libs     # don't build static libraries
3 #
4 Summary:        GNOME2 configuration database system
5 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
6 Summary(pt_BR): Sistema de Configuração do GNOME 2
7 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
8 Name:           GConf2
9 Version:        2.10.0
10 Release:        5
11 License:        LGPL
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.10/GConf-%{version}.tar.bz2
14 # Source0-md5:  a7cd37be4e317195a6668a086fc72033
15 Patch0:         %{name}-NO_MAJOR_VERSION.patch
16 Patch1:         %{name}-path.patch
17 Patch2:         %{name}-shutdown.patch
18 URL:            http://www.gnome.org/
19 BuildRequires:  ORBit2-devel >= 1:2.12.1
20 BuildRequires:  autoconf
21 BuildRequires:  automake >= 1:1.7
22 BuildRequires:  gettext-devel
23 BuildRequires:  gtk+2-devel >= 2:2.6.4
24 BuildRequires:  gtk-doc >= 1.3
25 BuildRequires:  libtool
26 BuildRequires:  libxml2-devel >= 1:2.6.19
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig
29 BuildRequires:  popt-devel
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 Obsoletes:      libGConf2
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GConf2 is a configuration database system, functionally similar to the
36 Windows registry but lots better. :-) It's being written for the
37 GNOME2 desktop but does not require GNOME2; configure should notice if
38 GNOME2 is not installed and compile the basic GConf2 library anyway.
39
40 %description -l pl
41 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
42 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
43 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
44 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
45
46 %description -l pt_BR
47 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
48
49 %package devel
50 Summary:        GConf2 includes, etc
51 Summary(pl):    Pliki nag³ówkowe GConf2
52 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
53 Group:          X11/Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       ORBit2-devel >= 1:2.12.1
56 Requires:       gtk-doc-common
57 Requires:       libxml2-devel >= 1:2.6.19
58 Obsoletes:      libGConf2-devel
59
60 %description devel
61 GConf2 includes etc.
62
63 %description devel -l pl
64 Pliki nag³ówkowe GConf2.
65
66 %description devel -l pt_BR
67 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
68
69 %package static
70 Summary:        GConf2 static libraries
71 Summary(pl):    Biblioteki statyczne GConf2
72 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
73 Group:          X11/Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 GConf2 static libraries.
78
79 %description static -l pl
80 Biblioteki statyczne GConf2.
81
82 %description static -l pt_BR
83 Bibliotecas estáticas para desenvolvimento com gconf
84
85 %prep
86 %setup -q -n GConf-%{version}
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 %build
92 rm -f acinclude.m4
93 %{__glib_gettextize}
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoheader}
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         --with-html-dir=%{_gtkdocdir} \
101         %{!?with_static_libs:--disable-static} \
102 %ifarch ppc
103         --disable-gtk-doc
104 %else
105         --enable-gtk-doc
106 %endif
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
118
119 %find_lang %{name}
120
121 # no *.{la,a} for modules - shut up check-files
122 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS NEWS README
133 %attr(755,root,root) %{_bindir}/gconf*
134 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
135 %attr(755,root,root) %{_libdir}/gconfd-2
136 %attr(755,root,root) %{_libdir}/lib*.so.*.*
137 %dir %{_libdir}/GConf2
138 %attr(755,root,root) %{_libdir}/GConf2/lib*.so
139 %{_sysconfdir}/gconf
140 %{_datadir}/sgml/gconf
141 %{_mandir}/man1/*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %doc ChangeLog TODO
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %{_libdir}/lib*.la
148 %{_includedir}/gconf2
149 %{_aclocaldir}/*.m4
150 %{_pkgconfigdir}/*.pc
151 %{_gtkdocdir}/gconf
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/lib*.a
157 %endif
This page took 0.073773 seconds and 4 git commands to generate.