]> git.pld-linux.org Git - packages/GConf2.git/blob - GConf2.spec
- due to new rpm it requires /etc/X11/xinitrc.d provided by xinitrc-ng
[packages/GConf2.git] / GConf2.spec
1 #
2 # TODO:
3 # - update documentation to follow changes introduced in Patch0
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNOME2 configuration database system
9 Summary(pl):    System konfiguracyjnej bazy danych dla GNOME 2
10 Summary(pt_BR): Sistema de Configuração do GNOME 2
11 Summary(ru):    óÉÓÔÅÍÁ ËÏÎÆÉÇÕÒÁÃÉÉ GNOME 2
12 Name:           GConf2
13 Version:        2.14.0
14 Release:        5
15 License:        LGPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/GConf/2.14/GConf-%{version}.tar.bz2
18 # Source0-md5:  d07c2efcaf477cf34225c604a04b6271
19 Source1:        %{name}-merge-tree.xinit
20 Patch0:         %{name}-NO_MAJOR_VERSION.patch
21 Patch1:         %{name}-path.patch
22 URL:            http://www.gnome.org/
23 BuildRequires:  ORBit2-devel >= 1:2.14.0
24 BuildRequires:  autoconf
25 BuildRequires:  automake >= 1:1.7
26 BuildRequires:  gettext-devel
27 BuildRequires:  glib2-devel >= 1:2.11.2
28 BuildRequires:  gtk+2-devel >= 2:2.9.2
29 BuildRequires:  gtk-doc >= 1.4-2
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel >= 1:2.6.25
32 BuildRequires:  openldap-devel
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  popt-devel
36 BuildRequires:  rpmbuild(macros) >= 1.197
37 Requires:       ORBit2 >= 1:2.14.0
38 Requires:       glib2 >= 1:2.11.2
39 Requires:       xinitrc-ng
40 Obsoletes:      libGConf2
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GConf2 is a configuration database system, functionally similar to the
45 Windows registry but lots better. :-) It's being written for the
46 GNOME2 desktop but does not require GNOME2; configure should notice if
47 GNOME2 is not installed and compile the basic GConf2 library anyway.
48
49 %description -l pl
50 GConf2 jest systemem konfiguracyjnej bazy danych, funkcjonalnie
51 podobnej do rejestru Windows, ale o wiele lepszej :-). Jest pisana dla
52 desktopu GNOME2, ale nie wymaga GNOME2; skrypt configure powinien
53 wykryæ brak GNOME2 i skompilowaæ tylko wersjê podstawow± GConf2.
54
55 %description -l pt_BR
56 Gconf2 é o sistema de banco de dados de configuração do GNOME2.
57
58 %package devel
59 Summary:        GConf2 includes, etc
60 Summary(pl):    Pliki nag³ówkowe GConf2
61 Summary(pt_BR): Sistema de Configuração do GNOME2 - arquivos para desenvolvimento
62 Group:          X11/Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       ORBit2-devel >= 1:2.14.0
65 Requires:       gtk-doc-common
66 Requires:       libxml2-devel >= 1:2.6.25
67 Obsoletes:      libGConf2-devel
68
69 %description devel
70 GConf2 includes etc.
71
72 %description devel -l pl
73 Pliki nag³ówkowe GConf2.
74
75 %description devel -l pt_BR
76 Sistema de Configuração do GNOME2 - arquivos para desenvolvimento.
77
78 %package static
79 Summary:        GConf2 static libraries
80 Summary(pl):    Biblioteki statyczne GConf2
81 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com gconf2
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 GConf2 static libraries.
87
88 %description static -l pl
89 Biblioteki statyczne GConf2.
90
91 %description static -l pt_BR
92 Bibliotecas estáticas para desenvolvimento com gconf
93
94 %package backend-evoldap
95 Summary:        Evolution Data Sources LDAP backend for GConf
96 Summary(pl):    Backend LDAP ¼róde³ danych Evolution dla GConfa
97 Group:          Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description backend-evoldap
101 This is a special-purpose backend for GConf which enables default mail
102 accounts, addressbooks and calendars for Evolution to be configured
103 using each user's LDAP entry. By setting each user's mail address,
104 incoming/outgoing mail server addresses and addressbook/calendar
105 addresses in the user's LDAP entry, Evolution will be automatically
106 configured to use these addresses.
107
108 %description backend-evoldap -l pl
109 To jest backend GConfa specjalnego przeznaczenia, pozwalaj±cy na
110 konfigurowanie domy¶lnych kont pocztowych, ksi±¿ek adresowych i
111 kalendarzy dla Evolution przy u¿yciu wpisu LDAP dla ka¿dego
112 u¿ytkownika. Poprzez ustawienie ka¿demu u¿ytkownikowi adres pocztowy,
113 adresy serwerów poczty przychodz±cej/wychodz±cej oraz adresy ksi±¿ki
114 adresowej i kalendarza w jego wpisie LDAP, Evolution zostanie
115 automatycznie skonfigurowane do u¿ywania tych adresów.
116
117 %prep
118 %setup -q -n GConf-%{version}
119 %patch0 -p1
120 %patch1 -p1
121
122 %build
123 %{__gtkdocize}
124 %{__glib_gettextize}
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoheader}
128 %{__autoconf}
129 %{__automake}
130 %configure \
131         %{!?with_static_libs:--disable-static} \
132         --enable-gtk-doc \
133         --with-html-dir=%{_gtkdocdir}
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT%{_sysconfdir}{/gconf/schemas,/X11/xinit/xinitrc.d}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/GConf2-merge-tree
145
146 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
147
148 %find_lang %{name}
149
150 # no *.{la,a} for modules - shut up check-files
151 rm -f $RPM_BUILD_ROOT%{_libdir}/GConf2/lib*.{la,a}
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS NEWS README
162 %attr(755,root,root) %{_bindir}/gconf*
163 %attr(755,root,root) %{_libdir}/gconf-sanity-check-2
164 %attr(755,root,root) %{_libdir}/gconfd-2
165 %attr(755,root,root) %{_libdir}/lib*.so.*.*
166 %dir %{_libdir}/GConf2
167 %attr(755,root,root) %{_libdir}/GConf2/libgconfbackend-oldxml.so
168 %attr(755,root,root) %{_libdir}/GConf2/libgconfbackend-xml.so
169 %dir %{_sysconfdir}/gconf
170 %dir %{_sysconfdir}/gconf/2
171 %{_sysconfdir}/gconf/gconf.xml.*
172 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gconf/path
173 %dir %{_sysconfdir}/gconf/schemas
174 %attr(755,root,root) %{_sysconfdir}/X11/xinit/xinitrc.d/*
175 %dir %{_datadir}/GConf
176 %dir %{_datadir}/GConf/schema
177 %{_datadir}/sgml/gconf
178 %{_mandir}/man1/*
179
180 %files devel
181 %defattr(644,root,root,755)
182 %doc ChangeLog TODO
183 %attr(755,root,root) %{_libdir}/lib*.so
184 %{_libdir}/lib*.la
185 %{_includedir}/gconf2
186 %{_aclocaldir}/*.m4
187 %{_pkgconfigdir}/*.pc
188 %{_gtkdocdir}/gconf
189
190 %if %{with static_libs}
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/lib*.a
194 %endif
195
196 %files backend-evoldap
197 %defattr(644,root,root,755)
198 %doc backends/README.evoldap
199 %attr(755,root,root) %{_libdir}/GConf2/libgconfbackend-evoldap.so
200 %{_datadir}/GConf/schema/evoldap.schema
201 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gconf/2/evoldap.conf
This page took 0.034276 seconds and 3 git commands to generate.