]> git.pld-linux.org Git - packages/Frodo.git/blob - Frodo.spec
- gcc3 patch with C++ fixes
[packages/Frodo.git] / Frodo.spec
1 Summary:        Commodore 64 emulator
2 Summary(pl):    Emulator Commodore 64
3 Name:           Frodo
4 Version:        4.1a
5 Release:        4
6 License:        non-commercial
7 Group:          Applications/Emulators
8 Source0:        http://iphcip1.physik.uni-mainz.de/~cbauer/%{name}V4_1a.Src.tar.gz
9 Patch0:         %{name}-16+bpp.patch
10 Patch1:         %{name}-TkGui.patch
11 Patch2:         %{name}-paths.patch
12 Patch3:         %{name}-opt.patch
13 Patch4:         %{name}-joy.patch
14 Patch5:         %{name}-gcc3.patch
15 URL:            http://www.uni-mainz.de/~bauec002/FRMain.html
16 BuildRequires:  XFree86-devel
17 BuildRequires:  autoconf
18 BuildRequires:  libstdc++-devel
19 Requires:       tk
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _prefix         /usr/X11R6
23 %define         _mandir         %{_prefix}/man
24
25 %description
26 Frodo V4.1 is a free, portable C64 emulator for BeOS, Unix, MacOS,
27 AmigaOS, RiscOS and WinNT/95 systems.
28
29 This emulator focuses on the exact reproduction of special graphical
30 effects possible on the C64, and has therefore relatively high system
31 requirements. It should only be run on systems with at least a
32 PowerPC/Pentium/68060. Frodo is capable of running most games and
33 demos correctly, even those with FLI, FLD, DYCP, open borders,
34 multiplexed sprites, timing dependent decoders, fast loaders etc. 6510
35 emulation: All undocumented opcodes, 100 percent correct decimal mode,
36 instruction/cycle exact emulation. VIC emulation: Line-/cycle-based
37 emulation, all display modes, sprites with collisions/priorities, DMA
38 cycles, open borders, all $d011/$d016 effects. SID emulation:
39 Real-time digital emulation (16 bit, 44.1kHz), including filters (only
40 under BeOS, Linux, HP-UX, MacOS and AmigaOS). 1541 emulation: Drive
41 simulation in directories, .d64/x64 or .t64/LYNX files, or
42 processor-level 1541 emulation that works with about 95 percent of all
43 fast loaders and even some copy protection schemes. Other peripherals:
44 Keyboard and joystick (real joysticks (only under BeOS, Linux and
45 AmigaOS) or keyboard emulation). The full source code in C++ is
46 available. Frodo is freeware.
47
48 %description -l pl
49 Frodo jest darmowym, przeno¶nym emulatorem C64 dla BeOS, uniksów,
50 MacOS, AmigaOS, RiscOS i WinNT/Win9x.
51
52 Ten emulator skupia siê na dok³adnym odtworzeniu specjalnych efektów
53 graficznych osi±galnych na C64, wiêc ma dosyæ du¿e wymagania dotycz±ce
54 systemu. Powinien byæ uruchamiany tylko na systemach z co najmniej
55 PowerPC/Pentium/68060. Frodo jest w stanie uruchomiæ poprawnie
56 wiêkszo¶æ gier i dem, nawet te z FLI, FLD, DYCP, otwartymi ramkami,
57 zamienianymi duszkami, dekoderami zale¿nymi od czasu, szybkimi
58 loaderami itp. Emulacja 6510: wszystkie nieudokumentowane instrukcje,
59 w pe³ni poprawny tryb dziesiêtny, dok³adna emulacja liczby cykli dla
60 instrukcji. Emulacja VIC: bazuj±ca na liniach lub cyklach, wszystkie
61 tryby wy¶wietlania, duszki z kolizjami i priorytetami, cykle DMA,
62 otwarte ramki, wszystkie efekty $d011/$d016. Emulacja SID: emulacja
63 cyfrowa w czasie rzeczywistym (16 bitów. 44.1kHz), w³±cznie z filtrami
64 (tylko pod BeOS-em, Linuksem, HP-UX-em, MacOS-em i AmigaOS-em).
65 Emulacja 1541: symulacja dysków w katalogach, plikach .d64/x64 albo
66 .t64/LYNX, lub emulacja 1541 na poziomie procesora, obs³uguj±ca oko³o
67 95%% wszystkich szybkich loaderów i nawet niektóre rodzaje
68 zabezpieczeñ przed kopiowaniem. Inne peryferia: klawiatura i joystick
69 (prawdziwe joysticki (tylko pod BeOS-em, Linuksem i AmigaOS-em) lub
70 emulacja na klawiaturze). Dostêpne s± pe³ne ¼ród³a w C++. Frodo jest
71 freeware.
72
73 %prep
74 %setup -q -n Frodo
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78 %patch3 -p1
79 %patch4 -p1
80 %patch5 -p1
81
82 %build
83 cd Src
84 %{__autoconf}
85 CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
86 CFLAGS="$CFLAGS -DX_USE_SHM -fno-exceptions -fno-rtti -fno-implicit-templates"
87 %configure
88 %{__make} all FRODOHOME="\\\"%{_libdir}/Frodo/\\\""
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_libdir}/Frodo/{64prgs,64imgs},%{_bindir}}
93
94 install Src/Frodo Src/FrodoPC Src/FrodoSC $RPM_BUILD_ROOT%{_bindir}
95 install TkGui.tcl "Frodo Logo" $RPM_BUILD_ROOT%{_libdir}/Frodo
96 install "1541 ROM" "Basic ROM" "Char ROM" "Kernal ROM" $RPM_BUILD_ROOT%{_libdir}/Frodo
97 install 64prgs/* $RPM_BUILD_ROOT%{_libdir}/Frodo/64prgs
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(644,root,root,755)
104 %doc CHANGES Docs/*
105 %attr(755,root,root) %{_bindir}/*
106 %{_libdir}/Frodo
This page took 0.063829 seconds and 4 git commands to generate.