]> git.pld-linux.org Git - packages/CodeEditor.git/blob - CodeEditor.spec
620801e492e8f29bcff7f8d65997a0cf8f079e09
[packages/CodeEditor.git] / CodeEditor.spec
1 Summary:        Code Editor for Objective C
2 Name:           CodeEditor
3 Version:        0.4.1
4 Release:        1
5 License:        GPL
6 Group:          X11/Applications
7 Source0:        http://savannah.nongnu.org/download/codeeditor/CodeEditor.pkg/0.4.1/CodeEditor-0.4.1.tar.gz
8 # Source0-md5:  4906152cd85fe0bd8b61ae1b17db9323
9 URL:            http://www.nongnu.org/codeeditor/
10 BuildRequires:  gnustep-gui-devel >= 0.8.7
11 Requires:       gnustep-gui >= 0.8.7
12 Requires: %{name}-libs = %{version}
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _prefix         /usr/lib/GNUstep
16
17 %define         libcombo        gnu-gnu-gnu
18 %define         gsos            linux-gnu
19 %ifarch %{ix86}
20 %define         gscpu           ix86
21 %else
22 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
23 %define         gscpu           %{_target_cpu}
24 %endif
25
26 %description
27 This is CodeEditor, a simple image viewer application for GNUstep.
28
29 %description -l pl
30 To jest CodeEditor - prosta przegl±darka obrazków dla ¶rodowiska
31 GNUstep.
32
33 %package libs
34 Summary: CodeEditorView bundle
35 Group: Development/Tools
36
37 %description libs
38 CodeEditorView bundle for embedding CodeEditor in other apps
39
40 %package devel
41 Summary: CodeEditorView bundle headers
42 Group: Development/Tools
43
44 %description devel
45 CodeEditorView bundle headers
46
47 %prep
48 %setup -q -n codeeditor
49
50 %build
51 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
52 %{__make} \
53         OPTFLAG="%{rpmcflags}" \
54         messages=yes
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
59
60 %{__make} install \
61         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README TODO
69 %dir %{_prefix}/System/Applications/CodeEditor.app
70 %attr(755,root,root) %{_prefix}/System/Applications/CodeEditor.app/CodeEditor
71 %dir %{_prefix}/System/Applications/CodeEditor.app/Resources
72 %{_prefix}/System/Applications/CodeEditor.app/Resources/*.desktop
73 %{_prefix}/System/Applications/CodeEditor.app/Resources/*.plist
74 %{_prefix}/System/Applications/CodeEditor.app/Resources/*.tiff
75 %{_prefix}/System/Applications/CodeEditor.app/Resources/*.gorm
76 %{_prefix}/System/Applications/CodeEditor.app/Resources/Scripts
77 %dir %{_prefix}/System/Applications/CodeEditor.app/%{gscpu}
78 %dir %{_prefix}/System/Applications/CodeEditor.app/%{gscpu}/%{gsos}
79 %dir %{_prefix}/System/Applications/CodeEditor.app/%{gscpu}/%{gsos}/%{libcombo}
80 %attr(755,root,root) %{_prefix}/System/Applications/CodeEditor.app/%{gscpu}/%{gsos}/%{libcombo}/CodeEditor
81 %{_prefix}/System/Applications/CodeEditor.app/%{gscpu}/%{gsos}/%{libcombo}/*.openapp
82
83 %files libs
84 %dir %{_prefix}/System/Library/ApplicationSupport/CodeEditorView/ObjCHandler.bundle
85 %{_prefix}/System/Library/ApplicationSupport/CodeEditorView/ObjCHandler.bundle/Resources/*.plist
86 %{_prefix}/System/Library/ApplicationSupport/CodeEditorView/ObjCHandler.bundle/%{gscpu}/%{gsos}/%{libcombo}/ObjCHandler
87
88 %files devel
89 %{_prefix}/System/Library/Headers/CodeEditorView/*.h
This page took 0.09222 seconds and 3 git commands to generate.