]> git.pld-linux.org Git - packages/brltty.git/blame_incremental - brltty.spec
- icu rebuild
[packages/brltty.git] / brltty.spec
... / ...
CommitLineData
1# TODO:
2# - what is that huge %post script?
3#
4# Conditional build:
5%bcond_without apidocs # documentation generated with doxygen
6%bcond_without java # Java bindings
7%bcond_without ocaml # OCaml bindings
8%bcond_without python # Python bindings
9%bcond_without python3 # Python 3.x bindings
10%bcond_without tcl # Tcl bindings
11%bcond_without x # X11-based utilities
12%bcond_without gpm # mouse tracking via GPM
13%bcond_without libbraille # libbraille Braille driver
14%bcond_without espeak # eSpeak synthesizer driver
15%bcond_without flite # Flite synthesizer driver
16%bcond_with mikropuhe # Mikropuhe synthesizer driver [commercial, Finnish]
17%bcond_without speech_dispatcher # Speech Dispatcher synthesizer driver
18%bcond_with swift # Swift synthesizer driver [commercial, from Cepstral]
19%bcond_with theta # Theta synthesizer driver [commercial, from Cepstral]
20%bcond_with viavoice # IBM ViaVoice synthesizer driver [commercial]
21%bcond_with at_spi # AtSpi screen driver
22%bcond_without at_spi2 # AtSpi2 screen driver
23#
24%define brlapi_ver 0.6.3
25#
26%include /usr/lib/rpm/macros.java
27Summary: Braille display driver for Linux/Unix
28Summary(pl.UTF-8): Sterownik do wyświetlaczy Braille'a
29Name: brltty
30Version: 5.2
31Release: 4
32Group: Daemons
33License: GPL v2+ (brltty and drivers), LGPL v2.1+ (APIs)
34Source0: http://mielke.cc/brltty/archive/%{name}-%{version}.tar.xz
35# Source0-md5: b484343461b5a45f95fedfb21d1ceca3
36Patch0: %{name}-java.patch
37Patch1: %{name}-speech-dispatcher.patch
38Patch2: %{name}-python.patch
39URL: http://mielke.cc/brltty/
40BuildRequires: alsa-lib-devel
41%{?with_at_spi:BuildRequires: at-spi-devel}
42BuildRequires: autoconf >= 2.62
43BuildRequires: automake
44BuildRequires: bison
45# just headers
46BuildRequires: bluez-libs-devel
47%{?with_at_spi2:BuildRequires: dbus-devel >= 1.0}
48%{?with_apidocs:BuildRequires: doxygen}
49%{?with_espeak:BuildRequires: espeak-devel}
50%{?with_flite:BuildRequires: flite-devel}
51%{?with_gpm:BuildRequires: gpm-devel}
52%{?with_java:BuildRequires: jdk}
53%{?with_java:BuildRequires: jpackage-utils}
54%{?with_libbraille:BuildRequires: libbraille-devel}
55BuildRequires: libicu-devel
56BuildRequires: ncurses-devel
57%{?with_ocaml:BuildRequires: ocaml}
58BuildRequires: pkgconfig
59%{?with_python:BuildRequires: python-Cython}
60%{?with_python3:BuildRequires: python3-Cython}
61%{?with_java:BuildRequires: rpm-javaprov}
62%{?with_python:BuildRequires: rpm-pythonprov}
63%{?with_speech_dispatcher:BuildRequires: speech-dispatcher-devel >= 0.8}
64BuildRequires: tar >= 1:1.22
65%{?with_tcl:BuildRequires: tcl-devel >= 8.5}
66%if %{with x}
67BuildRequires: xorg-lib-libX11-devel
68BuildRequires: xorg-lib-libXaw-devel
69BuildRequires: xorg-lib-libXext-devel
70BuildRequires: xorg-lib-libXt-devel
71BuildRequires: xorg-lib-libXtst-devel
72%endif
73BuildRequires: xz
74#%{?with_mikropuhe:BuildRequires: Mikropuhe-devel (-lmikropuhe <mpwrfile.h>)}
75#%{?with_swift:BuildRequires: Swift-devel (-lswift <swift.h>)}
76#%{?with_theta:BuildRequires: Theta-devel (-ltheta <theta.h>)}
77#%{?with_viavoice:BuildRequires: ViaVoice-devel (-libmeci50 <eci.h>)}
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80%description
81BRLTTY is a background process (daemon) which provides access to the
82Linux/Unix console (when in text mode) for a blind person using a
83refreshable Braille display. It drives the Braille display, and
84provides complete screen review functionality. Some speech capability
85has also been incorporated.
86
87%description -l pl.UTF-8
88BRLTTY jest demonem, który udostępnia dostęp do linuksowej konsoli (w
89trybie tekstowym) dla niewidomych używających wyświetlaczy Braille'a z
90odświeżaniem (refreshable Braille display). BRLTTY steruje
91wyświetlaczem Braille'a i dostarcza funkcjonalność całkowitego
92przeglądu ekranu. Do tego pakietu została włączona możliwość syntezy
93mowy.
94
95%package -n brlapi
96Summary: Application Programming Interface for BRLTTY
97Summary(pl.UTF-8): API do BRLTTY
98License: LGPL v2.1+
99Group: Libraries
100
101%description -n brlapi
102This package provides the run-time support for the Application
103Programming Interface to BRLTTY.
104
105Install this package if you have an application which directly
106accesses a refreshable Braille display.
107
108%description -n brlapi -l pl.UTF-8
109Ten pakiet zawiera środowisko uruchomieniowe dla programów
110korzystających z API BRLTTY.
111
112Zainstaluj ten pakiet jeśli masz aplikację, która bezpośrednio używa
113wyświetlacza Braille'a z odświeżaniem.
114
115%package -n brlapi-devel
116Summary: Headers and documentation for BrlAPI
117Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do BrlAPI
118License: LGPL v2.1+
119Group: Development/Libraries
120Requires: brlapi = %{version}-%{release}
121
122%description -n brlapi-devel
123This package provides the header files, shared object linker
124reference, and reference documentation for BrlAPI (the Application
125Programming Interface to BRLTTY). It enables the implementation of
126applications which take direct advantage of a refreshable Braille
127display in order to present information in ways which are more
128appropriate for blind users and/or to provide user interfaces which
129are more specifically atuned to their needs.
130
131Install this package if you're developing or maintaining an
132application which directly accesses a refreshable Braille display.
133
134%description -n brlapi-devel -l pl.UTF-8
135Ten pakiet zawiera pliki nagłówkowe oraz dokumentację do BrlAPI (API
136do BRLTTY). BrlAPI pozwala implementować aplikacje, które bezpośrednio
137korzystają z wyświetlaczy Braille'a dostarczając interfejs użytkownika
138bardziej przystosowany dla osób niewidomych.
139
140Zainstaluj ten pakiet, jeśli tworzysz lub nadzorujesz aplikację
141korzystającą bezpośrednio z odświeżalnych wyświetlaczy Braille'a.
142
143%package -n brlapi-static
144Summary: Static BrlAPI library
145Summary(pl.UTF-8): Statyczna biblioteka BrlAPI
146License: LGPL v2.1+
147Group: Development/Libraries
148Requires: brlapi-devel = %{version}-%{release}
149
150%description -n brlapi-static
151This is package with static BrlAPI library.
152
153%description -n brlapi-static -l pl.UTF-8
154Ten pakiet zawiera statyczną wersję biblioteki BrlAPI.
155
156%package -n brlapi-apidocs
157Summary: BrlAPI documentation
158Summary(pl.UTF-8): Documentacja BrlAPI
159Group: Documentation
160
161%description -n brlapi-apidocs
162Documentation for BrlAPI in HTML format generated from brltty
163sources by doxygen.
164
165%description -n brlapi-apidocs -l pl.UTF-8
166Dokumentacja BrlAPI w formacie HTML generowane ze
167źrodeł brltty przez doxygen.
168
169%package -n java-brlapi
170Summary: BrlAPI library for Java
171Summary(pl.UTF-8): Biblioteka BrlAPI dla Javy
172License: LGPL v2.1+
173Group: Libraries
174Requires: brlapi = %{version}-%{release}
175
176%description -n java-brlapi
177BrlAPI library for Java.
178
179%description -n java-brlapi -l pl.UTF-8
180Biblioteka BrlAPI dla Javy.
181
182%package -n ocaml-brlapi
183Summary: OCaml binding for BrlAPI
184Summary(pl.UTF-8): Wiązania OCamla do BrlAPI
185License: LGPL v2.1+
186Group: Libraries
187Requires: brlapi = %{version}-%{release}
188%requires_eq ocaml-runtime
189
190%description -n ocaml-brlapi
191OCaml binding for BrlAPI.
192
193%description -n ocaml-brlapi -l pl.UTF-8
194Wiązania OCamla do BrlAPI.
195
196%package -n ocaml-brlapi-devel
197Summary: OCaml binding for BrlAPI - development files
198Summary(pl.UTF-8): Wiązania OCamla do BrlAPI - pliki programistyczne
199License: LGPL v2.1+
200Group: Libraries
201Requires: ocaml-brlapi = %{version}-%{release}
202%requires_eq ocaml
203
204%description -n ocaml-brlapi-devel
205OCaml binding for BrlAPI - development files.
206
207%description -n ocaml-brlapi-devel -l pl.UTF-8
208Wiązania OCamla do BrlAPI - pliki programistyczne.
209
210%package -n python-brlapi
211Summary: Python 2.x interface to BrlAPI
212Summary(pl.UTF-8): Interfejs Pythona 2.x do BrlAPI
213License: LGPL v2.1+
214Group: Libraries
215Requires: brlapi = %{version}-%{release}
216
217%description -n python-brlapi
218Python 2.x interface to BrlAPI.
219
220%description -n python-brlapi -l pl.UTF-8
221Interfejs Pythona 2.x do BrlAPI.
222
223%package -n python3-brlapi
224Summary: Python 3.x interface to BrlAPI
225Summary(pl.UTF-8): Interfejs Pythona 3.x do BrlAPI
226License: LGPL v2.1+
227Group: Libraries
228Requires: brlapi = %{version}-%{release}
229
230%description -n python3-brlapi
231Python 3.x interface to BrlAPI.
232
233%description -n python3-brlapi -l pl.UTF-8
234Interfejs Pythona 3.x do BrlAPI.
235
236%package -n brlapi-tcl
237Summary: BrlAPI library for Tcl
238Summary(pl.UTF-8): Biblioteka BrlAPI dla Tcl
239License: LGPL v2.1+
240Group: Libraries
241Requires: brlapi = %{version}-%{release}
242
243%description -n brlapi-tcl
244BrlAPI library for Tcl.
245
246%description -n brlapi-tcl -l pl.UTF-8
247Biblioteka BrlAPI dla Tcl.
248
249%prep
250%setup -q
251%patch0 -p1
252%patch1 -p1
253%patch2 -p1
254
255%build
256%{__autoconf}
257CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
258%configure \
259 %{?with_java:JAVA_HOME=%{java_home}} \
260 --with-install-root="$RPM_BUILD_ROOT" \
261 %{!?with_libbraille:--without-libbraille} \
262 %{!?with_espeak:--without-espeak} \
263 %{!?with_flite:--without-flite} \
264 %{!?with_speech_dispatcher:--without-speechd} \
265 %{!?with_ocaml:--disable-caml-bindings} \
266 %{!?with_gpm:--disable-gpm} \
267 %{!?with_java:--disable-java-bindings} \
268 %{!?with_python:--disable-python-bindings} \
269 %{!?with_tcl:--disable-tcl-bindings} \
270 %{!?with_x:--disable-x} \
271 --enable-api
272
273%{__make} -j1
274
275%if %{with python3}
276cd Bindings/Python
277%{__python3} setup.py build \
278 -b build-3
279cd ../..
280%endif
281
282directory="doc"
283mkdir -p "$directory"
284for file in `find . \( -path "./$directory" -o -path ./Documents \) -prune -o \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o -name '*.sgml' -o \( -path "./Bootdisks/*" -type f -perm +ugo=x \) \) -print`
285do
286 mkdir -p "$directory/${file%/*}"
287 cp -rp "$file" "$directory/$file"
288done
289
290%install
291rm -rf $RPM_BUILD_ROOT
292
293%{__make} -j1 install \
294 OCAML_INSTALL_TARGET=install-without-findlib
295
296%if %{with python3}
297cd Bindings/Python
298%{__python3} setup.py \
299 build \
300 -b build-3 \
301 install \
302 --optimize=2 \
303 --skip-build \
304 --root=$RPM_BUILD_ROOT
305cd ../..
306%endif
307
308%if %{_lib} != "lib"
309 # Fix java plugin install path on 64-bit archs
310 install -d $RPM_BUILD_ROOT%{_libdir}/java
311 %{__mv} $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}/java/libbrlapi_java.so
312%endif
313
314install Documents/brltty.conf $RPM_BUILD_ROOT%{_sysconfdir}
315
316install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
317cat >$RPM_BUILD_ROOT/usr/lib/tmpfiles.d/brltty.conf <<EOF
318d /var/run/brltty 0755 root root -
319EOF
320
321# no sign in source wheter it is zh_CN or zh_TW so just remove it
322%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh
323
324%find_lang %{name}
325
326%clean
327rm -rf $RPM_BUILD_ROOT
328
329%pre
330# The pre-install scriptlet.
331
332# If a configuration file already exists then rpm installs the new one as
333# <path>.rpmnew. If this is done then the .rpmnew file is overwritten if it
334# already exists.
335
336# There's no explicit way to tell if a configuration file has been installed
337# as itself or as a .rpmnew file. The way we'll figure it out, therefore, is by
338# erasing the .rpmnew file now so that we can see if it gets created later.
339rm -f "%{_sysconfdir}/brltty.conf.rpmnew"
340
341%post
342# The post-install scriptlet.
343
344# If BRLTTY's boot parameter has been specified then update the just installed
345# configuration file template to reflect the options supplied thereby.
346
347# First, we need to determine which file to update. If there's a .rpmnew file
348# then update it since a previous configuration file must already have existed.
349file="%{_sysconfdir}/brltty.conf"
350new="${file}.rpmnew"
351[ -f "${new}" ] && file="${new}"
352
353# Update the configuration file template via the Bootdisks/bp2cf script.
354# Include it right within this scriptlet so that it needn't be installed.
355# Imbed it within a subshell to ensure that it won't impact this scriptlet.
356(
357 # First, set bp2cf's command line arguments.
358 set -- -u -f "${file}"
359
360#!/bin/sh
361###############################################################################
362# BRLTTY - A background process providing access to the Linux console (when in
363# text mode) for a blind person using a refreshable Braille display.
364#
365# Copyright (C) 1995-2003 by The BRLTTY Team. All rights reserved.
366#
367# BRLTTY comes with ABSOLUTELY NO WARRANTY.
368#
369# This is free software, placed under the terms of the
370# GNU General Public License, as published by the Free Software
371# Foundation. Please see the file COPYING for details.
372#
373# Web Page: http://mielke.cc/brltty/
374#
375# This software is maintained by Dave Mielke <dave@mielke.cc>.
376###############################################################################
377
378# Convert the boot parameter to configuration file directives.
379# If /proc is mounted then use the brltty= boot parameter in /proc/cmdline.
380# If /proc is not mounted then use the brltty environment variable.
381# Invoke with -h for usage information.
382
383programName="${0##*/}"
384programMessage()
385{
386 echo 2>&1 "${programName}: ${1}"
387}
388syntaxError()
389{
390 programMessage "${1}"
391 exit 2
392}
393internalError()
394{
395 programMessage "${1}"
396 exit 3
397}
398
399configurationFile=""
400requestedAction=create
401deviceTranslation=none
402requestedParameter=""
403OPTIND=1
404while getopts ":f:cundop:h" option
405do
406 case "${option}" in
407 f) configurationFile="${OPTARG}";;
408 c) requestedAction=create;;
409 u) requestedAction=update;;
410 n) deviceTranslation=none;;
411 d) deviceTranslation=devfs;;
412 o) deviceTranslation=old;;
413 p) requestedParameter="${OPTARG}";;
414 h)
415 cat <<EOF
416Usage: ${programName} [option ...]
417-f file The configuration file to create/update.
418-c Create the configuration file (write to stdout if no -f).
419-u Update the configuration file (copying from stdin to stdout if no -f).
420-n Do not translate device paths.
421-d Do old-style to devfs device path translation.
422-o Do devfs to old-style device path translation.
423-p [driver][,[device][,[table]]]
424 Explicitly specify the boot parameter.
425-h Display this usage summary.
426EOF
427 exit 0
428 ;;
429 \?) syntaxError "unknown option: -${OPTARG}";;
430 :) syntaxError "missing value: -${OPTARG}";;
431 *) internalError "unimplemented option: -${option}";;
432 esac
433done
434shift "`expr $OPTIND - 1`"
435[ "${#}" -eq 0 ] || syntaxError "too many parameters."
436
437case "${requestedAction}" in
438 create)
439 putConfigurationLine()
440 {
441 echo "${1}" || exit 4
442 }
443 startConfigurationFile()
444 {
445 [ -n "${configurationFile}" ] && exec >"${configurationFile}"
446 putConfigurationLine "`makeHeaderLine Created`"
447 putConfigurationLine "`makeParameterLine`"
448 putConfigurationLine ""
449 }
450 putConfigurationDirective()
451 {
452 putConfigurationLine "${1} ${2}"
453 }
454 finalizeConfigurationFile()
455 {
456 :
457 }
458 ;;
459 update)
460 putSedCommand()
461 {
462 sedScript="${sedScript}
463${1}"
464 }
465 startConfigurationFile()
466 {
467 if [ -n "${configurationFile}" ]; then
468 [ -e "${configurationFile}" ] || syntaxError "file not found: ${configurationFile}"
469 [ -f "${configurationFile}" ] || syntaxError "not a file: ${configurationFile}"
470 [ -r "${configurationFile}" ] || syntaxError "file not readable: ${configurationFile}"
471 [ -w "${configurationFile}" ] || syntaxError "file not writable: ${configurationFile}"
472 outputFile="${configurationFile}.new"
473 exec <"${configurationFile}" >"${outputFile}"
474 fi
475 sedScript=""
476 putSedCommand "1i\\
477`makeHeaderLine Updated`\\
478`makeParameterLine`\\
479"
480 }
481 putConfigurationDirective()
482 {
483 value="`echo "${2}" | sed -e 's%\\([/\\]\\)%\\\\\\1%g'`"
484 putSedCommand "/^ *#\\(${1} .*\\)/s//\\1/"
485 putSedCommand "/^ *\\(${1}\\) .*/s//\\1 ${value}/"
486 }
487 finalizeConfigurationFile()
488 {
489 sed -e "${sedScript}"
490 [ -n "${outputFile}" ] && mv -f "${outputFile}" "${configurationFile}"
491 }
492 ;;
493 *) internalError "unimplemented action: ${requestedAction}";;
494esac
495
496translateDevice_none()
497{
498 :
499}
500translateDevice_devfs()
501{
502 minor="${device#ttyS}"
503 if [ "${minor}" != "${device}" ]; then
504 device="tts/${minor}"
505 return 0
506 fi
507 minor="${device#lp}"
508 if [ "${minor}" != "${device}" ]; then
509 device="printers/${minor}"
510 return 0
511 fi
512 programMessage "unsupported old-style device: ${device}"
513}
514translateDevice_old()
515{
516 major="${device%%/*}"
517 if [ "${major}" != "${device}" ]; then
518 minor="${device#*/}"
519 case "${major}" in
520 tts) devfs="ttyS${minor}";;
521 printers) devfs="lp${minor}";;
522 esac
523 fi
524 if [ -n "${devfs}" ]; then
525 device="${devfs}"
526 else
527 programMessage "unsupported devfs device: ${device}"
528 fi
529}
530
531makeHeaderLine()
532{
533 echo "# ${1} by brltty-bp2cf`date +' on %Y-%m-%d at %H:%M:%S %Z (UTC%z)'`."
534}
535makeParameterLine()
536{
537 echo "# Boot Parameter:${bootParameter}"
538}
539putConfigurationFile()
540{
541 startConfigurationFile
542 [ -n "${brailleDriver}" ] && putConfigurationDirective "braille-driver" "${brailleDriver}"
543 [ -n "${brailleDevice}" ] && {
544 device="`echo "${brailleDevice}" | sed -e 's%//*%/%g' -e 's%^/dev/%%'`"
545 if [ "${device#/}" = "${device}" ]; then
546 translateDevice_${deviceTranslation}
547 fi
548 putConfigurationDirective "braille-device" "${device}"
549 }
550 [ -n "${textTable}" ] && putConfigurationDirective "text-table" "${textTable}"
551 finalizeConfigurationFile
552}
553parseBootParameter()
554{
555 bootParameter="${bootParameter} ${1}"
556 number=1
557 while [ "${number}" -le 3 ]; do
558 cut="cut -d, -f${number}"
559 [ "${number}" -gt 1 ] && cut="${cut} -s"
560 operand="`echo ${1} | ${cut}`"
561 if [ -n "${operand}" ]; then
562 case "${number}" in
563 1) brailleDriver="${operand}";;
564 2) brailleDevice="${operand}";;
565 3) textTable="${operand}";;
566 esac
567 fi
568 number="`expr ${number} + 1`"
569 done
570}
571putBootParameter()
572{
573 parseBootParameter "${1}"
574 putConfigurationFile
575}
576parseBootCommand()
577{
578 found=false
579 while [ "${#}" -gt 0 ]; do
580 case "${1}" in
581 "brltty="*)
582 found=true
583 parseBootParameter "${1#*=}"
584 ;;
585 esac
586 shift
587 done
588 "${found}" && putConfigurationFile
589}
590
591brailleDriver=""
592brailleDevice=""
593textTable=""
594bootCommandFile="/proc/cmdline"
595if [ -n "${requestedParameter}" ]; then
596 putBootParameter "${requestedParameter}"
597elif [ -f "${bootCommandFile}" ]; then
598 parseBootCommand `cat "${bootCommandFile}"`
599elif [ -n "${brltty}" ]; then
600 putBootParameter "${brltty}"
601fi
602exit 0
603)
604
605%post -n brlapi -p /sbin/ldconfig
606%postun -n brlapi -p /sbin/ldconfig
607
608%files -f %{name}.lang
609%defattr(644,root,root,755)
610%doc Documents/{Manual-BRLTTY/English/BRLTTY*,ChangeLog,HISTORY,TODO}
611%doc doc/{Bindings,Bootdisks,Drivers,Patches,Tables,README}
612%attr(755,root,root) %{_bindir}/brltty
613%attr(755,root,root) %{_bindir}/brltty-config
614%attr(755,root,root) %{_bindir}/brltty-ctb
615%attr(755,root,root) %{_bindir}/brltty-trtxt
616%attr(755,root,root) %{_bindir}/brltty-ttb
617%attr(755,root,root) %{_bindir}/eutp
618%attr(755,root,root) %{_bindir}/vstp
619%{?with_x:%attr(755,root,root) %{_bindir}/xbrlapi}
620%dir %{_libdir}/brltty
621# Braille drivers
622%attr(755,root,root) %{_libdir}/brltty/libbrlttybal.so
623%attr(755,root,root) %{_libdir}/brltty/libbrlttybat.so
624%attr(755,root,root) %{_libdir}/brltty/libbrlttybba.so
625%attr(755,root,root) %{_libdir}/brltty/libbrlttybbc.so
626%attr(755,root,root) %{_libdir}/brltty/libbrlttybbd.so
627%attr(755,root,root) %{_libdir}/brltty/libbrlttybbl.so
628%attr(755,root,root) %{_libdir}/brltty/libbrlttybbm.so
629%attr(755,root,root) %{_libdir}/brltty/libbrlttybbn.so
630%attr(755,root,root) %{_libdir}/brltty/libbrlttybcb.so
631%attr(755,root,root) %{_libdir}/brltty/libbrlttybce.so
632%attr(755,root,root) %{_libdir}/brltty/libbrlttybec.so
633%attr(755,root,root) %{_libdir}/brltty/libbrlttybeu.so
634%attr(755,root,root) %{_libdir}/brltty/libbrlttybfs.so
635%attr(755,root,root) %{_libdir}/brltty/libbrlttybhd.so
636%attr(755,root,root) %{_libdir}/brltty/libbrlttybhm.so
637%attr(755,root,root) %{_libdir}/brltty/libbrlttybht.so
638%attr(755,root,root) %{_libdir}/brltty/libbrlttybhw.so
639%attr(755,root,root) %{_libdir}/brltty/libbrlttybir.so
640%{?with_libbraille:%attr(755,root,root) %{_libdir}/brltty/libbrlttyblb.so}
641%attr(755,root,root) %{_libdir}/brltty/libbrlttyblt.so
642%attr(755,root,root) %{_libdir}/brltty/libbrlttybmb.so
643%attr(755,root,root) %{_libdir}/brltty/libbrlttybmd.so
644%attr(755,root,root) %{_libdir}/brltty/libbrlttybmm.so
645%attr(755,root,root) %{_libdir}/brltty/libbrlttybmn.so
646%attr(755,root,root) %{_libdir}/brltty/libbrlttybmt.so
647%attr(755,root,root) %{_libdir}/brltty/libbrlttybnp.so
648%attr(755,root,root) %{_libdir}/brltty/libbrlttybpg.so
649%attr(755,root,root) %{_libdir}/brltty/libbrlttybpm.so
650%attr(755,root,root) %{_libdir}/brltty/libbrlttybsk.so
651%attr(755,root,root) %{_libdir}/brltty/libbrlttybtn.so
652%attr(755,root,root) %{_libdir}/brltty/libbrlttybts.so
653%attr(755,root,root) %{_libdir}/brltty/libbrlttybtt.so
654%attr(755,root,root) %{_libdir}/brltty/libbrlttybvd.so
655%attr(755,root,root) %{_libdir}/brltty/libbrlttybvo.so
656%attr(755,root,root) %{_libdir}/brltty/libbrlttybvr.so
657%attr(755,root,root) %{_libdir}/brltty/libbrlttybvs.so
658%{?with_x:%attr(755,root,root) %{_libdir}/brltty/libbrlttybxw.so}
659# speech synthesizer drivers
660%attr(755,root,root) %{_libdir}/brltty/libbrlttysal.so
661%attr(755,root,root) %{_libdir}/brltty/libbrlttysbl.so
662%attr(755,root,root) %{_libdir}/brltty/libbrlttyscb.so
663%{?with_espeak:%attr(755,root,root) %{_libdir}/brltty/libbrlttyses.so}
664%{?with_flite:%attr(755,root,root) %{_libdir}/brltty/libbrlttysfl.so}
665%attr(755,root,root) %{_libdir}/brltty/libbrlttysfv.so
666%attr(755,root,root) %{_libdir}/brltty/libbrlttysgs.so
667%{?with_mikropuhe:%attr(755,root,root) %{_libdir}/brltty/libbrlttysmp.so}
668%{?with_speech_dispatcher:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssd.so}
669%{?with_swift:%attr(755,root,root) %{_libdir}/brltty/libbrlttyssw.so}
670%{?with_theta:%attr(755,root,root) %{_libdir}/brltty/libbrlttysth.so}
671%{?with_viavoice:%attr(755,root,root) %{_libdir}/brltty/libbrlttysvv.so}
672%attr(755,root,root) %{_libdir}/brltty/libbrlttysxs.so
673# screen drivers
674%{?with_at_spi2:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxa2.so}
675%{?with_at_spi:%attr(755,root,root) %{_libdir}/brltty/libbrlttyxas.so}
676%attr(755,root,root) %{_libdir}/brltty/libbrlttyxlx.so
677%attr(755,root,root) %{_libdir}/brltty/libbrlttyxsc.so
678%{_sysconfdir}/brltty
679%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/brltty.conf
680/usr/lib/tmpfiles.d/brltty.conf
681%dir /var/lib/BrlAPI
682%dir /var/run/brltty
683%{_mandir}/man1/brltty.1*
684%{_mandir}/man1/eutp.1*
685%{_mandir}/man1/vstp.1*
686%{?with_x:%{_mandir}/man1/xbrlapi.1*}
687
688%if %{with x}
689# gdm autostart - subpackage?
690#%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
691%endif
692
693%files -n brlapi
694%defattr(644,root,root,755)
695%attr(755,root,root) %{_libdir}/libbrlapi.so.*.*.*
696%attr(755,root,root) %ghost %{_libdir}/libbrlapi.so.0.6
697
698%files -n brlapi-devel
699%defattr(644,root,root,755)
700%doc Documents/Manual-BrlAPI/English/BrlAPI*
701%attr(755,root,root) %{_libdir}/libbrlapi.so
702%{_includedir}/brltty
703%{_includedir}/brlapi*.h
704%{_mandir}/man3/brlapi_*.3*
705
706%files -n brlapi-static
707%defattr(644,root,root,755)
708%{_libdir}/libbrlapi.a
709
710%if %{with apidocs}
711%files -n brlapi-apidocs
712%defattr(644,root,root,755)
713%doc Documents/BrlAPIref/html/*
714%endif
715
716%if %{with java}
717%files -n java-brlapi
718%defattr(644,root,root,755)
719%attr(755,root,root) %{_libdir}/java/libbrlapi_java.so
720%{_javadir}/brlapi.jar
721%endif
722
723%if %{with ocaml}
724%files -n ocaml-brlapi
725%defattr(644,root,root,755)
726%attr(755,root,root) %{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so
727%{_libdir}/ocaml/stublibs/dllbrlapi_stubs.so.owner
728
729%files -n ocaml-brlapi-devel
730%defattr(644,root,root,755)
731%dir %{_libdir}/ocaml/brlapi
732%{_libdir}/ocaml/brlapi/META
733%{_libdir}/ocaml/brlapi/brlapi.cm[aix]*
734%{_libdir}/ocaml/brlapi/brlapi.mli
735%{_libdir}/ocaml/brlapi/libbrlapi_stubs.a
736%endif
737
738%if %{with python}
739%files -n python-brlapi
740%defattr(644,root,root,755)
741%attr(755,root,root) %{py_sitedir}/brlapi.so
742%{py_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
743
744%if %{with python3}
745%files -n python3-brlapi
746%defattr(644,root,root,755)
747%attr(755,root,root) %{py3_sitedir}/brlapi.cpython-*.so
748%{py3_sitedir}/Brlapi-%{brlapi_ver}-py*.egg-info
749%endif
750%endif
751
752%if %{with tcl}
753%files -n brlapi-tcl
754%defattr(644,root,root,755)
755%dir %{_libdir}/brlapi-%{brlapi_ver}
756%attr(755,root,root) %{_libdir}/brlapi-%{brlapi_ver}/libbrlapi_tcl.so
757%{_libdir}/brlapi-%{brlapi_ver}/pkgIndex.tcl
758%endif
This page took 0.056216 seconds and 4 git commands to generate.