]> git.pld-linux.org Git - packages/beagle.git/blame_incremental - beagle.spec
- updated for 0.2.16.3
[packages/beagle.git] / beagle.spec
... / ...
CommitLineData
1#
2# TODO:
3# - kill bashisms in crawl stuff
4# - mozilla extension?
5#
6%include /usr/lib/rpm/macros.mono
7#
8# Conditional build:
9%bcond_without apidocs # don't build API documentation
10%bcond_without evolution # don't include evolution support
11%bcond_without galago # build without galago support
12%bcond_without gsf # build without libgsf support
13%bcond_without gui # don't build GNOME based GUI
14%bcond_without python # don't build python libraries
15%bcond_without epiphany # don't build epiphany extension
16%bcond_with sqlite3 # use sqlite3 instead of sqlite2
17%bcond_with thunderbird # use Thunderbird backend
18#
19%if !%{with gui}
20%undefine with_evolution
21%endif
22#
23Summary: Beagle - An indexing subsystem
24Summary(pl.UTF-8): Beagle - podsystem indeksujący
25Name: beagle
26Version: 0.2.16.2
27Release: 1
28License: Various
29Group: Libraries
30Source0: http://ftp.gnome.org/pub/gnome/sources/beagle/0.2/%{name}-%{version}.tar.bz2
31# Source0-md5: 4cff44be5917bfce5f1c265039a60626
32Patch0: %{name}-desktop.patch
33Patch1: %{name}-crawl.patch
34Patch2: %{name}-kill_exec_a.patch
35Patch3: %{name}-configure.patch
36Patch4: %{name}-epiphany-2.18.patch
37URL: http://beagle-project.org/Main_Page
38BuildRequires: autoconf >= 2.52
39BuildRequires: automake
40BuildRequires: chmlib-devel
41%{?with_evolution:BuildRequires: dotnet-evolution-sharp-devel >= 0.11.1}
42%{?with_galago:BuildRequires: dotnet-galago-sharp-devel >= 0.5.0}
43BuildRequires: dotnet-gmime-sharp-devel >= 2.2.3
44%{?with_gsf:BuildRequires: dotnet-gsf-sharp-devel >= 0.8.1}
45#BuildRequires: dotnet-gst-sharp-devel
46BuildRequires: dotnet-gtk-sharp2-devel >= 2.10.0
47%if %{with epiphany}
48BuildRequires: epiphany-devel >= 2.18.0
49%endif
50BuildRequires: gtk+2-devel >= 2:2.10.10
51%{?with_apidocs:BuildRequires: gtk-doc >= 1.8}
52BuildRequires: libexif-devel >= 0.6.13
53BuildRequires: librsvg-devel >= 1:2.16.1
54BuildRequires: libpng-devel
55BuildRequires: libtool
56BuildRequires: libxml2-devel >= 1:2.6.27
57BuildRequires: mono-csharp >= 1.1.13.5
58%{?with_python:BuildRequires: python-pygtk-devel >= 2:2.10.4}
59BuildRequires: pkgconfig
60BuildRequires: perl-XML-Parser
61BuildRequires: python-devel
62%if %{with sqlite3}
63BuildRequires: sqlite3-devel >= 3.3.4
64%else
65BuildRequires: sqlite-devel
66%endif
67BuildRequires: wv-devel >= 1.2.4
68BuildRequires: xorg-lib-libXScrnSaver-devel
69BuildRequires: zip
70# GUI BRs
71%if %{with gui}
72BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
73BuildRequires: gnome-vfs2-devel >= 2.18.0.1
74%endif
75Requires: %{name}-libs = %{version}-%{release}
76Requires: dotnet-gmime-sharp >= 2.2.3
77%if %{with sqlite3}
78Requires: sqlite3
79%else
80Requires: sqlite
81%endif
82ExclusiveArch: %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc sparcv9 sparc64
83ExcludeArch: i386
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%description
87Beagle is an indexing sub-system and search aggregator built on top of
88Lucene.Net.
89
90%description -l pl.UTF-8
91Beagle jest podsystemem indeksującym i wyszukującym zbudowanym na
92bazie Lucene.Net.
93
94%package libs
95Summary: Beagle libraries
96Summary(pl.UTF-8): Bibiloteki Beagle
97Group: Libraries
98
99%description libs
100Beagle libraries.
101
102%description libs -l pl.UTF-8
103Bibiloteki Beagle.
104
105%package devel
106Summary: Beagle development files
107Summary(pl.UTF-8): Pliki programistyczne Beagle
108Group: Development/Libraries
109Requires: %{name}-libs = %{version}-%{release}
110
111%description devel
112Beagle development files.
113
114%description devel -l pl.UTF-8
115Pliki programistyczne Beagle.
116
117%package static
118Summary: Beagle static libraries
119Summary(pl.UTF-8): Statyczne biblioteki Beagle
120Group: Development/Libraries
121Requires: %{name}-devel = %{version}-%{release}
122
123%description static
124Beagle static libraries.
125
126%description static -l pl.UTF-8
127Statyczne biblioteki Beagle.
128
129%package apidocs
130Summary: libbeagle API documentation
131Summary(pl.UTF-8): Dokumentacja API libbeagle
132Group: Documentation
133Requires: gtk-doc-common
134
135%description apidocs
136libbeagle API documentation.
137
138%description apidocs -l pl.UTF-8
139Dokumentacja API libbeagle.
140
141%package crawl-system
142Summary: Beagle crawl system
143Summary(pl.UTF-8): System przeszukujący beagle-crawl
144Group: Applications/System
145Requires: crondaemon
146Provides: group(beagleindex)
147Provides: user(beagleindex)
148
149%description crawl-system
150Beagle crawl system.
151
152%description crawl-system -l pl.UTF-8
153System przeszukujący beagle-crawl.
154
155%package evolution
156Summary: Beagle Evolution backend
157Summary(pl.UTF-8): Backend Beagle dla Evolution
158Group: X11/Applications/Networking
159Requires: %{name} = %{version}-%{release}
160Requires: dotnet-evolution-sharp >= 0.11.1
161Requires: evolution >= 2.10.0
162
163%description evolution
164Beagle Evolution backend.
165
166%description evolution -l pl.UTF-8
167Backend Beagle dla Evolution.
168
169%package thunderbird
170Summary: Beagle Mozilla Thunderbird backend
171Summary(pl.UTF-8): Backend Beagle dla Mozilli Thunderbird
172Group: X11/Applications/Networking
173Requires: %{name} = %{version}-%{release}
174
175%description thunderbird
176Beagle Mozilla Thunderbird backend.
177
178%description thunderbird -l pl.UTF-8
179Backend Beagle dla Mozilli Thunderbird.
180
181%package -n mozilla-firefox-extension-beagle
182Summary: Mozilla Firefox extension - beagle
183Summary(pl.UTF-8): Rozszerzenie dla Mozilla Firefox - beagle
184Group: X11/Applications/Networking
185Requires: %{name} = %{version}-%{release}
186Requires: mozilla-firefox >= 2.0.0.1-2
187
188%description -n mozilla-firefox-extension-beagle
189Mozilla Firefox extension that allows Beagle to index every page the
190user views.
191
192%description -n mozilla-firefox-extension-beagle -l pl.UTF-8
193Rozszerzenie dla Mozilla Firefox sprawiające, że Beagle indeksuje
194każdą odwiedzaną stronę.
195
196%package -n epiphany-extension-beagle
197Summary: Epiphany extension - beagle
198Summary(pl.UTF-8): Rozszerzenie dla Epiphany - beagle
199Group: X11/Applications/Networking
200Requires: %{name} = %{version}-%{release}
201Requires: epiphany-extensions >= 2.18.0
202
203%description -n epiphany-extension-beagle
204Epiphany extension that allows Beagle to index every page the user
205views.
206
207%description -n epiphany-extension-beagle -l pl.UTF-8
208Rozszerzenie dla Epiphany sprawiające, że Beagle indeksuje każdą
209odwiedzaną stronę.
210
211%package -n python-%{name}
212Summary: Beagle Python bindings
213Summary(pl.UTF-8): Wiązania języka Python dla Beagle
214Group: Libraries/Python
215Requires: %{name} = %{version}-%{release}
216%pyrequires_eq python-libs
217
218%description -n python-%{name}
219Beagle Python bindings.
220
221%description -n python-%{name} -l pl.UTF-8
222Wiązania języka Python dla Beagle.
223
224%package search-gui
225Summary: GNOME based Beagle GUI
226Summary(pl.UTF-8): Oparty na GNOME graficzny interfejs dla Beagle
227Group: Libraries/Python
228Requires: %{name} = %{version}-%{release}
229Requires: gtk+2 >= 2:2.10.10
230
231%description search-gui
232GNOME based Beagle GUI.
233
234%description search-gui -l pl.UTF-8
235Oparty na GNOME graficzny interfejs dla Beagle.
236
237%package startup
238Summary: Automatic startup integration for Beagle
239Summary(pl.UTF-8): Integracja funkcji automatycznego startu Beagle
240Group: X11/Applications
241Requires: %{name} = %{version}-%{release}
242Obsoletes: beagle-gnome
243
244%description startup
245Automatic session startup integration for Beagle.
246
247%description startup -l pl.UTF-8
248Integracja funkcji automatycznego startu Beagle.
249
250%prep
251%setup -q
252%patch0 -p1
253%patch1 -p1
254%patch2 -p1
255%patch3 -p1
256%patch4 -p1
257
258%build
259%{__libtoolize}
260%{__aclocal}
261%{__autoconf}
262%{__automake}
263%configure \
264 --enable-static \
265 %{?with_apidocs:--enable-gtk-doc} \
266 --with-html-dir=%{_gtkdocdir} \
267 --%{!?with_epiphany:dis}%{?with_epiphany:en}able-epiphany-extension \
268 --%{!?with_evolution:dis}%{?with_evolution:en}able-evolution-sharp \
269 --%{!?with_gui:dis}%{?with_gui:en}able-gui \
270 --%{!?with_thunderbird:dis}%{?with_thunderbird:en}able-thunderbird
271
272%{__make} \
273 MOZILLA_HOME=%{_libdir}/mozilla \
274 pythondir=%{py_sitedir}
275
276%install
277rm -rf $RPM_BUILD_ROOT
278install -d $RPM_BUILD_ROOT%{_var}/cache/beagle/indexes
279
280%{__make} install \
281 DESTDIR=$RPM_BUILD_ROOT \
282 pythondir=%{py_sitedir}
283
284dest=$RPM_BUILD_ROOT%{_datadir}/mozilla-firefox/extensions/\{fda00e13-8c62-4f63-9d19-d168115b11ca\}
285install -d $dest $dest/chrome
286install mozilla-extension/{chrome.manifest,install.rdf} $dest
287install mozilla-extension/chrome/beagle.jar $dest/chrome
288
289# Kill useless files
290rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/2.18/extensions/*.{la,a} \
291 $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
292
293rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
294rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.{a,la}
295
296rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/no
297
298%find_lang %{name}
299
300%clean
301rm -rf $RPM_BUILD_ROOT
302
303%pre crawl-system
304%groupadd -g 166 -r -f beagleindex
305%useradd -u 166 -r -d /var/cache/beagle -s /bin/false -c "Beagle indexing" -g beagleindex beagleindex
306
307%postun crawl-system
308if [ "$1" = "0" ]; then
309 %userremove beagleindex
310 %groupremove beagleindex
311fi
312
313%post libs -p /sbin/ldconfig
314%postun libs -p /sbin/ldconfig
315
316%files -f %{name}.lang
317%defattr(644,root,root,755)
318%doc AUTHORS COPYING ChangeLog NEWS README
319%attr(755,root,root) %{_bindir}/beagle-config
320%attr(755,root,root) %{_bindir}/beagled
321%attr(755,root,root) %{_bindir}/beagle-doc-extractor
322%attr(755,root,root) %{_bindir}/beagle-exercise-file-system
323%attr(755,root,root) %{_bindir}/beagle-extract-content
324%attr(755,root,root) %{_bindir}/beagle-index-info
325%attr(755,root,root) %{_bindir}/beagle-index-url
326%attr(755,root,root) %{_bindir}/beagle-info
327%attr(755,root,root) %{_bindir}/beagle-ping
328%attr(755,root,root) %{_bindir}/beagle-query
329%attr(755,root,root) %{_bindir}/beagle-shutdown
330%attr(755,root,root) %{_bindir}/beagle-status
331%attr(755,root,root) %{_libdir}/%{name}/libbeagleglue.so*
332%attr(755,root,root) %{_libdir}/%{name}/*.exe
333%dir %{_libdir}/%{name}
334%dir %{_libdir}/%{name}/Backends
335%dir %{_libdir}/%{name}/Filters
336%{_libdir}/%{name}/*.dll
337%{_libdir}/%{name}/*.dll.config
338%{_libdir}/%{name}/Filters/*.dll
339%attr(755,root,root) %{_libdir}/%{name}/beagled-index-helper
340%{_mandir}/man*/*
341
342%files libs
343%defattr(644,root,root,755)
344%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
345
346%files devel
347%defattr(644,root,root,755)
348%attr(755,root,root) %{_libdir}/*.so
349%{_includedir}/libbeagle
350%{_libdir}/*.la
351%{_pkgconfigdir}/*
352
353%files static
354%defattr(644,root,root,755)
355%{_libdir}/*.a
356
357%if %{with apidocs}
358%files apidocs
359%defattr(644,root,root,755)
360%{_gtkdocdir}/beagle
361%endif
362
363%files crawl-system
364%defattr(644,root,root,755)
365%attr(750,root,crontab) %config(noreplace) %verify(not md5 mtime size) /etc/cron.daily/*
366%dir %{_sysconfdir}/beagle
367%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/beagle/*
368%dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle
369%dir %attr(755,beagleindex,beagleindex) %{_var}/cache/beagle/indexes
370%attr(755,root,root) %{_sbindir}/*
371
372%if %{with evolution}
373%files evolution
374%defattr(644,root,root,755)
375%{_libdir}/%{name}/Backends/Evolution*.dll
376%endif
377
378%if %{with thunderbird}
379%files thunderbird
380%defattr(644,root,root,755)
381%attr(755,root,root) %{_bindir}/beagle-contactviewer
382%{_libdir}/%{name}/Backends/Thunderbird*.dll
383%endif
384
385%files -n mozilla-firefox-extension-beagle
386%defattr(644,root,root,755)
387%{_datadir}/mozilla-firefox/extensions/{fda00e13-8c62-4f63-9d19-d168115b11ca}
388
389%if %{with epiphany}
390%files -n epiphany-extension-beagle
391%defattr(644,root,root,755)
392%doc epiphany-extension/README
393%attr(755,root,root) %{_libdir}/epiphany/2.18/extensions/libbeagleextension.so*
394%{_libdir}/epiphany/2.18/extensions/*.xml
395%endif
396
397%if %{with python}
398%files -n python-%{name}
399%defattr(644,root,root,755)
400%attr(755,root,root) %{py_sitedir}/*.so
401%endif
402
403%if %{with gui}
404%files search-gui
405%defattr(644,root,root,755)
406%attr(755,root,root) %{_bindir}/beagle-imlogviewer
407%attr(755,root,root) %{_bindir}/beagle-search
408%attr(755,root,root) %{_bindir}/beagle-settings
409%attr(755,root,root) %{_libdir}/%{name}/libbeagleuiglue.so*
410%{_pixmapsdir}/*.png
411%{_desktopdir}/*.desktop
412%endif
413
414%files startup
415%defattr(644,root,root,755)
416%{_sysconfdir}/xdg/autostart/beagled-autostart.desktop
417%{_sysconfdir}/xdg/autostart/beagle-search-autostart.desktop
This page took 0.042957 seconds and 4 git commands to generate.