]> git.pld-linux.org Git - packages/apache1-mod_pointer.git/blame_incremental - apache1-mod_pointer.spec
- use apache1(EAPI) for runtime dep
[packages/apache1-mod_pointer.git] / apache1-mod_pointer.spec
... / ...
CommitLineData
1# TODO
2# - package split by backend
3%define mod_name pointer
4%define apxs %{_sbindir}/apxs1
5Summary: Apache module for making domain redirects
6Summary(pl.UTF-8): Moduł Apache'a do tworzenia przekierowań domen
7Name: apache1-mod_%{mod_name}
8Version: 0.8
9Release: 0.8
10License: Apache
11Group: Networking/Daemons
12Source0: http://stderr.net/mod_pointer/dist/mod_pointer-%{version}.tar.gz
13# Source0-md5: 2f6529c49f1d10ecd06d3f6bc8503a5f
14Source1: %{name}.conf
15Patch0: %{name}-mysql.patch
16URL: http://stderr.net/mod_pointer/
17BuildRequires: apache1-devel >= 1.3.34-8.5
18BuildRequires: gdbm-devel
19BuildRequires: mysql-devel
20BuildRequires: postgresql-devel
21BuildRequires: rpmbuild(macros) >= 1.268
22Requires: apache1(EAPI)
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28%description
29mod_pointer is an Apache module for making domain redirects easy - the
30known service of many hosting providers that lets a domain point to
31your webpage on another server.
32
33The configuration part of the mappings are handled in either a MySQL
34or PostgreSQL database or a NDBM or SDBM db file, so it's easy to
35build a webbased interface for letting users change it on their own.
36
37%description -l pl.UTF-8
38mod_pointer to moduł Apache'a do łatwego tworzenia przekierowań domen
39- znanej usługi wielu providerów pozwalającej domenie wskazywać na
40stronę na innym serwerze.
41
42Część konfiguracyjna odwzorowań jest obsługiwana poprzez bazę danych
43MySQL lub PostgreSQL albo plik bazy danych NDBM lub SDBM, więc łatwo
44stworzyć oparty na WWW interfejs umożliwiający użytkownikom
45samodzielną zmianę przekierowań.
46
47%prep
48%setup -q -n mod_%{mod_name}-%{version}
49%patch0 -p1
50
51%build
52%{__make} all \
53 WITH_APXS=%{apxs}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
58
59%{__make} install \
60 APXS="%{apxs} -S DESTDIR=$RPM_BUILD_ROOT"
61
62cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/40_mod_%{mod_name}.conf
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68%service -q apache restart
69
70%postun
71if [ "$1" = "0" ]; then
72 %service -q apache restart
73fi
74
75%files
76%defattr(644,root,root,755)
77%doc README CHANGES SUPPORT TODO frameset.html *.sql *.readme pointer.conf
78%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
79%attr(755,root,root) %{_pkglibdir}/*
This page took 0.030803 seconds and 5 git commands to generate.