]> git.pld-linux.org Git - packages/apache-php-fcgi.git/blame_incremental - apache-php-fcgi.spec
make apache config apache 2.4 compatible
[packages/apache-php-fcgi.git] / apache-php-fcgi.spec
... / ...
CommitLineData
1%define apxs /usr/sbin/apxs
2Summary: Support for the PHP via FastCGI protocol for Apache webserver
3Name: apache-php-fcgi
4Version: 5.6
5Release: 1
6License: GPL
7Group: Applications/WWW
8Source0: apache.conf
9BuildRequires: apache-devel >= 1.3.39
10BuildRequires: rpmbuild(macros) >= 1.268
11Requires: apache-mod_fastcgi
12Requires: php(fcgi)
13Requires: php-fcgi-init
14Provides: webserver(php) = %{version}
15BuildArch: noarch
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
19
20%description
21This virtual package provides support for the PHP via FastCGI
22protocol.
23
24%prep
25%setup -qcT
26
27%install
28rm -rf $RPM_BUILD_ROOT
29install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
30cp -p %{SOURCE0} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_php-fcgi.conf
31
32%clean
33rm -rf $RPM_BUILD_ROOT
34
35%post
36%service -q httpd restart
37
38%postun
39if [ "$1" = "0" ]; then
40 %service -q httpd restart
41fi
42
43%files
44%defattr(644,root,root,755)
45%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_php-fcgi.conf
This page took 0.127587 seconds and 4 git commands to generate.