]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blame_incremental - apache-mod_suphp.spec
- updated to 0.7.1
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
... / ...
CommitLineData
1#
2# Available build options:
3%bcond_with checkpath # enable check if php execution is within DOCUMENT_ROOT of the vhost
4#
5%define mod_name suphp
6%define apxs /usr/sbin/apxs
7Summary: Apache module: suPHP - execute PHP scripts with the permissions of their owners
8Summary(pl.UTF-8): Moduł do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich właścicieli
9Name: apache-mod_%{mod_name}
10Version: 0.7.1
11Release: 1
12License: GPL
13Group: Networking/Daemons/HTTP
14Source0: http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
15# Source0-md5: c172dd4f15a75f4dcb08ea97d4202bb8
16Source1: %{name}.logrotate
17Source2: %{name}.conf
18Source3: %{name}-suphp.conf
19Patch0: %{name}-compiler-flags.patch
20Patch1: %{name}-apache_version.patch
21URL: http://www.suphp.org/
22BuildRequires: %{apxs}
23BuildRequires: apache-devel >= 2.0.52-2
24BuildRequires: autoconf
25BuildRequires: automake
26BuildRequires: libstdc++-devel
27BuildRequires: libtool
28BuildRequires: rpmbuild(macros) >= 1.268
29Requires: apache(modules-api) = %apache_modules_api
30Requires: php-cgi
31Conflicts: logrotate < 3.7-4
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
35%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
36
37%description
38suPHP is a tool for executing PHP scripts with the permissions of
39their owners. It consists of an Apache module (mod_suphp) and a setuid
40root binary (suphp) that is called by the Apache module to change the
41uid of the process executing the PHP interpreter.
42
43%description -l pl.UTF-8
44suPHP jest narzędziem pozwalającym na wykonywanie skryptów w PHP z
45uprawnieniami ich właścicieli. Składa się z modułu (mod_suphp) oraz
46programu (suphp) z ustawionym bitem suid, który uruchamiany jest przez
47moduł w celu zmiany uid procesu uruchamiającego interpreter PHP.
48
49%prep
50%setup -q -n %{mod_name}-%{version}
51%patch0 -p1
52%patch1 -p1
53
54%build
55%{__libtoolize}
56%{__aclocal}
57%{__autoconf}
58%{__autoheader}
59%{__automake}
60APACHE_VERSION=$(rpm -q --qf '%{V}' apache-devel); export APACHE_VERSION
61%configure \
62 --%{?with_checkpath:en}%{!?with_checkpath:dis}able-checkpath \
63 --with-apache-user=http \
64 --with-min-uid=500 \
65 --with-min-gid=1000 \
66 --with-apxs=%{apxs} \
67 --with-apr=%{_bindir}/apr-1-config \
68 --with-setid-mode=owner \
69 --with-logfile=/var/log/httpd/suphp_log
70
71%{__make}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75install -d $RPM_BUILD_ROOT{%{_sbindir},%{apachelibdir},%{_datadir}/suphp}
76install -d $RPM_BUILD_ROOT%{apacheconfdir}
77
78install src/suphp $RPM_BUILD_ROOT%{_sbindir}
79install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
80install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/70_mod_%{mod_name}.conf
81install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
82
83install -d $RPM_BUILD_ROOT/etc/logrotate.d
84install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
85
86install doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
92%service -q httpd restart
93
94%postun
95if [ "$1" = "0" ]; then
96 %service -q httpd restart
97fi
98
99%files
100%defattr(644,root,root,755)
101%doc README AUTHORS ChangeLog doc
102%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
103%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{mod_name}.conf
104%attr(755,root,root) %{apachelibdir}/*.so
105%attr(4755,root,root) %{_sbindir}/suphp
106%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
107%dir %{_datadir}/suphp
108%{_datadir}/suphp/*
This page took 0.053495 seconds and 4 git commands to generate.