]> git.pld-linux.org Git - packages/alex.git/blame_incremental - alex.spec
- ghc has been taught to use ld.bfd, no need for hackery here
[packages/alex.git] / alex.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with bootstrap # use foreign (non-rpm) ghc
4#
5Summary: A lexical analyser generator for Haskell
6Summary(pl.UTF-8): Generator analizatorów składniowych dla Haskella
7Name: alex
8Version: 3.0.5
9Release: 1
10License: BSD-like w/o adv. clause
11Group: Development/Tools
12Source0: http://hackage.haskell.org/packages/archive/alex/%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: 018f9817cd3c094294c8ab83e530c1c8
14URL: http://haskell.org/alex/
15BuildRequires: autoconf
16BuildRequires: docbook-dtd42-xml
17BuildRequires: docbook-style-xsl
18%{!?with_bootstrap:BuildRequires: ghc >= 6.6}
19BuildRequires: ghc-QuickCheck >= 2
20BuildRequires: gmp-devel
21%{!?with_bootstrap:BuildRequires: happy}
22BuildRequires: libxslt-progs
23#For generating documentation in PDF: fop or xmltex
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27Alex is a tool for generating lexical analysers in Haskell, given a
28description of the tokens to be recognised in the form of regular
29expressions. It is similar to the tool lex or flex for C/C++.
30
31%description -l pl.UTF-8
32Alex to narzędzie do generowania analizatorów składniowych w Haskellu
33na podstawie opisu tokenów do rozpoznawania w postaci wyrażeń
34regularnych. Jest podobne do narzędzi lex lub flex dla C/C++.
35
36%prep
37%setup -q
38
39%build
40%{?with_bootstrap:PATH=$PATH:/usr/local/bin}
41runhaskell Setup.lhs configure --prefix=%{_prefix}
42runhaskell Setup.lhs build
43
44cd doc
45%{__autoconf}
46%configure
47%{__make} html
48cd ..
49
50%install
51rm -rf $RPM_BUILD_ROOT
52%{?with_bootstrap:PATH=$PATH:/usr/local/bin}
53runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
54
55install -d $RPM_BUILD_ROOT%{_examplesdir}
56cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58# work around automatic haddock docs installation
59%{__rm} -rf %{name}-%{version}-doc
60cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
61%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc ANNOUNCE README TODO doc/alex
69%attr(755,root,root) %{_bindir}/alex
70%{_datadir}/%{name}-%{version}
71%{_examplesdir}/%{name}-%{version}
This page took 0.039446 seconds and 4 git commands to generate.