]> git.pld-linux.org Git - packages/Zope-Interface.git/blame_incremental - Zope-Interface.spec
rebuild for pythonegg deps; unify python .spec
[packages/Zope-Interface.git] / Zope-Interface.spec
... / ...
CommitLineData
1Summary: Python 'interface' concept implementation
2Summary(pl.UTF-8): Implementacja interfejsów dla języka Python
3Name: Zope-Interface
4Version: 4.0.1
5Release: 2
6License: ZPL 2.1
7Group: Libraries/Python
8Source0: http://pypi.python.org/packages/source/z/zope.interface/zope.interface-%{version}.tar.gz
9# Source0-md5: d171f8f8a6997409c7680f1dbb3b7e45
10URL: http://www.zope.org/Products/ZopeInterface/
11BuildRequires: python
12BuildRequires: python-devel
13BuildRequires: python-setuptools
14BuildRequires: rpm-pythonprov
15BuildRequires: rpmbuild(macros) >= 1.219
16Requires: python-modules
17# set this requirement explicitly, so people know where %py_sitedir/zope can be found
18Requires: Zope-dirs
19Provides: ZopeInterface
20Obsoletes: ZopeInterface
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Python 'interface' concept implementation.
25
26%description -l pl.UTF-8
27Implementacja interfejsów (abstrakcyjnych reprezentacji klas) dla
28języka Python.
29
30%prep
31%setup -q -n zope.interface-%{version}
32
33%build
34CC="%{__cc}" \
35CFLAGS="%{rpmcflags}" \
36%{__python} setup.py build
37
38%install
39rm -rf $RPM_BUILD_ROOT
40%{__python} setup.py install \
41 --skip-build \
42 --optimize=2 \
43 --root=$RPM_BUILD_ROOT
44
45%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/*.c
46%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/common/tests
47%{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/zope/interface/tests
48
49%py_postclean
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(644,root,root,755)
56%doc CHANGES.txt
57%dir %{py_sitedir}/zope/interface
58%{py_sitedir}/zope/interface/*.py[co]
59%attr(755,root,root) %{py_sitedir}/zope/interface/_zope_interface_coptimizations.so
60%{py_sitedir}/zope/interface/common
61%{py_sitedir}/zope.interface-*.egg-info
62%{py_sitedir}/zope.interface-*-nspkg.pth
This page took 0.10586 seconds and 5 git commands to generate.