]> git.pld-linux.org Git - packages/SDL2.git/blame_incremental - SDL2.spec
upstream fix for missing cmake target; rel 2
[packages/SDL2.git] / SDL2.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with directfb # DirectFB graphics support
4%bcond_with nas # NAS audio support
5%bcond_without alsa # ALSA audio support
6%bcond_with arts # aRts audio support
7%bcond_with esd # EsounD audio support
8%bcond_with jack # JACK audio support
9%bcond_without opengl # OpenGL (GLX) support
10%bcond_without gles # OpenGL ES (EGL) support
11%bcond_with kms # KMS/DRM graphics support
12%bcond_without vulkan # Vulkan graphics support
13%bcond_without wayland # Wayland graphics support
14%bcond_without fcitx # Fcitx IM support
15%bcond_without ibus # IBus IM support
16%bcond_without static_libs # don't build static libraries
17%bcond_with mmx # MMX instructions
18%bcond_with sse # SSE instructions
19%bcond_with sse2 # SSE2 instructions
20%bcond_with 3dnow # 3Dnow! instructions
21%bcond_with altivec # Altivec instructions
22#
23# NOTE: the following libraries are dlopened by soname detected at build time:
24# libartsc.so.? [if with arts]
25# libasound.so.2 [if with alsa]
26# libaudio.so.2 [if with nas]
27# libdirectfb-*.so --needs patch (-release not supported by configure)
28# libdrm.so.2 [if with kms]
29# libesd.so.0 [if with esd]
30# libfusionsound-*.so --needs patch (-release not supported by configure)
31# libgbm.so.1 [if with kms]
32# libjack.so.0 [if with jack]
33# libpipewire-0.3.so.0
34# libpulse-simple.so.0
35# libsamplerate.so.0
36# libwayland-client.so.0 [if with wayland]
37# libwayland-cursor.so.0 [if with wayland]
38# libwayland-egl.so.1 [if with wayland]
39# libxkbcommon.so.0 [if with wayland]
40# libX11.so.6
41# libXcursor.so.1
42# libXext.so.6
43# libXi.so.6
44# libXrandr.so.2
45# libXrender.so.1
46# libXss.so.1
47%ifarch k6 athlon
48%define with_3dnow 1
49%endif
50%ifarch %{x8664} x32 pentium2 pentium3 pentium4 athlon
51%define with_mmx 1
52%endif
53%ifarch %{x8664} x32 pentium3 pentium4
54%define with_sse 1
55%endif
56%ifarch %{x8664} x32 pentium4
57%define with_sse2 1
58%endif
59Summary: SDL (Simple DirectMedia Layer) - Game/Multimedia Library
60Summary(pl.UTF-8): SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
61Summary(zh_CN.UTF-8): SDL (Simple DirectMedia Layer) Generic APIs - 游戏/多媒体库
62Name: SDL2
63Version: 2.24.0
64Release: 2
65License: Zlib (BSD-like)
66Group: Libraries
67Source0: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
68# Source0-md5: cf539ffe9e0dd6f943ac9de75fd2e56e
69Patch0: %{name}-config.patch
70Patch1: cmake-target.patch
71URL: http://www.libsdl.org/
72%{?with_kms:BuildRequires: Mesa-libgbm-devel >= 11.1.0}
73%{?with_directfb:BuildRequires: DirectFB-devel >= 1.0.0}
74%if %{with opengl} || %{with gles}
75BuildRequires: EGL-devel
76%endif
77%{?with_directfb:BuildRequires: FusionSound-devel >= 1.1.1}
78%{?with_opengl:BuildRequires: OpenGL-GLX-devel}
79%{?with_gles:BuildRequires: OpenGLES-devel}
80%{?with_alsa:BuildRequires: alsa-lib-devel >= 1.0.11}
81%{?with_arts:BuildRequires: artsc-devel >= 1.1}
82BuildRequires: autoconf >= 2.59-9
83BuildRequires: automake
84BuildRequires: dbus-devel
85%{?with_esd:BuildRequires: esound-devel >= 0.2.8}
86%{?with_fcitx:BuildRequires: fcitx-devel}
87BuildRequires: gcc >= 5:4.0
88BuildRequires: hidapi-devel
89%{?with_ibus:BuildRequires: ibus-devel >= 1.0}
90%{?with_jack:BuildRequires: jack-audio-connection-kit-devel >= 0.125}
91%{?with_kms:BuildRequires: libdrm-devel >= 1.4.82}
92BuildRequires: libsamplerate-devel
93BuildRequires: libtool >= 2:2.0
94%{?with_nas:BuildRequires: nas-devel}
95BuildRequires: perl-modules
96BuildRequires: pipewire-devel >= 0.3.20
97BuildRequires: pkgconfig >= 1:0.7
98BuildRequires: pulseaudio-devel >= 0.9
99BuildRequires: udev-devel
100# wayland-client, wayland-cursor
101%{?with_wayland:BuildRequires: wayland-devel >= 1.18}
102%{?with_wayland:BuildRequires: wayland-egl-devel}
103BuildRequires: xorg-lib-libX11-devel
104BuildRequires: xorg-lib-libXScrnSaver-devel
105BuildRequires: xorg-lib-libXcursor-devel
106BuildRequires: xorg-lib-libXext-devel
107BuildRequires: xorg-lib-libXi-devel
108BuildRequires: xorg-lib-libXrandr-devel
109BuildRequires: xorg-lib-libXrender-devel
110%if %{with wayland}
111BuildRequires: xorg-lib-libxkbcommon-devel >= 0.5.0
112%endif
113BuildRequires: xorg-proto-xextproto-devel
114BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116%define specflags_ppc -maltivec
117
118%description
119SDL (Simple DirectMedia Layer) is a library that allows you portable,
120low level access to a video framebuffer, audio output, mouse, and
121keyboard. It can support both windowed and DGA modes of XFree86, and
122it is designed to be portable - applications linked with SDL can also
123be built on Win32 and BeOS.
124
125%description -l pl.UTF-8
126SDL (Simple DirectMedia Layer) jest biblioteką udostępniającą
127przenośny, niskopoziomowy dostęp do bufora ramki video, wyjścia audio,
128myszy oraz klawiatury. Może obsługiwać zarówno okienkowy tryb XFree86
129jak i DGA. Konstruując ją miano na uwadze przenośność: aplikacje
130konsolidowane z SDL można również budować w systemach Win32 i BeOS.
131
132%description -l pt_BR.UTF-8
133Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
134baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
135
136Essa biblioteca é usada por alguns jogos.
137
138%description -l ru.UTF-8
139SDL (Simple DirectMedia Layer) это набор функций, предоставляющий
140низкоуровневый доступ к звуку, клавиатуре, манипулятору мышь и к
141буферу экрана на множестве различных платформ.
142
143%package devel
144Summary: SDL - Header files
145Summary(pl.UTF-8): SDL - Pliki nagłówkowe
146Summary(pt_BR.UTF-8): Bibliotecas e arquivos de cabeçalho para aplicações SDL
147Summary(ru.UTF-8): Файлы, необходимые для разработки программ, использующих SDL
148Summary(uk.UTF-8): Файли, необхідні для розробки програм, що використовують SDL
149Summary(zh_CN.UTF-8): SDL (Simple DirectMedia Layer) 开发库
150Group: Development/Libraries
151Requires: %{name} = %{version}-%{release}
152%{?with_directfb:Requires: DirectFB-devel >= 1.0.0}
153Requires: xorg-lib-libX11-devel
154Suggests: OpenGL-GLU-devel
155
156%description devel
157SDL - Header files.
158
159%description devel -l pl.UTF-8
160SDL - Pliki nagłówkowe.
161
162%description devel -l pt_BR.UTF-8
163Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
164recursos para o desenvolvimento de aplicativos com SDL.
165
166%description devel -l ru.UTF-8
167Этот пакет содержит файлы, необходимые для разработки программ,
168использующих SDL.
169
170%description devel -l uk.UTF-8
171Цей пакет містить файли, необхідні для розробки програм, що
172використовують SDL.
173
174%package static
175Summary: SDL - static libraries
176Summary(pl.UTF-8): SDL - biblioteki statyczne
177Summary(pt_BR.UTF-8): Biblioteca estática para desenvolvimento de aplicações com a SDL
178Summary(ru.UTF-8): Статические библиотеки для разработки с использованием SDL
179Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням SDL
180Group: Development/Libraries
181Requires: %{name}-devel = %{version}-%{release}
182
183%description static
184SDL - static libraries.
185
186%description static -l pl.UTF-8
187SDL - biblioteki statyczne.
188
189%description static -l pt_BR.UTF-8
190Biblioteca estática para desenvolvimento de aplicações com a SDL.
191
192%description static -l ru.UTF-8
193Этот пакет содержит статические библиотеки для разработки программ,
194использующих SDL.
195
196%description static -l uk.UTF-8
197Цей пакет містить статичні бібліотеки для розробки програм, що
198використовують SDL.
199
200%package examples
201Summary: SDL - example programs
202Summary(pl.UTF-8): SDL - programy przykładowe
203License: Public Domain
204Group: Development/Libraries
205Requires: %{name}-devel = %{version}-%{release}
206
207%description examples
208SDL - example programs.
209
210%description examples -l pl.UTF-8
211SDL - przykładowe programy.
212
213%prep
214%setup -q
215%patch0 -p1
216%patch1 -p1
217
218%build
219%{__libtoolize}
220%{__aclocal} -I acinclude
221%{__autoconf}
222%configure \
223 %{!?with_3dnow:--disable-3dnow} \
224 %{!?with_alsa:--disable-alsa} \
225 %{!?with_altiveca:--disable-altivec} \
226 %{!?with_arts:--disable-arts} \
227 %{!?with_esd:--disable-esd} \
228 %{!?with_fcitx:--disable-fcitx} \
229 %{!?with_ibus:--disable-ibus} \
230 %{!?with_jack:--disable-jack} \
231 %{!?with_mmx:--disable-mmx} \
232 %{!?with_nas:--disable-nas} \
233 --enable-pthreads \
234 --enable-pthread-sem \
235 --disable-rpath \
236 %{!?with_sse:--disable-sse --disable-ssemath} \
237 %{!?with_sse2:--disable-sse2} \
238 %{?with_sse:--enable-ssemath} \
239 %{!?with_static_libs:--disable-static} \
240 %{!?with_directfb:--disable-video-directfb} \
241 %{?with_kms:--enable-video-kmsdrm} \
242 --enable-video-opengl%{!?with_opengl:=no} \
243 --enable-video-opengles%{!?with_gles:=no} \
244 --enable-video-vulkan%{!?with_vulkan:=no} \
245 --enable-video-wayland%{!?with_wayland:=no} \
246 --with-x
247
248%{__make} \
249 V=1
250
251%install
252rm -rf $RPM_BUILD_ROOT
253install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
254
255%{__make} install \
256 DESTDIR=$RPM_BUILD_ROOT \
257 m4datadir=%{_aclocaldir}
258
259cp -pr test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
260
261%clean
262rm -rf $RPM_BUILD_ROOT
263
264%post -p /sbin/ldconfig
265%postun -p /sbin/ldconfig
266
267%files
268%defattr(644,root,root,755)
269# non-Linux READMEs packaged for portability information
270%doc BUGS.txt CREDITS.txt LICENSE.txt README*.txt TODO.txt WhatsNew.txt
271%attr(755,root,root) %{_libdir}/libSDL2-2.0.so.*.*.*
272%attr(755,root,root) %ghost %{_libdir}/libSDL2-2.0.so.0
273
274%files devel
275%defattr(644,root,root,755)
276%attr(755,root,root) %{_bindir}/sdl2-config
277%attr(755,root,root) %{_libdir}/libSDL2.so
278%{_libdir}/libSDL2.la
279%{_libdir}/libSDL2_test.a
280%{_libdir}/libSDL2_test.la
281%{_libdir}/libSDL2main.a
282%{_libdir}/libSDL2main.la
283%{_includedir}/SDL2
284%{_aclocaldir}/sdl2.m4
285%{_pkgconfigdir}/sdl2.pc
286%{_libdir}/cmake/SDL2
287
288%if %{with static_libs}
289%files static
290%defattr(644,root,root,755)
291%{_libdir}/libSDL2.a
292%endif
293
294%files examples
295%defattr(644,root,root,755)
296%{_examplesdir}/%{name}-%{version}
This page took 0.201352 seconds and 4 git commands to generate.