]> git.pld-linux.org Git - packages/QtCurve.git/blame_incremental - QtCurve.spec
- KDE3 up to 0.59.5
[packages/QtCurve.git] / QtCurve.spec
... / ...
CommitLineData
1# TODO:
2# - kde4
3# - gtk1 no longer updated. drop after dropping last gtk+ 1.x app
4#
5# Conditional build:
6%bcond_without gtk # don't build GTK+ styles
7%bcond_without gtk2 # don't build GTK+2 styles
8%bcond_without kde # don't build KDE styles
9#
10%define ver 0.59.5
11%define kde_ver 0.59.5
12%define gtk2_ver 0.59.7
13%define gtk1_ver 0.42.2
14Summary: A free and corrected port of Red Hat's GTK+/Qt theme
15Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16Name: QtCurve
17Version: %{ver}
18Release: 1
19License: GPL
20Group: Themes
21Source0: http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22# Source0-md5: e6e721a38650c4c453c686c5d871862d
23Source1: http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24# Source1-md5: afa418c3d22091fb4ef9397de0195a23
25Source2: http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26# Source2-md5: 8219f58493ca4e65a8fe61ee76eca522
27Patch0: %{name}-Gtk2-userjs.patch
28Patch1: %{name}-Gtk2-mailto.patch
29Patch2: %{name}-Gtk1-lib64.patch
30URL: http://www.kde-look.org/content/show.php?content=40492
31BuildRequires: autoconf
32BuildRequires: automake
33BuildRequires: cmake
34%{?with_gtk:BuildRequires: gtk+-devel}
35%{?with_gtk2:BuildRequires: gtk+2-devel}
36%{?with_kde:BuildRequires: kdelibs-devel >= 3.1}
37BuildRequires: libtool
38BuildRequires: pkgconfig
39BuildRequires: rpmbuild(macros) >= 1.293
40BuildRequires: sed > 4.0
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44A free and corrected port of Red Hat's GTK+/Qt theme.
45
46%description -l pl.UTF-8
47Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
48
49%package -n kde-style-QtCurve
50Summary: A free and corrected port of Red Hat's GTK+/Qt theme
51Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
52Version: %{kde_ver}
53Group: Themes
54Requires: kdelibs >= 3.1
55
56%description -n kde-style-QtCurve
57A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
58
59%description -n kde-style-QtCurve -l pl.UTF-8
60Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
61Wersja pod KDE.
62
63%package -n gtk-theme-QtCurve
64Summary: A free and corrected port of Red Hat's GTK+/Qt theme
65Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
66Version: %{gtk1_ver}
67Group: Themes
68Requires: theme-QtCurve-common = %{ver}-%{release}
69
70%description -n gtk-theme-QtCurve
71A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
72
73%description -n gtk-theme-QtCurve -l pl.UTF-8
74Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
75Wersja pod GTK+.
76
77%package -n gtk2-theme-QtCurve
78Summary: A free and corrected port of Red Hat's GTK+/Qt theme
79Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
80Version: %{gtk2_ver}
81Group: Themes
82Requires: theme-QtCurve-common = %{ver}-%{release}
83
84%description -n gtk2-theme-QtCurve
85A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
86
87%description -n gtk2-theme-QtCurve -l pl.UTF-8
88Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
89Wersja pod GTK+2.
90
91%package -n theme-QtCurve-common
92Summary: A free and corrected port of Redhats GTK+/Qt theme - common
93Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
94Version: %{ver}
95Group: Themes
96Obsoletes: gtk-theme-bluecurve
97Obsoletes: gtk2-theme-bluecurve
98Obsoletes: kde-style-bluecurve
99Obsoletes: kde-theme-bluecurve
100Obsoletes: theme-bluecurve-common
101
102%description -n theme-QtCurve-common
103A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
104and common files package.
105
106%description -n theme-QtCurve-common -l pl.UTF-8
107Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
108Pakiet z dokumentacja i plikami współdzielonymi.
109
110%prep
111%setup -q -c -D %{?with_kde:-a0} %{?with_gtk2:-a1} %{?with_gtk:-a2}
112%if %{with gtk2}
113cd %{name}-Gtk2-%{gtk2_ver}
114%patch0 -p1
115%patch1 -p0
116cd -
117%endif
118
119%if %{with gtk}
120%if "%{_lib}" == "lib64"
121cd %{name}-Gtk1-%{gtk1_ver}
122%patch2 -p1
123cd -
124%endif
125%endif
126
127
128%build
129%if %{with kde}
130cd %{name}-KDE3-%{kde_ver}
131%cmake \
132 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
133 .
134%{__make}
135cd -
136%endif
137
138%if %{with gtk}
139cd %{name}-Gtk1-%{gtk1_ver}
140%{__libtoolize}
141%{__aclocal}
142%{__autoconf}
143%{__autoheader}
144%{__automake}
145%configure
146%{__make}
147cd -
148%endif
149
150%if %{with gtk2}
151cd %{name}-Gtk2-%{gtk2_ver}
152%cmake \
153 -DQTC_ADD_EVENT_FILTER=true \
154 -DQTC_MODIFY_MOZILLA=true \
155 -DQTC_MODIFY_MOZILLA_USER_JS=true \
156 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
157 .
158%{__make}
159cd -
160%endif
161
162%install
163rm -rf $RPM_BUILD_ROOT
164
165%if %{with kde}
166%{__make} -C %{name}-KDE3-%{kde_ver} install \
167 DESTDIR=$RPM_BUILD_ROOT
168%endif
169
170%if %{with gtk}
171%{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
172 DESTDIR=$RPM_BUILD_ROOT
173%endif
174
175%if %{with gtk2}
176%{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
177 DESTDIR=$RPM_BUILD_ROOT
178
179chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
180chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/mozilla/mailto.sh
181%endif
182
183rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
184
185%clean
186rm -rf $RPM_BUILD_ROOT
187
188%if %{with kde}
189%files -n kde-style-QtCurve
190%defattr(644,root,root,755)
191%{_libdir}/kde3/kstyle_qtcurve_config.la
192%attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
193%attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
194%{_datadir}/apps/kstyle/themes/qtcurve*.themerc
195%{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
196%{_datadir}/apps/QtCurve
197%endif
198
199%if %{with gtk}
200%files -n gtk-theme-QtCurve
201%defattr(644,root,root,755)
202%attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
203%{_datadir}/themes/QtCurve/gtk
204%endif
205
206%if %{with gtk2}
207%files -n gtk2-theme-QtCurve
208%defattr(644,root,root,755)
209%attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
210%dir %{_datadir}/themes/QtCurve/gtk-2.0
211%{_datadir}/themes/QtCurve/gtk-2.0/gtkrc
212%{_datadir}/themes/QtCurve/gtk-2.0/icons3
213%{_datadir}/themes/QtCurve/gtk-2.0/icons4
214%attr(755,root,root) %{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
215%dir %{_datadir}/themes/QtCurve/mozilla
216%{_datadir}/themes/QtCurve/mozilla/QtCurve.css
217%{_datadir}/themes/QtCurve/mozilla/firefox-user.js
218%{_datadir}/themes/QtCurve/mozilla/preferences-rev.xml
219%attr(755,root,root) %{_datadir}/themes/QtCurve/mozilla/mailto.sh
220%endif
221
222%files -n theme-QtCurve-common
223%defattr(644,root,root,755)
224%doc %{name}-KDE3-%{kde_ver}/ChangeLog
225%doc %{name}-KDE3-%{kde_ver}/README
226%doc %{name}-KDE3-%{kde_ver}/TODO
227%dir %{_datadir}/themes/QtCurve
This page took 0.0513 seconds and 4 git commands to generate.