]> git.pld-linux.org Git - packages/QtCurve.git/blame_incremental - QtCurve.spec
- build switched to cmake
[packages/QtCurve.git] / QtCurve.spec
... / ...
CommitLineData
1# TODO:
2# - kde4
3# - gtk1 no longer updated. drop?
4# - include /usr/share/themes/QtCurve/mozilla somewhere
5# - unpackaged:
6#
7# Conditional build:
8%bcond_with gtk # build GTK styles
9%bcond_without gtk2 # don't build GTK+2 styles
10#
11%define kde_ver 0.55.1
12%define gtk2_ver 0.55.1
13%define gtk1_ver 0.42.2
14Summary: A free and corrected port of Red Hat's GTK+/Qt theme
15Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
16Name: QtCurve
17Version: 0.55.1
18Release: 1
19License: GPL
20Group: Themes
21Source0: http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
22# Source0-md5: 1ba394626a40e8926966739500dbf87d
23Source1: http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
24# Source1-md5: 0d5eeb45990c3ecf060daa68a2ed2e6f
25Source2: http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
26# Source2-md5: 8219f58493ca4e65a8fe61ee76eca522
27URL: http://www.kde-look.org/content/show.php?content=40492
28BuildRequires: autoconf
29BuildRequires: automake
30BuildRequires: cmake
31%{?with_gtk:BuildRequires: gtk+-devel}
32%{?with_gtk2:BuildRequires: gtk+2-devel}
33BuildRequires: kdelibs-devel >= 3.1
34BuildRequires: libtool
35BuildRequires: pkgconfig
36BuildRequires: rpmbuild(macros) >= 1.293
37BuildRequires: sed > 4.0
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41A free and corrected port of Red Hat's GTK+/Qt theme.
42
43%description -l pl.UTF-8
44Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
45
46%package -n kde-style-QtCurve
47Summary: A free and corrected port of Red Hat's GTK+/Qt theme
48Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
49Group: Themes
50Requires: kdelibs >= 3.1
51
52%description -n kde-style-QtCurve
53A free and corrected port of Red Hat's GTK+/Qt theme. KDE version.
54
55%description -n kde-style-QtCurve -l pl.UTF-8
56Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
57Wersja pod KDE.
58
59%package -n gtk-theme-QtCurve
60Summary: A free and corrected port of Red Hat's GTK+/Qt theme
61Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
62Group: Themes
63Requires: theme-QtCurve-common = %{version}-%{release}
64
65%description -n gtk-theme-QtCurve
66A free and corrected port of Red Hat's GTK+/Qt theme. GTK+ version.
67
68%description -n gtk-theme-QtCurve -l pl.UTF-8
69Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
70Wersja pod GTK+.
71
72%package -n gtk2-theme-QtCurve
73Summary: A free and corrected port of Red Hat's GTK+/Qt theme
74Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
75Group: Themes
76Requires: theme-QtCurve-common = %{version}-%{release}
77
78%description -n gtk2-theme-QtCurve
79A free and corrected port of Red Hat's GTK+/Qt theme. GTK+2 version.
80
81%description -n gtk2-theme-QtCurve -l pl.UTF-8
82Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
83Wersja pod GTK+2.
84
85%package -n theme-QtCurve-common
86Summary: A free and corrected port of Redhats GTK+/Qt theme - common
87Summary(pl.UTF-8): Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata - common
88Group: Themes
89Obsoletes: gtk-theme-bluecurve
90Obsoletes: gtk2-theme-bluecurve
91Obsoletes: kde-style-bluecurve
92Obsoletes: kde-theme-bluecurve
93Obsoletes: theme-bluecurve-common
94
95%description -n theme-QtCurve-common
96A free and corrected port of Red Hat's GTK+/Qt theme. Documentation
97and common files package.
98
99%description -n theme-QtCurve-common -l pl.UTF-8
100Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
101Pakiet z dokumentacja i plikami współdzielonymi.
102
103%prep
104%setup -q -c %{?with_gtk2:-a1} %{?with_gtk:-a2}
105
106%build
107cd %{name}-KDE3-%{kde_ver}
108%cmake \
109 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
110 .
111%{__make}
112cd -
113
114%if %{with gtk}
115cd %{name}-Gtk1-%{gtk1_ver}
116%{__libtoolize}
117%{__aclocal}
118%{__autoconf}
119%{__autoheader}
120%{__automake}
121%configure
122%{__make}
123cd -
124%endif
125
126%if %{with gtk2}
127cd %{name}-Gtk2-%{gtk2_ver}
128%cmake \
129 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
130 .
131%{__make}
132cd -
133%endif
134
135%install
136rm -rf $RPM_BUILD_ROOT
137
138%{__make} -C %{name}-KDE3-%{kde_ver} install \
139 DESTDIR=$RPM_BUILD_ROOT
140
141%if %{with gtk}
142%{__make} -C %{name}-Gtk1-%{gtk1_ver} install \
143 DESTDIR=$RPM_BUILD_ROOT
144%endif
145
146%if %{with gtk2}
147%{__make} -C %{name}-Gtk2-%{gtk2_ver} install \
148 DESTDIR=$RPM_BUILD_ROOT
149%endif
150
151rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%files -n kde-style-QtCurve
157%defattr(644,root,root,755)
158%{_libdir}/kde3/kstyle_qtcurve_config.la
159%attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
160#%{_libdir}/kde3/plugins/styles/*.la
161%attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
162%{_datadir}/apps/kstyle/themes/qtcurve*.themerc
163%{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
164%{_datadir}/apps/QtCurve
165
166%if %{with gtk}
167%files -n gtk-theme-QtCurve
168%defattr(644,root,root,755)
169%attr(755,root,root) %{_libdir}/gtk/themes/engines/*.so
170%{_datadir}/themes/QtCurve/gtk
171%endif
172
173%if %{with gtk2}
174%files -n gtk2-theme-QtCurve
175%defattr(644,root,root,755)
176%attr(755,root,root) %{_libdir}/gtk-2.0/*/*/*.so
177%{_datadir}/themes/QtCurve/gtk-2.0
178%{_datadir}/themes/QtCurve/mozilla
179%endif
180
181%files -n theme-QtCurve-common
182%defattr(644,root,root,755)
183%doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
184%dir %{_datadir}/themes/QtCurve
This page took 0.085084 seconds and 4 git commands to generate.