]> git.pld-linux.org Git - packages/blueman.git/blame - blueman.spec
- fixed locales installation
[packages/blueman.git] / blueman.spec
CommitLineData
7e0fad4e 1%define rev 106
5cc4ce65
MWP
2Summary: Blueman - bluetooth management utility for GNOME
3Name: blueman
7e0fad4e 4Version: 0.6
550d86cd 5Release: 0.%{rev}.2
3c7b0773 6License: GPL
5cc4ce65 7Group: Applications
7e0fad4e
MWP
8Source0: http://download.tuxfamily.org/blueman/tarballs/%{name}-%{version}-r%{rev}.tar.gz
9# Source0-md5: 0dd95fd39523b938cbe125bd21cf4934
5cc4ce65
MWP
10URL: http://blueman.tuxfamily.org/
11BuildRequires: bluez-libs-devel
e84511d9 12BuildRequires: gettext-devel
5cc4ce65 13BuildRequires: gnome-bluetooth-devel
e84511d9 14BuildRequires: intltool
5cc4ce65
MWP
15BuildRequires: python-Pyrex
16BuildRequires: python-devel
17BuildRequires: python-devel >= 2.5
18BuildRequires: python-distutils-extra
19BuildRequires: rpm-pythonprov
20Requires: bluez-libs >= 2.20
21Requires: bluez-utils
22Requires: gtk+2 >= 2.12
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Blueman is a GTK+ bluetooth management utility for GNOME using bluez
27dbus backend. The aim is to create a full featured graphical bluetooth
28manager for Linux.
29
30Features:
31
32- Easy to use interface
33- Storing Favourite devices
34- Send files
35- Browse files on devices
36- List all seen devices
37- View Local/Remote Device information
38- View transfer speeds and link quality
39- Configure local devices
40- Manage Pairing (Bonding)
41- Host/Connect to Personal Area Networks
42- Bind services to /dev/rfcomm ports, for eg. connecting via gprs
43- Connect and receive connections from: audio, network, input and
44 serial devices
45
46%prep
7e0fad4e 47%setup -q -n %{name}
550d86cd
SS
48for i in po/blueman*.po; do
49 lang=${i##po/blueman-}
50 lang=${lang%.po}
51 mv $i po/$lang.po
52done
5cc4ce65
MWP
53
54%build
4eaabbcf
MWP
55%{__sed} -i -e 's,lib/,%{_lib}/,g' setup.py
56%{__sed} -i -e 's,lib/,%{_lib}/,g' sys/org.blueman.Mechanism.service
5cc4ce65
MWP
57%{__python} setup.py build
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__python} setup.py install \
63 --root=$RPM_BUILD_ROOT
64
65%find_lang %{name} --with-gnome
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files -f %{name}.lang
71%defattr(644,root,root,755)
72%doc README
73#%dir %{_sysconfdir}
74%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/network.conf
75%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dbus-1/system.d/org.blueman.Mechanism.conf
269ff996 76%attr(755,root,root) %{_libdir}/%{name}
5cc4ce65
MWP
77%attr(755,root,root) %{_bindir}/*
78%{_datadir}/%{name}
79%{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
7e0fad4e 80%{_iconsdir}/hicolor/scalable/*/*.svg
5cc4ce65
MWP
81%{_iconsdir}/hicolor/*/apps/*.png
82%{_datadir}/PolicyKit/policy/org.blueman.policy
83%{_desktopdir}/blueman.desktop
84%{py_sitedir}/%{name}
85%{py_sitedir}/%{name}-%{version}-py*.egg-info
This page took 0.054699 seconds and 4 git commands to generate.