]> git.pld-linux.org Git - packages/aufs.git/blame - aufs.spec
- disable requirement security_inode_permission export in kernel (needs check)
[packages/aufs.git] / aufs.spec
CommitLineData
bf531407 1#
4734e1ff
ER
2# Conditional build:
3%bcond_without dist_kernel # allow non-distribution kernel
4%bcond_without kernel # don't build kernel modules
4734e1ff
ER
5%bcond_without userspace # don't build userspace programs
6%bcond_with verbose # verbose build (V=1)
0f3a7497 7%bcond_without vserver # kernel build without vserver & grsecurity
4734e1ff
ER
8
9%if %{without kernel}
10%undefine with_dist_kernel
11%endif
12
3b805c44 13%define subver 20080313
46de4e94
ER
14%define prel 0.%{subver}.%{rel}
15
88bd8994 16%define rel 10
509b678e 17Summary: aufs - Another Unionfs
bf531407 18Summary(pl.UTF-8): aufs (Another Unionfs) - inny unionfs
4734e1ff
ER
19Name: aufs
20Version: 0
46de4e94 21Release: %{prel}
4734e1ff
ER
22License: GPL v2
23Group: Base/Kernel
46de4e94 24Source0: %{name}-%{subver}.tar.bz2
3b805c44 25# Source0-md5: 044ba36a61ca6a0ebe72108aaa77b816
509b678e 26Patch0: %{name}-vserver.patch
3b805c44 27Patch1: %{name}-disable-security_inode_permission.patch
4734e1ff
ER
28URL: http://aufs.sourceforge.net/
29%if %{with kernel}
a18698d8 30%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
509b678e 31BuildRequires: rpmbuild(macros) >= 1.379
4734e1ff 32%endif
518cfd38 33BuildRequires: sed >= 4.0
4734e1ff
ER
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37In the early days, aufs was entirely re-designed and re-implemented
38Unionfs. After many original ideas, approaches, improvements and
39implementations, it becomes totally different from Unionfs while
40keeping the basic features. Unionfs is being developed by Professor
41Erez Zadok at Stony Brook University and his team. If you don't know
42Unionfs, I recommend you to try and know it before using aufs. Some
43terminology in aufs follows Unionfs's.
44
bf531407
JB
45%description -l pl.UTF-8
46Początkowo aufs był całkowicie przeprojektowanym i od nowa
47zaimplementowanym unionfs-em. Po wielu oryginalnych pomysłach,
48podejściach, poprawkach i implementacjach stał sie całkowicie innym
49niż unionfs zachowując podstawowe możliwości. unionfs jest rozwijany
50przez profesora Ereza Zadoka w Stony Brook University i jego zespół.
51Nie znający unionfs-a powinni spróbować go i poznać przed używaniem
52aufs-a. Część terminologii wywodzi się z unionfs-a.
53
4734e1ff
ER
54%package -n kernel%{_alt_kernel}-fs-aufs
55Summary: Linux driver for aufs
56Summary(pl.UTF-8): Sterownik dla Linuksa do aufs
46de4e94 57Release: %{prel}@%{_kernel_ver_str}
4734e1ff
ER
58Group: Base/Kernel
59Requires(post,postun): /sbin/depmod
60%if %{with dist_kernel}
509b678e 61%requires_releq_kernel
62Requires(postun): %releq_kernel
4734e1ff
ER
63%endif
64
65%description -n kernel%{_alt_kernel}-fs-aufs
66This is driver for aufs for Linux.
67
68This package contains Linux module.
69
70%description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
71Sterownik dla Linuksa do aufs.
72
73Ten pakiet zawiera moduł jądra Linuksa.
74
4734e1ff
ER
75%prep
76%setup -qn %{name}
509b678e 77%if %{with vserver}
78%patch0 -p1
79%endif
3b805c44 80%patch1 -p1
509b678e 81
82sed '
83 s/$(CONFIG_AUFS)/m/;
84 %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/};
85 s/$(CONFIG_AUFS_HINOTIFY)/n/;
86 s/$(CONFIG_AUFS_EXPORT)/y/;
87 s/$(CONFIG_AUFS_SYSAUFS)/n/
88' -i fs/aufs/Makefile
518cfd38 89cp -a include/linux fs/aufs
4734e1ff
ER
90
91%build
92%if %{with kernel}
518cfd38 93%build_kernel_modules -C fs/aufs -m aufs \
509b678e 94 EXTRA_CFLAGS=" \
95 -DCONFIG_AUFS_BRANCH_MAX_127 \
96 -DCONFIG_AUFS_BRANCH_MAX_CHAR \
97 -DCONFIG_AUFS_FAKE_DM \
98 -DCONFIG_AUFS_MODULE \
99 -UCONFIG_AUFS_KSIZE_PATCH \
3b805c44 100 -UCONFIG_AUFS_DLGT \
509b678e 101 %{?debug:-DCONFIG_AUFS_DEBUG} \
3b805c44 102 %{?with_vserver:-DVSERVER}"
4734e1ff
ER
103%endif
104
7d59a9cf 105%if %{with userspace}
106%{__make} -C util \
107 CC="%{__cc}" \
108 CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
109%endif
110
4734e1ff
ER
111%install
112rm -rf $RPM_BUILD_ROOT
113
7d59a9cf 114%if %{with userspace}
115install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
116install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
117install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
118%endif
119
4734e1ff 120%if %{with kernel}
0f3a7497 121%install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
4734e1ff
ER
122%endif
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -n kernel%{_alt_kernel}-fs-aufs
128%depmod %{_kernel_ver}
129
130%postun -n kernel%{_alt_kernel}-fs-aufs
131%depmod %{_kernel_ver}
132
4734e1ff 133%if %{with kernel}
4734e1ff
ER
134%files -n kernel%{_alt_kernel}-fs-aufs
135%defattr(644,root,root,755)
0f3a7497 136%dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
137/lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
4734e1ff
ER
138%endif
139
4734e1ff
ER
140%if %{with userspace}
141%files
142%defattr(644,root,root,755)
143%doc README History
7d59a9cf 144%attr(755,root,root) %{_sbindir}/*
145%{_mandir}/man5/*
4734e1ff 146%endif
This page took 0.440882 seconds and 4 git commands to generate.