]> git.pld-linux.org Git - packages/aufs.git/blame - aufs.spec
- rel 8 (2.6.16.59-2)
[packages/aufs.git] / aufs.spec
CommitLineData
bf531407 1#
4734e1ff
ER
2# Conditional build:
3%bcond_without dist_kernel # allow non-distribution kernel
4%bcond_without kernel # don't build kernel modules
4734e1ff
ER
5%bcond_without userspace # don't build userspace programs
6%bcond_with verbose # verbose build (V=1)
0f3a7497 7%bcond_without vserver # kernel build without vserver & grsecurity
4734e1ff
ER
8
9%if %{without kernel}
10%undefine with_dist_kernel
11%endif
12
46de4e94
ER
13%define subver 20071017
14%define prel 0.%{subver}.%{rel}
15
16%define rel 8
509b678e 17Summary: aufs - Another Unionfs
bf531407 18Summary(pl.UTF-8): aufs (Another Unionfs) - inny unionfs
4734e1ff
ER
19Name: aufs
20Version: 0
46de4e94 21Release: %{prel}
4734e1ff
ER
22License: GPL v2
23Group: Base/Kernel
46de4e94 24Source0: %{name}-%{subver}.tar.bz2
191d4a68 25# Source0-md5: dee001829acbf3a4fa857a752527b385
509b678e 26Patch0: %{name}-vserver.patch
4734e1ff
ER
27URL: http://aufs.sourceforge.net/
28%if %{with kernel}
a18698d8 29%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
509b678e 30BuildRequires: rpmbuild(macros) >= 1.379
4734e1ff 31%endif
518cfd38 32BuildRequires: sed >= 4.0
4734e1ff
ER
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36In the early days, aufs was entirely re-designed and re-implemented
37Unionfs. After many original ideas, approaches, improvements and
38implementations, it becomes totally different from Unionfs while
39keeping the basic features. Unionfs is being developed by Professor
40Erez Zadok at Stony Brook University and his team. If you don't know
41Unionfs, I recommend you to try and know it before using aufs. Some
42terminology in aufs follows Unionfs's.
43
bf531407
JB
44%description -l pl.UTF-8
45Początkowo aufs był całkowicie przeprojektowanym i od nowa
46zaimplementowanym unionfs-em. Po wielu oryginalnych pomysłach,
47podejściach, poprawkach i implementacjach stał sie całkowicie innym
48niż unionfs zachowując podstawowe możliwości. unionfs jest rozwijany
49przez profesora Ereza Zadoka w Stony Brook University i jego zespół.
50Nie znający unionfs-a powinni spróbować go i poznać przed używaniem
51aufs-a. Część terminologii wywodzi się z unionfs-a.
52
4734e1ff
ER
53%package -n kernel%{_alt_kernel}-fs-aufs
54Summary: Linux driver for aufs
55Summary(pl.UTF-8): Sterownik dla Linuksa do aufs
46de4e94 56Release: %{prel}@%{_kernel_ver_str}
4734e1ff
ER
57Group: Base/Kernel
58Requires(post,postun): /sbin/depmod
59%if %{with dist_kernel}
509b678e 60%requires_releq_kernel
61Requires(postun): %releq_kernel
4734e1ff
ER
62%endif
63
64%description -n kernel%{_alt_kernel}-fs-aufs
65This is driver for aufs for Linux.
66
67This package contains Linux module.
68
69%description -n kernel%{_alt_kernel}-fs-aufs -l pl.UTF-8
70Sterownik dla Linuksa do aufs.
71
72Ten pakiet zawiera moduł jądra Linuksa.
73
4734e1ff
ER
74%prep
75%setup -qn %{name}
509b678e 76%if %{with vserver}
77%patch0 -p1
78%endif
79
80sed '
81 s/$(CONFIG_AUFS)/m/;
82 %{!?debug:s/$(CONFIG_AUFS_DEBUG.*)/n/};
83 s/$(CONFIG_AUFS_HINOTIFY)/n/;
84 s/$(CONFIG_AUFS_EXPORT)/y/;
85 s/$(CONFIG_AUFS_SYSAUFS)/n/
86' -i fs/aufs/Makefile
518cfd38 87cp -a include/linux fs/aufs
4734e1ff
ER
88
89%build
90%if %{with kernel}
518cfd38 91%build_kernel_modules -C fs/aufs -m aufs \
509b678e 92 EXTRA_CFLAGS=" \
93 -DCONFIG_AUFS_BRANCH_MAX_127 \
94 -DCONFIG_AUFS_BRANCH_MAX_CHAR \
95 -DCONFIG_AUFS_FAKE_DM \
96 -DCONFIG_AUFS_MODULE \
97 -UCONFIG_AUFS_KSIZE_PATCH \
98 %{?debug:-DCONFIG_AUFS_DEBUG} \
99 %{?with_vserver:-DVSERVER} \
100 "
4734e1ff
ER
101%endif
102
7d59a9cf 103%if %{with userspace}
104%{__make} -C util \
105 CC="%{__cc}" \
106 CFLAGS="%{rpmcflags} -DCONFIG_AUFS_BRANCH_MAX_127"
107%endif
108
4734e1ff
ER
109%install
110rm -rf $RPM_BUILD_ROOT
111
7d59a9cf 112%if %{with userspace}
113install -d $RPM_BUILD_ROOT{%{_mandir}/man5,%{_sbindir}}
114install util/{mount.aufs,umount.aufs,auplink,aulchown} $RPM_BUILD_ROOT%{_sbindir}
115install util/aufs.5 $RPM_BUILD_ROOT%{_mandir}/man5/
116%endif
117
4734e1ff 118%if %{with kernel}
0f3a7497 119%install_kernel_modules -m fs/aufs/aufs -d kernel/fs/aufs
4734e1ff
ER
120%endif
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post -n kernel%{_alt_kernel}-fs-aufs
126%depmod %{_kernel_ver}
127
128%postun -n kernel%{_alt_kernel}-fs-aufs
129%depmod %{_kernel_ver}
130
4734e1ff 131%if %{with kernel}
4734e1ff
ER
132%files -n kernel%{_alt_kernel}-fs-aufs
133%defattr(644,root,root,755)
0f3a7497 134%dir /lib/modules/%{_kernel_ver}/kernel/fs/aufs
135/lib/modules/%{_kernel_ver}/kernel/fs/aufs/*.ko*
4734e1ff
ER
136%endif
137
4734e1ff
ER
138%if %{with userspace}
139%files
140%defattr(644,root,root,755)
141%doc README History
7d59a9cf 142%attr(755,root,root) %{_sbindir}/*
143%{_mandir}/man5/*
4734e1ff 144%endif
This page took 0.13973 seconds and 4 git commands to generate.