]> git.pld-linux.org Git - packages/apache1-mod_frontpage.git/blame - apache1-mod_frontpage.spec
- added fpexec patch,
[packages/apache1-mod_frontpage.git] / apache1-mod_frontpage.spec
CommitLineData
73331299 1%define mod_name frontpage
2%define arname mod_%{mod_name}
3%define apxs /usr/sbin/apxs
4
5Summary: The improved mod_frontpage module for the Apache Web server.
6Name: apache-mod_%{mod_name}
7Version: 1.6.1
8Release: 0.1
9Group: Networking/Daemons
10URL: http://home.edo.uni-dortmund.de/~chripo/
11#Source0: http://home.edo.uni-dortmund.de/~chripo/download/%{name}-%{version}mdk-1.3.19.tar.bz2
12#The patch is now maintained by FreeBSD
13Source0: http://people.freebsd.org/~mbr/distfiles/mod_frontpage-%{version}.tar.bz2
561da95c 14Patch0: %{arname}-PLD.patch
15Patch1: %{arname}-Makefile.patch
16Patch2: %{arname}-fpexec-PLD.patch
73331299 17License: Apache License
18Prereq: grep
19Prereq: apache(EAPI) >= 1.3.23
20Prereq: %{_sbindir}/apxs
21Requires: apache
22BuildRequires: apache(EAPI)-devel >= 1.3.23
23BuildRequires: perl
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
27%define _sysconfdir /etc/httpd
28
29%description
30This is a module for the Apache HTTP Server
31<http://www.apache.org/httpd.html>. It replaces the Apache-FP patches
32and module supplied with the FrontPage Server Extensions available
33from Microsoft <http://www.microsoft.com> and Ready-to-Run Software
34<http://www.rtr.com/fpsupport>.
35
36Using this module allows you to use advanced features of the FrontPage
37client with your Apache HTTP Server (e.g. creating FrontPage-extended
38subwebs using the FrontPage client in contrast to creating them as
39user "root" with "fpinstall.sh" or the "fpsrvadm.exe"-utility on the
40system's shell).
41
42%prep
43%setup -q -n %{arname}-%{version}
44%patch -p0
45%patch1 -p0
561da95c 46%patch2 -p0
73331299 47
48%build
49perl Makefile.PL
50%{__make} CFLAGS="%{rpmcflags} -DLINUX=22 -DINET6 -Dss_family=__ss_family -Dss_len=__ss_len -DDEV_RANDOM=/dev/random -DEAPI -DEAPI_MM"
51
52%install
53rm -rf $RPM_BUILD_ROOT
54install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sbindir}}
55install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56install fp{exec,static} $RPM_BUILD_ROOT%{_sbindir}
57
58gzip -9nf {CHANGES,FEATURES,INSTALL,LICENSE,README}
59
60%post
61%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
62if [ -f /var/lock/subsys/httpd ]; then
63 /etc/rc.d/init.d/httpd restart 1>&2
64fi
65
66%preun
67 if [ "$1" = "0" ]; then
68 %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
69 if [ -f /var/lock/subsys/httpd ]; then
70 /etc/rc.d/init.d/httpd restart 1>&2
71 fi
72fi
73
74%files
75%defattr(644,root,root,755)
76%attr(755,root,root) %{_pkglibdir}/*
77%attr(4550,root,root) %{_sbindir}/fpexec
78%attr(0555,root,root) %{_sbindir}/fpstatic
79%doc *.gz
80
81%clean
82rm -rf $RPM_BUILD_ROOT
This page took 0.071542 seconds and 4 git commands to generate.