]> git.pld-linux.org Git - packages/apache-mod_xsendfile.git/blame - apache-mod_xsendfile.spec
- tabs in preamble
[packages/apache-mod_xsendfile.git] / apache-mod_xsendfile.spec
CommitLineData
35d1673e
ER
1%define mod_name xsendfile
2%define apxs /usr/sbin/apxs
4983f265 3Summary: Apache module: processing X-SENDFILE headers
1e60d610 4Summary(pl.UTF-8): Moduł Apache'a przetwarzający nagłówki X-SENDFILE
35d1673e
ER
5Name: apache-mod_%{mod_name}
6Version: 0.8
7Release: 0.1
8License: Apache 2.0
9Group: Networking/Daemons
10Source0: http://celebnamer.celebworld.ws/stuff/mod_xsendfile/mod_xsendfile-%{version}.tar.gz
11# Source0-md5: aa885ed32cce545404f329fdf507e53b
12URL: http://celebnamer.celebworld.ws/stuff/mod_xsendfile/
13BuildRequires: %{apxs}
55faf3ef 14BuildRequires: apache-devel >= 2.0
35d1673e
ER
15BuildRequires: rpmbuild(macros) >= 1.268
16Requires: apache(modules-api) = %apache_modules_api
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
20%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
21%define _pkglogdir %(%{apxs} -q PREFIX 2>/dev/null)/logs
22
23%description
24mod_xsendfile is a small Apache2 module that processes X-SENDFILE
25headers registered by the original output handler. If it encounters
26the presence of such header it will discard all output and send the
27file specified by that header instead using Apache internals including
28all optimizations like caching-headers and sendfile or mmap if
29configured. It is useful for processing script-output of e.g. PHP,
30Perl or any CGI.
31
1717be06
JR
32%description -l pl.UTF-8
33mod_xsendfile to mały moduł Apache'a 2 przetwarzający nagłówki
34X-SENDFILE zarejestrowane przez oryginalną procedurę obsługi wyjścia.
35Kiedy stwierdzi obecność takiego nagłówka, anuluje całe wyjście i
36zamiast niego wysyła plik wskazany przez ten nagłówek przy użyciu
37funkcji wewnętrznych Apache'a wraz ze wszystkimi optymalizacjami,
38takimi jak buforowanie nagłówków i sendfile/mmap. Moduł ten jest
39przydatny do przetwarzania wyjścia skryptów, np. PHP, Perla czy
4983f265
JB
40dowolnego CGI.
41
35d1673e
ER
42%prep
43%setup -qc
44
45%build
46%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
51
52install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
54 $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post
60%service -q httpd restart
61
62%postun
63if [ "$1" = "0" ]; then
64 %service -q httpd restart
65fi
66
67%files
68%defattr(644,root,root,755)
69%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
70%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.07446 seconds and 4 git commands to generate.