]> git.pld-linux.org Git - packages/apache-mod_wsgi.git/blame - apache-mod_wsgi.spec
- updated to 2.5
[packages/apache-mod_wsgi.git] / apache-mod_wsgi.spec
CommitLineData
c1cb356c
PZ
1%define mod_name wsgi
2%define apxs /usr/sbin/apxs
3Summary: WSGI interface for the Apache Web server
4Summary(pl.UTF-8): Interfejs WSGI dla serwera WWW Apache
5Name: apache-mod_%{mod_name}
7d252d86
AF
6Version: 2.5
7Release: 1
e606faaa 8License: Apache
c1cb356c
PZ
9Group: Networking/Daemons
10Source0: http://modwsgi.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
7d252d86 11# Source0-md5: 43ad11c477799e2f780c50197c420afd
c1cb356c 12Source1: %{name}.conf
198257be 13Patch0: %{name}-apache-version.patch
c1cb356c 14URL: http://code.google.com/p/modwsgi/
dc5b014c 15BuildRequires: %{apxs}
c1cb356c
PZ
16BuildRequires: apache-devel >= 2.0.52-7
17BuildRequires: apr-devel >= 1:1.0.0
18BuildRequires: autoconf
19BuildRequires: automake
20BuildRequires: python-devel >= 2.3
21BuildRequires: rpmbuild(macros) >= 1.268
22Requires: apache(modules-api) = %apache_modules_api
23Requires: apr >= 1:1.0.0
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
198257be
ER
26%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
27%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
c1cb356c
PZ
28
29%description
30The mod_wsgi adapter is an Apache module that provides a WSGI
31compliant interface for hosting Python based web applications within
32Apache. The adapter is written completely in C code against the Apache
33C runtime and for hosting WSGI applications within Apache has a lower
34overhead than using existing WSGI adapters for mod_python or CGI.
35
36%description -l pl.UTF-8
db2bc9ef 37Adapter mod_wsgi jest modułem udostępniającym interfejs WSGI dla
c1cb356c 38aplikacji WWW napisanych w języku Python i osadzonych w serwerze
db2bc9ef
JB
39Apache. Adapter jest w całości napisany w języku C w oparciu o
40bibliotekę uruchomieniową Apache i ma mniejsze wymagania niż w
41przypadku używania istniejących adapterów WSGI dla modułu mod_python
42lub CGI.
c1cb356c
PZ
43
44%prep
45%setup -q -n mod_%{mod_name}-%{version}
198257be 46%patch0 -p1
c1cb356c
PZ
47
48%build
49%{__aclocal}
50%{__autoconf}
198257be 51HTTPD_VERSION=$(rpm -q --qf '%{V}' apache-devel); export HTTPD_VERSION
c1cb356c
PZ
52%configure \
53 --with-apxs=%{apxs}
54
55%install
56rm -rf $RPM_BUILD_ROOT
198257be 57install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
c1cb356c
PZ
58
59%{__make} install \
60 DESTDIR=$RPM_BUILD_ROOT
61
198257be 62install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/61_mod_wsgi.conf
c1cb356c
PZ
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68%service -q httpd restart
69
70%postun
71if [ "$1" = "0" ]; then
72 %service -q httpd restart
73fi
74
75%files
76%defattr(644,root,root,755)
77%doc README
198257be
ER
78%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
79%attr(755,root,root) %{apachelibdir}/*.so
This page took 0.082456 seconds and 4 git commands to generate.