]> git.pld-linux.org Git - packages/apache-mod_whatkilledus.git/blame - apache-mod_whatkilledus.spec
- new
[packages/apache-mod_whatkilledus.git] / apache-mod_whatkilledus.spec
CommitLineData
070fd57c
AM
1%define mod_name whatkilledus
2%define apxs /usr/sbin/apxs
3Summary: Knows what a thread was handling in case the thread segfaults
4Name: apache-mod_%{mod_name}
5Version: 1.0
6Release: 1
7License: Apache
8Group: Networking/Daemons
9Source0: http://people.apache.org/~trawick/mod_whatkilledus.c
10# Source0-md5: e59c5d56e294a31e5b158ad5e4553001
11URL: http://people.apache.org/~trawick/exception_hook.html
12BuildRequires: %{apxs}
13BuildRequires: apache-devel >= 2.0.43
14BuildRequires: rpm-perlprov
15Requires(post,preun): %{apxs}
16Requires: apache >= 2.0.43
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
20%define _sysconfdir %(%{apxs} -q SYSCONFDIR)
21
22%description
23Keeps a little bit of state on each active connection, which allows it
24to know what a thread was handling in case the thread segfaults.
25
26%prep
27%setup -q -c -T
28
29%build
30%{apxs} -c %{SOURCE0}
31
32%install
33rm -rf $RPM_BUILD_ROOT
34install -d $RPM_BUILD_ROOT/etc/httpd/httpd.conf
35
36libtool --mode=install install -D mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
37
38echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > $RPM_BUILD_ROOT/etc/httpd/httpd.conf/68_mod_%{mod_name}.conf
39
40%clean
41rm -rf $RPM_BUILD_ROOT
42
43%post
44if [ -f /var/lock/subsys/httpd ]; then
45 /etc/rc.d/init.d/httpd restart 1>&2
46else
47 echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
48fi
49
50%preun
51if [ "$1" = "0" ]; then
52 if [ -f /var/lock/subsys/httpd ]; then
53 /etc/rc.d/init.d/httpd restart 1>&2
54 fi
55fi
56
57%files
58%defattr(644,root,root,755)
59%attr(755,root,root) %{_pkglibdir}/*.so
60%config %{_sysconfdir}/httpd.conf/*.conf
This page took 0.080297 seconds and 4 git commands to generate.