]> git.pld-linux.org Git - packages/apache-mod_ruby.git/blame - apache-mod_ruby.spec
- rel 1.1
[packages/apache-mod_ruby.git] / apache-mod_ruby.spec
CommitLineData
e0991000
JR
1# TODO:
2# - make it work with ruby 1.9, currently any request -> Sig11
bd41caad
AG
3%define mod_name mod_ruby
4%define apxs /usr/sbin/apxs
7bea277e 5Summary: Apache mod_ruby module - embeds the Ruby interpreter into the Apache web server
e9f120cc 6Summary(pl.UTF-8): Moduł Apache'a mod_ruby - zapewniający obsługę skryptów rubego przez serwer Apache
bd41caad 7Name: apache-%{mod_name}
0adcba8e 8Version: 1.3.0
e0991000 9Release: 1.1
7bea277e 10License: BSD-like
a5ab6ed3 11Group: Networking/Daemons/HTTP
bd41caad 12Source0: http://www.modruby.net/archive/%{mod_name}-%{version}.tar.gz
0adcba8e 13# Source0-md5: 5aae358c3c9f1bfa2554da9242289ab7
bd41caad
AG
14Source1: %{name}.conf
15Patch0: %{name}-struct.patch
16URL: http://www.modruby.net/
b9e5ec1f 17BuildRequires: %{apxs}
a70c7ba3 18BuildRequires: apache-devel >= 2.0
ff01f49d 19BuildRequires: rpmbuild(macros) >= 1.268
7d3f8d7d 20BuildRequires: ruby-devel >= 1:1.6.4
5e053f2a 21Requires: apache(modules-api) = %apache_modules_api
192806ed 22Requires: ruby >= 1:1.6.4
56ff64c0 23%{?ruby_mod_ver_requires_eq}
7bea277e 24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
bd41caad 25
5e053f2a
ER
26%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
6092531b 28
bd41caad
AG
29%description
30mod_ruby embeds the Ruby interpreter into the Apache web server,
31allowing Ruby CGI scripts to be executed natively. These scripts will
32start up much faster than without mod_ruby.
33
274622d5
JR
34%description -l pl.UTF-8
35mod_ruby zapewnia obsługę skryptów Ruby'ego bezpośrednio z poziomu
36Apache'a, dzięki czemu będą się one ładowały znacznie szybciej niż
37gdyby były wywoływane tradycyjnie.
bd41caad
AG
38
39%prep
40%setup -q -n %{mod_name}-%{version}
41%patch0 -p1
42
43%build
7bea277e 44./configure.rb \
052f3e6c 45 --with-apr-includes='/usr/include/apr -I/usr/include/apr-util'\
7bea277e 46 --with-apxs=%{apxs}
bd41caad
AG
47%{__make}
48
49%install
50rm -rf $RPM_BUILD_ROOT
bd41caad 51
5e053f2a 52install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,%{ruby_rubylibdir}}
bd41caad 53install %{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{mod_name}.so
f39ce59d 54install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
3d502d8b 55cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
56
bd41caad 57%clean
7bea277e 58rm -rf $RPM_BUILD_ROOT
bd41caad
AG
59
60%post
ff01f49d 61%service -q httpd restart
bd41caad 62
1217a566 63%postun
bd41caad 64if [ "$1" = "0" ]; then
ff01f49d 65 %service -q httpd restart
bd41caad 66fi
bd41caad
AG
67
68%files
69%defattr(644,root,root,755)
7bea277e
JB
70%doc COPYING ChangeLog README.en examples doc/*
71%lang(ja) %doc README.ja
5e053f2a 72%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
940a6cb8 73%attr(755,root,root) %{_pkglibdir}/*.so
3d502d8b 74%{ruby_rubylibdir}/*
This page took 0.040322 seconds and 4 git commands to generate.