]> git.pld-linux.org Git - packages/apache-mod_mpm_itk.git/blame - apache-mod_mpm_itk.spec
- rel 3; use /var/run/php/ug for php session files
[packages/apache-mod_mpm_itk.git] / apache-mod_mpm_itk.spec
CommitLineData
c9c87750
AM
1%define mod_name mpm_itk
2%define apxs /usr/sbin/apxs
3%define ver 2.4.7
d2b3c984 4%define subver 02
c9c87750
AM
5Summary: mod_mpm_itk - allows you to run each of your vhost under a separate uid and gid
6Name: apache-mod_mpm_itk
7Version: %{ver}.%{subver}
82dde414 8Release: 3
c9c87750
AM
9License: Apache v2.0
10Group: Networking/Daemons/HTTP
11Source0: http://mpm-itk.sesse.net/mpm-itk-%{ver}-%{subver}.tar.gz
d2b3c984 12# Source0-md5: 241eddeef8d3931c6699a51d5d2169a7
10eb5784 13Source1: %{name}.conf
82dde414 14Source2: %{name}-php.conf
c9c87750
AM
15URL: http://mpm-itk.sesse.net/
16BuildRequires: %{apxs}
17BuildRequires: apache-devel >= 2.4.7
18BuildRequires: apr-devel >= 1:1.0
19BuildRequires: apr-util-devel >= 1:1.0
20BuildRequires: libcap-devel
21Requires: apache(modules-api) = %{apache_modules_api}
22Requires: apache-base >= 2.4.7
82dde414 23Requires: php-dirs
c9c87750
AM
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
28
29%description
30apache2-mpm-itk (just mpm-itk for short) is an MPM (Multi-Processing
31Module) for the Apache web server. mpm-itk allows you to run each of
ae0cdc1e 32your vhost under a separate uid and gid - in short, the scripts and
c9c87750
AM
33configuration files for one vhost no longer have to be readable for
34all the other vhosts.
35
36mpm-itk is based on the traditional prefork MPM, which means it's
37non-threaded; in short, this means you can run non-thread-aware code
38(like many PHP extensions) without problems. On the other hand, you
39lose out to any performance benefit you'd get with threads, of course;
40you'd have to decide for yourself if that's worth it or not. You will
41also take an additional performance hit over prefork, since there's an
42extra fork per request.
43
82dde414
AM
44%define no_install_post_check_tmpfiles 1
45
c9c87750
AM
46%prep
47%setup -q -n mpm-itk-%{ver}-%{subver}
48
49%build
50%configure \
51 --with-apxs=%{apxs}
c9c87750
AM
52%{__make}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_sysconfdir}/conf.d}
82dde414 57install -d $RPM_BUILD_ROOT/var/run/php/ug
c9c87750 58
ae0cdc1e 59install -p .libs/mpm_itk.so $RPM_BUILD_ROOT%{_pkglibdir}
10eb5784 60cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/10_mod_%{mod_name}.conf
82dde414 61cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/99_mod_%{mod_name}-php.conf
c9c87750
AM
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post
67%service -q httpd restart
68
69%postun
70if [ "$1" = "0" ]; then
71 %service -q httpd restart
72fi
73
74%files
75%defattr(644,root,root,755)
76%doc CHANGES README
77%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
82dde414 78%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}-php.conf
c9c87750 79%attr(755,root,root) %{_pkglibdir}/mpm_itk.so
82dde414
AM
80# multiple uid/gids in use
81%dir %attr(1773,root,root) /var/run/php/ug
82
This page took 0.126936 seconds and 4 git commands to generate.