]> git.pld-linux.org Git - packages/apache-mod_auth_xradius.git/blame - apache-mod_auth_xradius.spec
- BR apxs is not bogus
[packages/apache-mod_auth_xradius.git] / apache-mod_auth_xradius.spec
CommitLineData
71532eb5
SP
1#
2%define mod_name auth_xradius
f7ab3a57 3%define apxs %{_sbindir}/apxs
71532eb5
SP
4Summary: Apache module:
5Name: apache-mod_%{mod_name}
6Version: 0.4.6
f7ab3a57 7Release: 3
71532eb5
SP
8License: GPL
9Group: Networking/Daemons/HTTP
10Source0: http://www.outoforder.cc/downloads/mod_auth_xradius/mod_auth_xradius-%{version}.tar.bz2
11# Source0-md5: eeecc96f15dec9fe0a9c78c0b022903d
12Source1: %{name}.conf
13URL: http://www.outoforder.cc/projects/apache/mod_auth_xradius/
f7ab3a57 14BuildRequires: %{apxs}
71532eb5
SP
15BuildRequires: apache-devel >= 2.2
16BuildRequires: rpmbuild(macros) >= 1.268
17Requires: apache(modules-api) = %apache_modules_api
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
22
23%description
24mod_auth_xradius provides high performance authentication against RFC
252865 RADIUS Servers. Features:
26- Supports popular RADIUS Servers including OpenRADIUS, FreeRADIUS and
27 commercial servers.
28- Distributed Authentication Cache using apr_memcache.
29- Local Authentication Cache using DBM.
30- Uses standard HTTP Basic Authentication, unlike mod_auth_radius
31 which uses cookies for sessions.
32
33%prep
34%setup -q -n mod_%{mod_name}-%{version}
35
36%build
37%configure
38
39%{__make}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
44
45%{__make} install \
46 DESTDIR=$RPM_BUILD_ROOT
47
48install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54%service -q httpd restart
55
56%postun
57if [ "$1" = "0" ]; then
58 %service -q httpd restart
59fi
60
61%files
62%defattr(644,root,root,755)
63%doc README
64%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
65%attr(755,root,root) %{_pkglibdir}/*
This page took 0.082266 seconds and 4 git commands to generate.