]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
fix -gui runtime deps if built against qt5
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
f2c99d8a 3%bcond_without alsa # ALSA backend
b5f2479e 4%bcond_without jack # JACK backend
4899bbd7 5%bcond_without pipewire # PipeWire backend
f2c99d8a
JB
6%bcond_without portaudio # PortAudio backend
7%bcond_without pulseaudio # PulseAudio backend
4899bbd7 8%bcond_without rtkit # RTKit support
bd9b58be 9%bcond_with sdl # SDL2 backend
bd9b58be 10%bcond_with sse2 # force use of SSE2 instructions (x86)
f2c99d8a 11%bcond_without gui # alsoft-config GUI
99cf5ae3 12%bcond_with qt4 # Qt 4 instead of Qt 5 for GUI
73ba13c5 13
b90768b3 14%ifarch pentium4 x32 %{x8664}
bd9b58be
JB
15%define with_sse2 1
16%endif
d451b59a 17Summary: Open Audio Library
8be14136 18Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 19Name: OpenAL
4899bbd7 20Version: 1.22.0
769e4bfc 21Release: 2
65437b48 22License: LGPL v2+
68071dbf 23Group: Libraries
73ba13c5 24Source0: https://openal-soft.org/openal-releases/openal-soft-%{version}.tar.bz2
4899bbd7 25# Source0-md5: 40e5b29a241e1e320b5b16ed8f912257
60781cc7 26Patch0: %{name}-pc.patch
b90768b3 27Patch1: %{name}-nosse.patch
827050d4 28URL: http://www.openal.org/
bd9b58be 29%{?with_sdl:BuildRequires: SDL2-devel >= 2}
e62907a5 30%{?with_alsa:BuildRequires: alsa-lib-devel}
99cf5ae3 31BuildRequires: cmake >= 3.0.2
4899bbd7 32%{?with_rtkit:BuildRequires: dbus-devel}
b5f2479e 33%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
2b67cb40 34BuildRequires: libmysofa-devel
94a1f148 35BuildRequires: libstdc++-devel >= 6:5
4899bbd7 36%{?with_pipewire:BuildRequires: pipewire-devel >= 0.3}
89d1fa49 37BuildRequires: pkgconfig
7e80d8dd 38%{?with_portaudio:BuildRequires: portaudio-devel}
f953b352 39%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
4899bbd7 40BuildRequires: rpmbuild(macros) >= 1.742
f2c99d8a 41%if %{with gui}
99cf5ae3 42%if %{with qt4}
f2c99d8a
JB
43BuildRequires: QtCore-devel >= 4.8.0
44BuildRequires: QtGui-devel >= 4.8.0
45BuildRequires: qt4-build >= 4.8.0
99cf5ae3
JB
46%else
47BuildRequires: Qt5Core-devel >= 5
48BuildRequires: Qt5Gui-devel >= 5
49BuildRequires: Qt5Widgets-devel >= 5
50BuildRequires: qt5-build >= 5
51%endif
f2c99d8a 52%endif
b90768b3 53%{?with_sse2:Requires: cpuinfo(sse2)}
6a3db3d8 54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
6a3db3d8 56%description
57OpenAL, the Open Audio Library, is a joint effort to create an open,
58vendor-neutral, cross-platform API for interactive, primarily
59spatialized audio. OpenAL's primary audience are application
60developers and desktop users that rely on portable standards like
61OpenGL, for games and other multimedia applications. OpenAL is already
62supported by a number of hardware vendors and developers.
63
a4959810
JR
64%description -l pl.UTF-8
65OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
66stworzenia otwartego, niezależnego od producentów, międzyplatformowego
67interfejsu projektowania aplikacji w części obsługi dźwięku.
68Biblioteka adresowana jest do twórców aplikacji i użytkowników,
69którzy wybierają przenośne standardy, jak OpenGL, w grach i
70aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
71dostarczycieli sprzętu i programistów.
d451b59a 72
6a3db3d8 73%package devel
d451b59a 74Summary: Headers for OpenAL
8be14136 75Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 76Group: Development/Libraries
e62907a5 77Requires: %{name} = %{version}-%{release}
6a3db3d8 78
79%description devel
d451b59a 80Header files for OpenAL-based programs.
6a3db3d8 81
a4959810
JR
82%description devel -l pl.UTF-8
83Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 84OpenAL.
85
f2c99d8a
JB
86%package gui
87Summary: OpenAL configuration GUI
88Summary(pl.UTF-8): Graficzny interfejs do konfiguracji biblioteki OpenAL
89Group: X11/Applications/Sound
90Requires: %{name} = %{version}-%{release}
a517dbfd 91%if %{with qt4}
f2c99d8a
JB
92Requires: QtCore >= 4.8.0
93Requires: QtGui >= 4.8.0
a517dbfd
JP
94%else
95Requires: Qt5Core >= 5
96Requires: Qt5Gui >= 5
97Requires: Qt5Widgets >= 5
98%endif
f2c99d8a
JB
99
100%description gui
101OpenAL configuration GUI.
102
103%description gui -l pl.UTF-8
104Graficzny interfejs do konfiguracji biblioteki OpenAL.
105
6a3db3d8 106%prep
7e80d8dd 107%setup -q -n openal-soft-%{version}
60781cc7 108%patch0 -p1
b90768b3 109%patch1 -p1
68071dbf 110
6a3db3d8 111%build
99cf5ae3
JB
112cd build
113%cmake .. \
b5f2479e
JB
114 %{!?with_alsa:-DALSOFT_BACKEND_ALSA=OFF} \
115 %{!?with_jack:-DALSOFT_BACKEND_JACK=OFF} \
4899bbd7 116 %{cmake_on_off pipewire ALSOFT_BACKEND_PIPEWIRE} \
b5f2479e 117 %{!?with_portaudio:-DALSOFT_BACKEND_PORTAUDIO=OFF} \
99cf5ae3 118 %{!?with_pulseaudio:-DALSOFT_BACKEND_PULSEAUDIO=OFF} \
4899bbd7 119 %{cmake_on_off rtkit ALSOFT_RTKIT} \
bd9b58be 120 %{?with_sdl:-DALSOFT_BACKEND_SDL2=ON} \
b90768b3 121 %{!?with_sse2:-DALSOFT_ENABLE_SSE2_CODEGEN=OFF} \
99cf5ae3
JB
122 -DALSOFT_EXAMPLES=OFF \
123 %{!?with_gui:-DALSOFT_NO_CONFIG_UTIL=ON} \
124 %{?with_qt4:-DALSOFT_NO_QT5=ON} \
65437b48 125
7e80d8dd 126%{__make}
6a3db3d8 127
128%install
129rm -rf $RPM_BUILD_ROOT
6ce9e958 130install -d $RPM_BUILD_ROOT%{_sysconfdir}/openal
d451b59a 131
99cf5ae3 132%{__make} -C build install \
68071dbf 133 DESTDIR=$RPM_BUILD_ROOT
d451b59a 134
c06f4ed0 135install -p alsoftrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/openal/alsoft.conf
6ce9e958 136
6a3db3d8 137%clean
138rm -rf $RPM_BUILD_ROOT
139
404a1bc6
JB
140%post -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
6a3db3d8 143%files
3f81b215 144%defattr(644,root,root,755)
6ce9e958 145%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openal
996f154d 146%attr(755,root,root) %{_bindir}/makemhr
65437b48 147%attr(755,root,root) %{_bindir}/openal-info
a26f1dac 148%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
65437b48 149%attr(755,root,root) %ghost %{_libdir}/libopenal.so.1
f2c99d8a 150%{_datadir}/openal
6a3db3d8 151
152%files devel
153%defattr(644,root,root,755)
a26f1dac 154%attr(755,root,root) %{_libdir}/libopenal.so
68071dbf 155%{_includedir}/AL
a26f1dac 156%{_pkgconfigdir}/openal.pc
99cf5ae3 157%{_libdir}/cmake/OpenAL
f2c99d8a
JB
158
159%if %{with gui}
160%files gui
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_bindir}/alsoft-config
163%endif
This page took 0.129002 seconds and 4 git commands to generate.