summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2007-01-16 00:12:42 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitff47cff02e841ddd0cf19d7481b5d6e1a708bc3a (patch)
tree16d840b68aede47066183a3dadecc9bf7840a3c1
parent8292c0f44e401a576371791bd1515e58aa80dcda (diff)
downloadxalan-c-ff47cff02e841ddd0cf19d7481b5d6e1a708bc3a.zip
xalan-c-ff47cff02e841ddd0cf19d7481b5d6e1a708bc3a.tar.gz
- try something, still total failure
Changed files: xalan-c.spec -> 1.19
-rw-r--r--xalan-c.spec32
1 files changed, 28 insertions, 4 deletions
diff --git a/xalan-c.spec b/xalan-c.spec
index 7999a53..96464ff 100644
--- a/xalan-c.spec
+++ b/xalan-c.spec
@@ -52,8 +52,15 @@ Dokumentacja xalan-c.
%patch0 -p1
# Binaries provided with sources.
rm -rf c/{bin,lib}/*
+
# We don't need it, so why waste space?
-rm -rf ../xerces-c1_5_1-linux
+# XXX removing files outside our build root!?
+#rm -r ../xerces-c1_5_1-linux
+
+# for gcc on ac
+sed -i -e 's/-instances=static//' c/src/Makefile.in
+# add xerces includes
+sed -i -e 's,^XSL_INCL =.*,& -I/usr/include/xercesc/sax' c/src/Makefile.in
%build
cd c/src
@@ -66,9 +73,26 @@ export XERCESCROOT="%{_includedir}"
#autoconf
#CPPFLAGS="-Iinclude"
#export CPPFLAGS
-chmod 755 runConfigure
-./runConfigure -plinux -cgcc -xg++ -minmem -nfileonly -tnative
-%{__make} XERCES_VER=`rpm -q xerces-c --qf '%%{version}' | tr . _`
+#chmod 755 runConfigure
+#./runConfigure \
+# -plinux \
+# -c"%{__cc}" \
+# -x"%{__cxx}" \
+# -minmem # gone\
+# -nfileonly # gone\
+# -tnative # gone
+
+
+%{__make} \
+ LIBS="-lpthread" \
+ LDFLAGS="%{rpmcflags}" \
+ CXXFLAGS="%{rpmcxxflags}" \
+ CPPFLAGS=/usr/include/xercesc/sax \
+ CC="%{__cc}" \
+ CXX="%{__cxx}" \
+ ICUROOT=/usr \
+ XALAN_USE_ICU=1 \
+ XERCES_VER=%(rpm -q xerces-c --qf '%%{version}' | tr . _)
%install
rm -rf $RPM_BUILD_ROOT