summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElan Ruusamäe2007-01-16 08:00:25 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit99cc1afba453a4a2096c39465a5350bf15434157 (patch)
treef14f07a535030c2b3b311dd32b06fcdc9527820c
parent85ea993d8abf46b56712acc5a304c1cc045a8c59 (diff)
downloadxalan-c-99cc1afba453a4a2096c39465a5350bf15434157.zip
xalan-c-99cc1afba453a4a2096c39465a5350bf15434157.tar.gz
- almost compiles
Changed files: xalan-c.spec -> 1.21
-rw-r--r--xalan-c.spec46
1 files changed, 17 insertions, 29 deletions
diff --git a/xalan-c.spec b/xalan-c.spec
index 1b474ea..fe5c22c 100644
--- a/xalan-c.spec
+++ b/xalan-c.spec
@@ -1,3 +1,5 @@
+# TODO
+# - buildfail: /usr/bin/ld: cannot find -lxalan-c
%define _ver %(echo %{version} | tr . _)
Summary: XML parser
Summary(pl): Analizator składniowy XML-a
@@ -8,9 +10,9 @@ License: Apache License, Version 2.0
Group: Applications/Publishing/XML
Source0: http://www.apache.org/dist/xml/xalan-c/Xalan-C_%{_ver}-src.tar.gz
# Source0-md5: 0a3fbb535885531cc544b07a2060bfb1
-Patch0: %{name}-getopt.patch
+Patch0: %{name}-getopt.patch
URL: http://xalan.apache.org/
-BuildRequires: autoconf
+BuildRequires: libicu-devel
BuildRequires: util-linux
BuildRequires: xerces-c >= 2.7.0
BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -55,44 +57,30 @@ Dokumentacja xalan-c.
cd c
export XALANCROOT=$(pwd)
export XERCESROOT=/usr
+export ICUROOT=/usr
+export XALAN_USE_ICU=true
-%if 1
./runConfigure \
-p linux \
-c "%{__cc}" \
-x "%{__cxx}" \
- -minmem
-
-%{__make}
-%endif
-
-# passes CC correctly but broken
-%if 0
%ifarch %{x8664}
-CXXFLAGS=-DXML_BITSTOBUILD_64
-CFLAGS=-DXML_BITSTOBUILD_64
-BITSTOBUILD=64
+ -b 64 \
%else
-BITSTOBUILD=32
-%endif
-%configure
-%{__make} \
- LIBS="-lpthread" \
- LDFLAGS="%{rpmcflags}" \
- CXXFLAGS="%{rpmcxxflags} $CXXFLAGS" \
- CFLAGS="%{rpmcxxflags} $CFLAGS" \
- CC="%{__cc}" \
- CXX="%{__cxx}" \
- XALAN_LOCALE_SYSTEM=inmem \
- XALAN_LOCALE=en_US \
- BITSTOBUILD=$BITSTOBUILD \
- TRANSCODER= \
+ -b 32 \
%endif
+ -t icu \
+ -m icu
+
+%{__make}
%install
rm -rf $RPM_BUILD_ROOT
-cd c/src
-rm -rf $RPM_BUILD_ROOT
+cd c
+
+%{__make} install \
+ DESTDIR=$RPM_BUILD_ROOT
+exit 1
install -d $RPM_BUILD_ROOT%{_libdir}
install -d $RPM_BUILD_ROOT%{_includedir}