summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ruby-ZenTest.spec15
1 files changed, 14 insertions, 1 deletions
diff --git a/ruby-ZenTest.spec b/ruby-ZenTest.spec
index 132c1fd..f84ff36 100644
--- a/ruby-ZenTest.spec
+++ b/ruby-ZenTest.spec
@@ -1,4 +1,5 @@
Summary: Ruby Testing framework
+Summary(pl): Szkielet do testów dla języka Ruby
Name: ruby-ZenTest
Version: 2.3.0
Release: 1
@@ -21,17 +22,29 @@ that have slipped through the testing process. I've run it against my
own software and found I missed a lot in a well tested package.
Writing those tests found 4 bugs I had no idea existed.
+%description -l pl
+ZenTest skanuje cel oraz kod testów jednostkowych i pisze brakujący
+kod w oparciu o proste reguły nazywania, pozwalając na duży szybsze
+XP. ZenTest działa tylko z Rubym i Test::Unit.
+
+Dla potrzeb audytu ZenTest dostarcza świetne środki znajdowania metod
+wyślizgujących się z procesu testowania. Autor uruchamiał je na
+własnym oprogramowaniu i znalazł, że wiele pominął w dobrze
+przetestowanym pakiecie. Napisanie tych testów znalazło 4 błędy, o
+których istnieniu autor nie miał pojęcia.
+
%prep
%setup -q -n ZenTest-%{version}
%build
%{__make}
-find . -name '*.rb' | xargs perl -pi -e "s#local/bin/ruby#bin/ruby#"
+find . -name '*.rb' | xargs perl -pi -e "s#local/bin/ruby#bin/ruby#"
%install
rm -rf $RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_bindir}
+
install ZenTest.rb $RPM_BUILD_ROOT%{_bindir}/ZenTest
install unit_diff.rb $RPM_BUILD_ROOT%{_bindir}/unit_diff