summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2010-04-15 13:52:26 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commita962184356e9a48224f6d3bbc40f68a24abb0f1a (patch)
tree41210e04e6a7b0b194a740290eb94985af99a548
parent5a03ad046c923a0831403d713ab96c8d32d15d73 (diff)
downloadpostfix-a962184356e9a48224f6d3bbc40f68a24abb0f1a.zip
postfix-a962184356e9a48224f6d3bbc40f68a24abb0f1a.tar.gz
- up to 2.7.0
- vda-bigquota patch needs love - build-tested without vda-bigquota Changed files: postfix-dynamicmaps.patch -> 1.16 postfix-ident.patch -> 1.6 postfix-log-proxy-rejects.patch -> 1.7 postfix-master.cf_cyrus.patch -> 1.9 postfix.spec -> 1.341
-rw-r--r--postfix-dynamicmaps.patch12
-rw-r--r--postfix-ident.patch2
-rw-r--r--postfix-log-proxy-rejects.patch18
-rw-r--r--postfix-master.cf_cyrus.patch19
-rw-r--r--postfix.spec12
5 files changed, 31 insertions, 32 deletions
diff --git a/postfix-dynamicmaps.patch b/postfix-dynamicmaps.patch
index 75666ce..aabeaab 100644
--- a/postfix-dynamicmaps.patch
+++ b/postfix-dynamicmaps.patch
@@ -602,9 +602,9 @@ diff -dur postfix-2.1.3.orig/src/global/mail_dict.c postfix-2.1.3/src/global/mai
write_buf.c write_wait.c sane_basename.c format_tv.c allspace.c \
- allascii.c load_file.c killme_after.c vstream_tweak.c upass_connect.c \
+ allascii.c load_file.c killme_after.c vstream_tweak.c upass_connect.c load_lib.c \
- upass_listen.c upass_trigger.c edit_file.c inet_windowsize.c
+ upass_listen.c upass_trigger.c edit_file.c inet_windowsize.c \
+ unix_pass_fd_fix.c dict_cache.c
OBJS = alldig.o allprint.o argv.o argv_split.o attr_clnt.o attr_print0.o \
- attr_print64.o attr_print_plain.o attr_scan0.o attr_scan64.o \
@@ -38,7 +38,7 @@
chroot_uid.o cidr_match.o clean_env.o close_on_exec.o concatenate.o \
ctable.o dict.o dict_alloc.o dict_cdb.o dict_cidr.o dict_db.o \
@@ -620,18 +620,18 @@ diff -dur postfix-2.1.3.orig/src/global/mail_dict.c postfix-2.1.3/src/global/mai
write_buf.o write_wait.o sane_basename.o format_tv.o allspace.o \
- allascii.o load_file.o killme_after.o vstream_tweak.o upass_connect.o \
+ allascii.o load_file.o killme_after.o vstream_tweak.o upass_connect.o load_lib.o \
- upass_listen.o upass_trigger.o edit_file.o inet_windowsize.o
+ upass_listen.o upass_trigger.o edit_file.o inet_windowsize.o \
+ unix_pass_fd_fix.o dict_cache.o
HDRS = argv.h attr.h attr_clnt.h auto_clnt.h base64_code.h binhash.h \
- chroot_uid.h cidr_match.h clean_env.h connect.h ctable.h dict.h \
@@ -83,7 +83,7 @@
sigdelay.h sock_addr.h spawn_command.h split_at.h stat_as.h \
stringops.h sys_defs.h timed_connect.h timed_wait.h trigger.h \
username.h valid_hostname.h vbuf.h vbuf_print.h vstream.h vstring.h \
- vstring_vstream.h watchdog.h format_tv.h load_file.h killme_after.h \
+ vstring_vstream.h watchdog.h format_tv.h load_file.h killme_after.h load_lib.h \
- edit_file.h
+ edit_file.h dict_cache.h
TESTSRC = fifo_open.c fifo_rdwr_bug.c fifo_rdonly_bug.c select_bug.c \
- stream_test.c dup2_pass_on_exec.c
+ stream_test.c dup2_pass_on_exec.c test_send_fd test_recv_fd
@@ -91,6 +91,7 @@
CFLAGS = $(DEBUG) $(OPT) $(DEFS)
FILES = Makefile $(SRCS) $(HDRS)
diff --git a/postfix-ident.patch b/postfix-ident.patch
index 72e64e9..66ba08e 100644
--- a/postfix-ident.patch
+++ b/postfix-ident.patch
@@ -193,7 +193,7 @@ diff -urN -x '*~' postfix-2.2.5/src/smtpd/smtpd_ident.c postfix-2.2.5-ident/src/
@@ -2503,10 +2509,18 @@
* intermediate proxy.
*/
- if (!state->proxy || state->xforward.flags == 0) {
+ if (!proxy || state->xforward.flags == 0) {
- out_fprintf(out_stream, REC_TYPE_NORM,
- "Received: from %s (%s [%s])",
- state->helo_name ? state->helo_name : state->name,
diff --git a/postfix-log-proxy-rejects.patch b/postfix-log-proxy-rejects.patch
index 2f7e369..516b89f 100644
--- a/postfix-log-proxy-rejects.patch
+++ b/postfix-log-proxy-rejects.patch
@@ -14,25 +14,25 @@ diff -ur postfix-2.4.5/src/smtpd/smtpd.c postfix-2.4.5-proxy/src/smtpd/smtpd.c
#ifdef USE_TLS
@@ -2705,8 +2707,19 @@
if (state->err == CLEANUP_STAT_OK) {
- (void) smtpd_proxy_cmd(state, SMTPD_PROX_WANT_ANY, ".");
+ (void) proxy->cmd(state, SMTPD_PROX_WANT_ANY, ".");
if (state->err == CLEANUP_STAT_OK &&
-- *STR(state->proxy_buffer) != '2')
-+ *STR(state->proxy_buffer) != '2') {
+- *STR(proxy->buffer) != '2')
++ *STR(proxy->buffer) != '2') {
state->err = CLEANUP_STAT_CONT;
+ proxy_why = vstring_alloc(10);
-+ vstring_strncpy(proxy_why, STR(state->proxy_buffer), 3);
++ vstring_strncpy(proxy_why, STR(proxy->buffer), 3);
+ if (alldig(STR(proxy_why)))
+ proxy_code = atol(STR(proxy_why));
+ else
+ proxy_code = 554;
-+ vstring_strncpy(proxy_why, STR(state->proxy_buffer)+4, 5);
++ vstring_strncpy(proxy_why, STR(proxy->buffer)+4, 5);
+ smtpd_check_reject(state, MAIL_ERROR_POLICY, proxy_code, proxy_why,
-+ "%s", STR(state->proxy_buffer));
++ "%s", STR(proxy->buffer));
+ vstring_free(proxy_why);
+ }
- } else if (state->err != CLEANUP_STAT_SIZE) {
- state->err |= CLEANUP_STAT_PROXY;
- detail = cleanup_stat_detail(CLEANUP_STAT_PROXY);
+ }
+ }
+
--- postfix-2.6.1/src/smtpd/smtpd_check.c.orig 2009-05-25 19:29:43.159923869 +0200
+++ postfix-2.6.1/src/smtpd/smtpd_check.c 2009-05-25 19:31:30.299567709 +0200
@@ -386,7 +386,7 @@
diff --git a/postfix-master.cf_cyrus.patch b/postfix-master.cf_cyrus.patch
index 1b2fb02..1947926 100644
--- a/postfix-master.cf_cyrus.patch
+++ b/postfix-master.cf_cyrus.patch
@@ -1,15 +1,6 @@
--- postfix-2.2.2/conf/master.cf.orig 2005-01-24 20:12:46.000000000 +0100
+++ postfix-2.2.2/conf/master.cf 2005-04-26 11:46:51.000000000 +0200
-@@ -60,15 +60,15 @@
- # The Cyrus deliver program has changed incompatibly, multiple times.
- #
- #old-cyrus unix - n n - - pipe
--# flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
-+# flags=R user=cyrus argv=/usr/lib/cyrus/deliver -e -m ${extension} ${user}
- #
- # ====================================================================
- #
- # Cyrus 2.1.5 (Amos Gouaux)
+@@ -60,14 +60,14 @@
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus unix - n n - - pipe
@@ -18,3 +9,11 @@
#
# ====================================================================
#
+ # Old example of delivery via Cyrus.
+ #
+ #old-cyrus unix - n n - - pipe
+-# flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
++# flags=R user=cyrus argv=/usr/lib/cyrus/deliver -e -m ${extension} ${user}
+ #
+ # ====================================================================
+ #
diff --git a/postfix.spec b/postfix.spec
index c84b285..ae4dce1 100644
--- a/postfix.spec
+++ b/postfix.spec
@@ -23,7 +23,7 @@
%bcond_without epoll # disable epoll for 2.4 kernels
%endif
-%define vda_ver 2.6.5
+%define vda_ver 2.7.0
Summary: Postfix Mail Transport Agent
Summary(cs.UTF-8): Postfix - program pro přepravu pošty (MTA)
Summary(es.UTF-8): Postfix - Un MTA (Mail Transport Agent) de alto desempeño
@@ -32,21 +32,21 @@ Summary(pl.UTF-8): Serwer SMTP Postfix
Summary(pt_BR.UTF-8): Postfix - Um MTA (Mail Transport Agent) de alto desempenho
Summary(sk.UTF-8): Agent prenosu pošty Postfix
Name: postfix
-Version: 2.6.6
-Release: 1
+Version: 2.7.0
+Release: 0.1
Epoch: 2
License: distributable
Group: Networking/Daemons/SMTP
Source0: ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
-# Source0-md5: 2032102731aee48b4d1541962ecc0438
+# Source0-md5: df648f59421604e895cce56325f00bae
Source1: %{name}.aliases
Source2: %{name}.cron
Source3: %{name}.init
Source4: %{name}.sysconfig
Source5: %{name}.sasl
Source6: %{name}.pamd
-Source7: http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng.patch.gz
-# Source7-md5: 43e54d0a1a016b90d15a1bd231e6fa38
+Source7: http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
+# Source7-md5: f73d119fc9e00f31f23599176554e763
Source8: %{name}-bounce.cf.pl
# http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
Source9: %{name}-bounce.cf.de