summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Rękorajski2010-11-08 19:18:13 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit1df88c6252a672c5f18263da33dcbe9cca1e55fe (patch)
treea98a6e258b4014305d8ee4af41c07c7adbe32786
parentb60d9a61b0cf327bb68bfa4436b424a729e12ff2 (diff)
downloadpostfix-1df88c6252a672c5f18263da33dcbe9cca1e55fe.zip
postfix-1df88c6252a672c5f18263da33dcbe9cca1e55fe.tar.gz
- fix linking issues (inter-library deps for internal libs) Changed files: postfix-link.patch -> 1.1 postfix.spec -> 1.351
-rw-r--r--postfix-link.patch48
-rw-r--r--postfix.spec4
2 files changed, 51 insertions, 1 deletions
diff --git a/postfix-link.patch b/postfix-link.patch
new file mode 100644
index 0000000..7cdd0cf
--- /dev/null
+++ b/postfix-link.patch
@@ -0,0 +1,48 @@
+diff -ur postfix-2.7.1/src/dns/Makefile.in postfix-2.7.1-libs/src/dns/Makefile.in
+--- postfix-2.7.1/src/dns/Makefile.in 2010-11-08 20:14:18.394139054 +0100
++++ postfix-2.7.1-libs/src/dns/Makefile.in 2010-11-08 20:12:39.300139053 +0100
+@@ -31,7 +31,7 @@
+ root_tests:
+
+ $(LIB): $(OBJS)
+- gcc -shared -Wl,-soname,libpostfix-dns.so.1 -o $(LIB) $(OBJS)
++ gcc -shared -Wl,-soname,libpostfix-dns.so.1 -o $(LIB) $(OBJS) $(LIBS) -lresolv
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)
+diff -ur postfix-2.7.1/src/global/Makefile.in postfix-2.7.1-libs/src/global/Makefile.in
+--- postfix-2.7.1/src/global/Makefile.in 2010-11-08 20:14:18.424139054 +0100
++++ postfix-2.7.1-libs/src/global/Makefile.in 2010-11-08 20:10:05.004139060 +0100
+@@ -120,7 +120,7 @@
+ test: $(TESTPROG)
+
+ $(LIB): $(OBJS)
+- gcc -shared -Wl,-soname,libpostfix-global.so.1 -o $(LIB) $(OBJS)
++ gcc -shared -Wl,-soname,libpostfix-global.so.1 -o $(LIB) $(OBJS) $(LIBS)
+
+ $(LDAPSO): dict_ldap.o $(LIB)
+ gcc -shared -Wl,-soname,dict_ldap.so -o $@ $? -lldap -llber -L../../lib -lutil -L. -lglobal
+diff -ur postfix-2.7.1/src/master/Makefile.in postfix-2.7.1-libs/src/master/Makefile.in
+--- postfix-2.7.1/src/master/Makefile.in 2010-11-08 20:14:18.400139054 +0100
++++ postfix-2.7.1-libs/src/master/Makefile.in 2010-11-08 20:10:24.072139054 +0100
+@@ -39,7 +39,7 @@
+ root_tests:
+
+ $(LIB): $(LIB_OBJ)
+- gcc -shared -Wl,-soname,libpostfix-master.so.1 -o $(LIB) $(LIB_OBJ)
++ gcc -shared -Wl,-soname,libpostfix-master.so.1 -o $(LIB) $(LIB_OBJ) $(LIBS)
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)/$(LIB)
+diff -ur postfix-2.7.1/src/util/Makefile.in postfix-2.7.1-libs/src/util/Makefile.in
+--- postfix-2.7.1/src/util/Makefile.in 2010-11-08 20:14:18.465139054 +0100
++++ postfix-2.7.1-libs/src/util/Makefile.in 2010-11-08 20:12:49.982139058 +0100
+@@ -126,7 +126,7 @@
+ gcc -shared -Wl,-soname,dict_pcre.so -o $@ $? -lpcre -L. -lutil
+
+ $(LIB): $(OBJS)
+- gcc -shared -Wl,-soname,libpostfix-util.so.1 -o $(LIB) $(OBJS) -ldl
++ gcc -shared -Wl,-soname,libpostfix-util.so.1 -o $(LIB) $(OBJS) -ldl -lcdb -lnsl -ldb
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)
diff --git a/postfix.spec b/postfix.spec
index b3fb7e0..241ede0 100644
--- a/postfix.spec
+++ b/postfix.spec
@@ -33,7 +33,7 @@ Summary(pt_BR.UTF-8): Postfix - Um MTA (Mail Transport Agent) de alto desempenho
Summary(sk.UTF-8): Agent prenosu pošty Postfix
Name: postfix
Version: 2.7.1
-Release: 2
+Release: 3
Epoch: 2
License: distributable
Group: Networking/Daemons/SMTP
@@ -65,6 +65,7 @@ Patch6: %{name}-lib64.patch
Patch7: %{name}-conf.patch
Patch8: %{name}-dictname.patch
Patch9: %{name}-make-jN.patch
+Patch10: %{name}-link.patch
URL: http://www.postfix.org/
%{?with_sasl:BuildRequires: cyrus-sasl-devel}
BuildRequires: db-devel
@@ -273,6 +274,7 @@ sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt
%patch7 -p1
%patch8 -p1
%patch9 -p1
+%patch10 -p1
%if %{with tcp}
sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c