summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJacek Konieczny2004-06-22 13:04:38 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commitfe8e351e27c9be8cedaa9a1e1327f7baf06d4845 (patch)
tree59fa2ac7fc40c07f8f774e870f70b2dfcf434660
parent02c22037ddfacdaea1326a21aeedfe236640562a (diff)
downloadpostfix-fe8e351e27c9be8cedaa9a1e1327f7baf06d4845.zip
postfix-fe8e351e27c9be8cedaa9a1e1327f7baf06d4845.tar.gz
- updated for postfix 2.1.3
Changed files: postfix-dynamicmaps.patch -> 1.6.2.1 postfix-master.cf_cyrus.patch -> 1.5.2.1
-rw-r--r--postfix-dynamicmaps.patch568
-rw-r--r--postfix-master.cf_cyrus.patch8
2 files changed, 196 insertions, 380 deletions
diff --git a/postfix-dynamicmaps.patch b/postfix-dynamicmaps.patch
index 7eba876..f58f230 100644
--- a/postfix-dynamicmaps.patch
+++ b/postfix-dynamicmaps.patch
@@ -1,18 +1,8 @@
---- postfix-2.0.16.orig/conf/dynamicmaps.cf 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/conf/dynamicmaps.cf 2003-11-08 19:52:14.000000000 +0100
-@@ -0,0 +1,9 @@
-+# Postfix dynamic maps configuration file.
-+#
-+# The first match found is the one that is used. The only wildcard
-+# allowed is '*', which matches everything. The first %s is expanded
-+# to the map type.
-+#
-+#type location of .so file name of open function
-+#==== ================================ =====================
-+* /usr/lib/postfix/dict_%s.so dict_%s_open
---- postfix-2.0.16.orig/src/dns/Makefile.in 2003-09-14 02:03:59.000000000 +0200
-+++ postfix-2.0.16/src/dns/Makefile.in 2003-11-08 19:52:14.000000000 +0100
-@@ -15,7 +15,7 @@
+Only in postfix-2.1.3/conf: dynamicmaps.cf
+diff -dur postfix-2.1.3.orig/src/dns/Makefile.in postfix-2.1.3/src/dns/Makefile.in
+--- postfix-2.1.3.orig/src/dns/Makefile.in 2004-04-22 21:37:34.000000000 +0200
++++ postfix-2.1.3/src/dns/Makefile.in 2004-06-22 14:46:14.462368115 +0200
+@@ -12,7 +12,7 @@
LIB_DIR = ../../lib
INC_DIR = ../../include
@@ -21,7 +11,7 @@
all: $(LIB)
-@@ -27,12 +27,10 @@
+@@ -24,12 +24,10 @@
tests: test
$(LIB): $(OBJS)
@@ -35,8 +25,78 @@
update: $(LIB_DIR)/$(LIB) $(HDRS)
-for i in $(HDRS); \
---- postfix-2.0.16.orig/src/global/mail_conf.c 2002-01-14 17:24:35.000000000 +0100
-+++ postfix-2.0.16/src/global/mail_conf.c 2003-11-08 19:52:14.000000000 +0100
+diff -dur postfix-2.1.3.orig/src/global/Makefile.in postfix-2.1.3/src/global/Makefile.in
+--- postfix-2.1.3.orig/src/global/Makefile.in 2004-06-22 14:45:16.607745629 +0200
++++ postfix-2.1.3/src/global/Makefile.in 2004-06-22 14:55:20.723473815 +0200
+@@ -90,8 +90,11 @@
+ LIB_DIR = ../../lib
+ INC_DIR = ../../include
+ MAKES =
++LDAPSO = dict_ldap.so
++MYSQLSO = dict_mysql.so
++PGSQLSO = dict_pgsql.so
+
+-.c.o:; $(CC) $(CFLAGS) -c $*.c
++.c.o:; $(CC) -fPIC $(CFLAGS) -c $*.c
+
+ all: $(LIB)
+
+@@ -101,14 +104,30 @@
+ test: $(TESTPROG)
+
+ $(LIB): $(OBJS)
+- $(AR) $(ARFL) $(LIB) $?
+- $(RANLIB) $(LIB)
++ gcc -shared -Wl,-soname,libpostfix-global.so.1 -o $(LIB) $(OBJS)
++
++$(LDAPSO): dict_ldap.o
++ gcc -shared -Wl,-soname,dict_ldap.so -o $@ $? -lldap -llber -L../../lib -lutil -L. -lglobal
++
++$(MYSQLSO): dict_mysql.o
++ gcc -shared -Wl,-soname,dict_ldap.so -o $@ $? -lldap -llber -L../../lib -lutil -L. -lglobal
++
++$(PGSQLSO): dict_pgsql.o
++ gcc -shared -Wl,-soname,dict_ldap.so -o $@ $? -lldap -llber -L../../lib -lutil -L. -lglobal
++
++dict_ldap.c: ../util/dict_ldap.c
++ ln -f $? $@
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)
+- $(RANLIB) $(LIB_DIR)/$(LIB)
+
+-update: $(LIB_DIR)/$(LIB) $(HDRS)
++$(LIB_DIR)/$(LDAPSO): $(LDAPSO)
++ cp $(LDAPSO) $(LIB_DIR)
++
++$(LIB_DIR)/$(MYSQLSO): $(MYSQLSO)
++ cp $(MYSQLSO) $(LIB_DIR)
++
++update: $(LIB_DIR)/$(LIB) $(LIB_DIR)/${LDAPSO} $(LIB_DIR)/${MYSQLSO} $(LIB_DIR)/${PGSQLSO} $(HDRS)
+ -for i in $(HDRS); \
+ do \
+ cmp -s $$i $(INC_DIR)/$$i 2>/dev/null || cp $$i $(INC_DIR); \
+@@ -360,7 +379,7 @@
+ lint $(DEFS) $(SRCS) $(LINTFIX)
+
+ clean:
+- rm -f *.o $(LIB) *core $(TESTPROG) junk
++ rm -f *.o $(LIB) $(LDAPSO) $(MYSQLSO) $(PGSQLSO) dict_ldap.c *core $(TESTPROG) junk
+ rm -rf printfck
+
+ tidy: clean
+@@ -575,6 +594,8 @@
+ dict_proxy.o: mail_params.h
+ dict_proxy.o: clnt_stream.h
+ dict_proxy.o: dict_proxy.h
++dict_ldap.o: dict_ldap.c
++dict_ldap.o: ../../include/sys_defs.h
+ domain_list.o: domain_list.c
+ domain_list.o: ../../include/sys_defs.h
+ domain_list.o: ../../include/match_list.h
+diff -dur postfix-2.1.3.orig/src/global/mail_conf.c postfix-2.1.3/src/global/mail_conf.c
+--- postfix-2.1.3.orig/src/global/mail_conf.c 2004-04-10 16:52:51.000000000 +0200
++++ postfix-2.1.3/src/global/mail_conf.c 2004-06-22 14:46:14.464367998 +0200
@@ -175,6 +175,13 @@
path = concatenate(var_config_dir, "/", "main.cf", (char *) 0);
dict_load_file(CONFIG_DICT, path);
@@ -51,9 +111,10 @@
}
/* mail_conf_eval - expand macros in string */
---- postfix-2.0.16.orig/src/global/mail_params.c 2003-11-08 19:49:41.000000000 +0100
-+++ postfix-2.0.16/src/global/mail_params.c 2003-11-08 19:52:14.000000000 +0100
-@@ -148,6 +148,8 @@
+diff -dur postfix-2.1.3.orig/src/global/mail_params.c postfix-2.1.3/src/global/mail_params.c
+--- postfix-2.1.3.orig/src/global/mail_params.c 2004-06-22 14:45:16.890729111 +0200
++++ postfix-2.1.3/src/global/mail_params.c 2004-06-22 14:46:14.465367939 +0200
+@@ -154,6 +154,8 @@
#ifdef HAS_DB
#include <dict_db.h>
#endif
@@ -62,7 +123,7 @@
/* Global library. */
-@@ -257,6 +259,7 @@
+@@ -270,6 +272,7 @@
char *var_debug_peer_list;
int var_debug_peer_level;
char *var_reject_reply_msg_access_denied;
@@ -70,7 +131,7 @@
int var_fault_inj_code;
char *var_bounce_service;
char *var_cleanup_service;
-@@ -439,6 +442,38 @@
+@@ -456,6 +459,38 @@
(long) var_sgid_gid);
}
@@ -109,7 +170,7 @@
/* mail_params_init - configure built-in parameters */
void mail_params_init()
-@@ -601,6 +636,9 @@
+@@ -632,6 +667,9 @@
* Variables that are needed by almost every program.
*/
get_mail_conf_str_table(other_str_defaults);
@@ -119,91 +180,128 @@
get_mail_conf_int_table(other_int_defaults);
get_mail_conf_bool_table(bool_defaults);
get_mail_conf_time_table(time_defaults);
---- postfix-2.0.16.orig/src/global/Makefile.in 2003-11-08 19:49:41.000000000 +0100
-+++ postfix-2.0.16/src/global/Makefile.in 2003-11-08 19:52:14.000000000 +0100
-@@ -83,8 +83,9 @@
+diff -dur postfix-2.1.3.orig/src/master/Makefile.in postfix-2.1.3/src/master/Makefile.in
+--- postfix-2.1.3.orig/src/master/Makefile.in 2004-04-22 21:37:35.000000000 +0200
++++ postfix-2.1.3/src/master/Makefile.in 2004-06-22 14:46:14.476367297 +0200
+@@ -20,7 +20,7 @@
+ INC_DIR = ../../include
+ BIN_DIR = ../../libexec
+
+-.c.o:; $(CC) $(CFLAGS) -c $*.c
++.c.o:; $(CC) `for i in $(LIB_OBJ); do [ $$i = $@ ] && echo -fPIC; done` $(CFLAGS) -c $*.c
+
+ all: $(PROG) $(LIB)
+
+@@ -35,12 +35,10 @@
+ tests: test
+
+ $(LIB): $(LIB_OBJ)
+- $(AR) $(ARFL) $(LIB) $?
+- $(RANLIB) $(LIB)
++ gcc -shared -Wl,-soname,libpostfix-master.so.1 -o $(LIB) $(LIB_OBJ)
+
+ $(LIB_DIR)/$(LIB): $(LIB)
+ cp $(LIB) $(LIB_DIR)/$(LIB)
+- $(RANLIB) $(LIB_DIR)/$(LIB)
+
+ $(BIN_DIR)/$(PROG): $(PROG)
+ cp $(PROG) $(BIN_DIR)
+diff -dur postfix-2.1.3.orig/src/util/Makefile.in postfix-2.1.3/src/util/Makefile.in
+--- postfix-2.1.3.orig/src/util/Makefile.in 2004-06-22 14:45:16.750737282 +0200
++++ postfix-2.1.3/src/util/Makefile.in 2004-06-22 14:56:54.100013561 +0200
+@@ -30,13 +30,14 @@
+ attr_print_plain.c sane_connect.c neuter.c name_code.c \
+ uppercase.c \
+ get_port.c \
+- dict_sdbm.c sdbm.c
++ dict_sdbm.c sdbm.c \
++ load_lib.c
+ OBJS = alldig.o argv.o argv_split.o attr_print0.o attr_print64.o \
+ attr_scan0.o attr_scan64.o base64_code.o basename.o binhash.o \
+ chroot_uid.o clean_env.o close_on_exec.o concatenate.o ctable.o \
+ dict.o dict_alloc.o dict_db.o dict_dbm.o dict_debug.o dict_env.o \
+ dict_cidr.o dict_ht.o dict_ni.o dict_nis.o \
+- dict_nisplus.o dict_open.o dict_pcre.o dict_regexp.o \
++ dict_nisplus.o dict_open.o dict_regexp.o \
+ dict_static.o dict_tcp.o dict_unix.o dir_forest.o doze.o \
+ duplex_pipe.o environ.o events.o exec_command.o fifo_listen.o \
+ fifo_trigger.o file_limit.o find_inet.o fsspace.o fullname.o \
+@@ -62,7 +63,8 @@
+ attr_print_plain.o sane_connect.o $(STRCASE) neuter.o name_code.o \
+ uppercase.o \
+ get_port.o \
+- dict_sdbm.o sdbm.o
++ dict_sdbm.o sdbm.o \
++ load_lib.o
+ HDRS = argv.h attr.h base64_code.h binhash.h chroot_uid.h clean_env.h \
+ connect.h ctable.h dict.h dict_db.h dict_dbm.h dict_env.h \
+ dict_cidr.h dict_ht.h dict_ni.h dict_nis.h \
+@@ -83,13 +85,15 @@
+ vbuf_print.h vstream.h vstring.h vstring_vstream.h watchdog.h \
+ auto_clnt.h attr_clnt.h sane_connect.h name_code.h \
+ get_port.h \
+- dict_sdbm.h sdbm.h
++ dict_sdbm.h sdbm.h \
++ load_lib.h
+ TESTSRC = fifo_open.c fifo_rdwr_bug.c fifo_rdonly_bug.c select_bug.c \
+ stream_test.c dup2_pass_on_exec.c
+ DEFS = -I. -D$(SYSTYPE)
+ CFLAGS = $(DEBUG) $(OPT) $(DEFS)
+ FILES = Makefile $(SRCS) $(HDRS)
+ INCL =
++PCRESO = dict_pcre.so
+ LIB = libutil.a
+ TESTPROG= dict_open dup2_pass_on_exec events exec_command fifo_open \
+ fifo_rdonly_bug fifo_rdwr_bug fifo_trigger fsspace fullname \
+@@ -102,8 +106,9 @@
+
LIB_DIR = ../../lib
INC_DIR = ../../include
- MAKES =
-+LDAPSO = dict_ldap.so
++LIBS = $(LIB_DIR)/$(LIB) $(LIB_DIR)/$(PCRESO)
-.c.o:; $(CC) $(CFLAGS) -c $*.c
+.c.o:; $(CC) -fPIC $(CFLAGS) -c $*.c
all: $(LIB)
-@@ -94,14 +95,21 @@
+@@ -112,15 +117,19 @@
+
test: $(TESTPROG)
++$(PCRESO): dict_pcre.o
++ gcc -shared -Wl,-soname,dict_pcre.so -o $@ $? -lpcre -L. -lutil
++
$(LIB): $(OBJS)
- $(AR) $(ARFL) $(LIB) $?
- $(RANLIB) $(LIB)
-+ gcc -shared -Wl,-soname,libpostfix-global.so.1 -o $(LIB) $(OBJS)
-+
-+$(LDAPSO): dict_ldap.o
-+ gcc -shared -Wl,-soname,dict_ldap.so -o $@ $? -lldap -llber -L../../lib -lutil -L. -lglobal
-+
-+dict_ldap.c: ../util/dict_ldap.c
-+ ln -f $? $@
++ gcc -shared -Wl,-soname,libpostfix-util.so.1 -o $(LIB) $(OBJS) -ldl
$(LIB_DIR)/$(LIB): $(LIB)
cp $(LIB) $(LIB_DIR)
- $(RANLIB) $(LIB_DIR)/$(LIB)
-update: $(LIB_DIR)/$(LIB) $(HDRS)
-+$(LIB_DIR)/$(LDAPSO): $(LDAPSO)
-+ cp $(LDAPSO) $(LIB_DIR)
++$(LIB_DIR)/$(PCRESO): $(PCRESO)
++ cp $(PCRESO) $(LIB_DIR)
+
-+update: $(LIB_DIR)/$(LIB) $(LIB_DIR)/${LDAPSO} $(HDRS)
++update: $(LIBS) $(HDRS)
-for i in $(HDRS); \
do \
cmp -s $$i $(INC_DIR)/$$i 2>/dev/null || cp $$i $(INC_DIR); \
-@@ -333,7 +341,7 @@
- lint $(DEFS) $(SRCS) $(LINTFIX)
+@@ -142,7 +151,8 @@
+ lint $(SRCS)
clean:
-- rm -f *.o $(LIB) *core $(TESTPROG) junk
-+ rm -f *.o $(LIB) $(LDAPSO) dict_ldap.c *core $(TESTPROG) junk
+- rm -f *.o $(LIB) *core $(TESTPROG) junk $(MAKES) *.tmp
++ rm -f *.o $(LIB) $(PCRESO) *core $(TESTPROG) \
++ junk $(MAKES) *.tmp
rm -rf printfck
tidy: clean
-@@ -508,6 +516,8 @@
- dict_proxy.o: mail_params.h
- dict_proxy.o: clnt_stream.h
- dict_proxy.o: dict_proxy.h
-+dict_ldap.o: dict_ldap.c
-+dict_ldap.o: ../../include/sys_defs.h
- domain_list.o: domain_list.c
- domain_list.o: ../../include/sys_defs.h
- domain_list.o: ../../include/match_list.h
---- postfix-2.0.16.orig/src/master/Makefile.in 2003-09-14 02:04:02.000000000 +0200
-+++ postfix-2.0.16/src/master/Makefile.in 2003-11-08 19:52:14.000000000 +0100
-@@ -23,7 +23,7 @@
- INC_DIR = ../../include
- BIN_DIR = ../../libexec
-
--.c.o:; $(CC) $(CFLAGS) -c $*.c
-+.c.o:; $(CC) `for i in $(LIB_OBJ); do [ $$i = $@ ] && echo -fPIC; done` $(CFLAGS) -c $*.c
-
- all: $(PROG) $(LIB)
-
-@@ -38,12 +38,10 @@
- tests: test
-
- $(LIB): $(LIB_OBJ)
-- $(AR) $(ARFL) $(LIB) $?
-- $(RANLIB) $(LIB)
-+ gcc -shared -Wl,-soname,libpostfix-master.so.1 -o $(LIB) $(LIB_OBJ)
-
- $(LIB_DIR)/$(LIB): $(LIB)
- cp $(LIB) $(LIB_DIR)/$(LIB)
-- $(RANLIB) $(LIB_DIR)/$(LIB)
-
- $(BIN_DIR)/$(PROG): $(PROG)
- cp $(PROG) $(BIN_DIR)
---- postfix-2.0.16.orig/src/util/dict.h 2003-01-05 02:03:28.000000000 +0100
-+++ postfix-2.0.16/src/util/dict.h 2003-11-08 19:52:14.000000000 +0100
-@@ -80,6 +80,20 @@
+diff -dur postfix-2.1.3.orig/src/util/dict.h postfix-2.1.3/src/util/dict.h
+--- postfix-2.1.3.orig/src/util/dict.h 2003-07-03 17:04:13.000000000 +0200
++++ postfix-2.1.3/src/util/dict.h 2004-06-22 14:46:14.477367239 +0200
+@@ -82,6 +82,20 @@
*/
extern ARGV *dict_mapnames(void);
@@ -224,8 +322,9 @@
/*
* High-level interface, with logical dictionary names.
*/
---- postfix-2.0.16.orig/src/util/dict_open.c 2003-11-08 19:49:41.000000000 +0100
-+++ postfix-2.0.16/src/util/dict_open.c 2003-11-08 19:52:14.000000000 +0100
+diff -dur postfix-2.1.3.orig/src/util/dict_open.c postfix-2.1.3/src/util/dict_open.c
+--- postfix-2.1.3.orig/src/util/dict_open.c 2004-06-22 14:45:16.754737049 +0200
++++ postfix-2.1.3/src/util/dict_open.c 2004-06-22 14:46:14.478367180 +0200
@@ -158,6 +158,9 @@
#include <strings.h>
#endif
@@ -381,297 +480,12 @@
#ifdef TEST
/*
---- postfix-2.0.16.orig/src/util/load_lib.c 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/src/util/load_lib.c 2003-11-08 19:52:14.000000000 +0100
-@@ -0,0 +1,135 @@
-+/*++
-+/* NAME
-+/* load_lib 3
-+/* SUMMARY
-+/* library loading wrappers
-+/* SYNOPSIS
-+/* #include <load_lib.h>
-+/*
-+/* extern int load_library_symbols(const char *, LIB_FN *, LIB_FN *);
-+/* const char *libname;
-+/* LIB_FN *libfuncs;
-+/* LIB_FN *libdata;
-+/*
-+/* DESCRIPTION
-+/* This module loads functions from libraries, returnine pointers
-+/* to the named functions.
-+/*
-+/* load_library_symbols() loads all of the desired functions, and
-+/* returns zero for success, or exits via msg_fatal().
-+/*
-+/* SEE ALSO
-+/* msg(3) diagnostics interface
-+/* DIAGNOSTICS
-+/* Problems are reported via the msg(3) diagnostics routines:
-+/* library not found, symbols not found, other fatal errors.
-+/* LICENSE
-+/* .ad
-+/* .fi
-+/* The Secure Mailer license must be distributed with this software.
-+/* AUTHOR(S)
-+/* LaMont Jones
-+/* Hewlett-Packard Company
-+/* 3404 Harmony Road
-+/* Fort Collins, CO 80528, USA
-+/*
-+/* Wietse Venema
-+/* IBM T.J. Watson Research
-+/* P.O. Box 704
-+/* Yorktown Heights, NY 10598, USA
-+/*--*/
-+
-+/* System libraries. */
-+
-+#include "sys_defs.h"
-+#include <stdlib.h>
-+#include <stddef.h>
-+#include <string.h>
-+#if defined(HAS_DLOPEN)
-+#include <dlfcn.h>
-+#elif defined(HAS_SHL_LOAD)
-+#include <dl.h>
-+#endif
-+
-+/* Application-specific. */
-+
-+#include "msg.h"
-+#include "load_lib.h"
-+
-+extern int load_library_symbols(const char * libname, LIB_FN * libfuncs, LIB_FN * libdata)
-+{
-+ char *myname = "load_library_symbols";
-+ LIB_FN *fn;
-+
-+#if defined(HAS_DLOPEN)
-+ void *handle;
-+ char *emsg;
-+
-+ handle=dlopen(libname,RTLD_NOW);
-+ emsg=dlerror();
-+ if (emsg) {
-+ msg_fatal("%s: dlopen failure loading %s: %s", myname, libname, emsg);
-+ }
-+
-+ if (libfuncs) {
-+ for (fn=libfuncs; fn->name; fn++) {
-+ *(fn->ptr) = dlsym(handle,fn->name);
-+ emsg=dlerror();
-+ if (emsg) {
-+ msg_fatal("%s: dlsym failure looking up %s in %s: %s", myname,
-+ fn->name, libname, emsg);
-+ }
-+ if (msg_verbose>1) {
-+ msg_info("loaded %s = %lx",fn->name, *((long*)(fn->ptr)));
-+ }
-+ }
-+ }
-+
-+ if (libdata) {
-+ for (fn=libdata; fn->name; fn++) {
-+ *(fn->ptr) = dlsym(handle,fn->name);
-+ emsg=dlerror();
-+ if (emsg) {
-+ msg_fatal("%s: dlsym failure looking up %s in %s: %s", myname,
-+ fn->name, libname, emsg);
-+ }
-+ if (msg_verbose>1) {
-+ msg_info("loaded %s = %lx",fn->name, *((long*)(fn->ptr)));
-+ }
-+ }
-+ }
-+#elif defined(HAS_SHL_LOAD)
-+ shl_t handle;
-+
-+ handle = shl_load(libname,BIND_IMMEDIATE,0);
-+
-+ if (libfuncs) {
-+ for (fn=libfuncs; fn->name; fn++) {
-+ if (shl_findsym(&handle,fn->name,TYPE_PROCEDURE,fn->ptr) != 0) {
-+ msg_fatal("%s: shl_findsym failure looking up %s in %s: %m",
-+ myname, fn->name, libname);
-+ }
-+ if (msg_verbose>1) {
-+ msg_info("loaded %s = %x",fn->name, *((long*)(fn->ptr)));
-+ }
-+ }
-+ }
-+
-+ if (libdata) {
-+ for (fn=libdata; fn->name; fn++) {
-+ if (shl_findsym(&handle,fn->name,TYPE_DATA,fn->ptr) != 0) {
-+ msg_fatal("%s: shl_findsym failure looking up %s in %s: %m",
-+ myname, fn->name, libname);
-+ }
-+ if (msg_verbose>1) {
-+ msg_info("loaded %s = %x",fn->name, *((long*)(fn->ptr)));
-+ }
-+ }
-+ }
-+
-+#else
-+ msg_fatal("%s: need dlopen or shl_load support for dynamic libraries",
-+ myname);
-+#endif
-+ return 0;
-+}
---- postfix-2.0.16.orig/src/util/load_lib.h 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/src/util/load_lib.h 2003-11-08 19:52:14.000000000 +0100
-@@ -0,0 +1,41 @@
-+#ifndef _LOAD_LIB_H_INCLUDED_
-+#define _LOAD_LIB_H_INCLUDED_
-+
-+/*++
-+/* NAME
-+/* load_lib 3h
-+/* SUMMARY
-+/* library loading wrappers
-+/* SYNOPSIS
-+/* #include "load_lib.h"
-+/* DESCRIPTION
-+/* .nf
-+
-+ /*
-+ * External interface.
-+ */
-+/* NULL name terminates list */
-+typedef struct LIB_FN {
-+ const char *name;
-+ void **ptr;
-+} LIB_FN;
-+
-+extern int load_library_symbols(const char *, LIB_FN *, LIB_FN *);
-+
-+/* LICENSE
-+/* .ad
-+/* .fi
-+/* The Secure Mailer license must be distributed with this software.
-+/* AUTHOR(S)
-+/* LaMont Jones
-+/* Hewlett-Packard Company
-+/* 3404 Harmony Road
-+/* Fort Collins, CO 80528, USA
-+/*
-+/* Wietse Venema
-+/* IBM T.J. Watson Research
-+/* P.O. Box 704
-+/* Yorktown Heights, NY 10598, USA
-+/*--*/
-+
-+#endif
---- postfix-2.0.16.orig/src/util/Makefile.in 2003-11-08 19:49:41.000000000 +0100
-+++ postfix-2.0.16/src/util/Makefile.in 2003-11-08 19:55:55.000000000 +0100
-@@ -3,7 +3,7 @@
- attr_scan0.c attr_scan64.c base64_code.c basename.c binhash.c \
- chroot_uid.c clean_env.c close_on_exec.c concatenate.c ctable.c \
- dict.c dict_alloc.c dict_db.c dict_dbm.c dict_debug.c dict_env.c \
-- dict_ht.c dict_ldap.c dict_mysql.c dict_ni.c dict_nis.c \
-+ dict_ht.c dict_mysql.c dict_ni.c dict_nis.c \
- dict_nisplus.c dict_open.c dict_pcre.c dict_regexp.c dict_static.c \
- dict_tcp.c dict_unix.c dir_forest.c doze.c duplex_pipe.c \
- environ.c events.c exec_command.c fifo_listen.c fifo_trigger.c \
-@@ -27,13 +27,13 @@
- valid_hostname.c vbuf.c vbuf_print.c vstream.c vstream_popen.c \
- vstring.c vstring_vstream.c watchdog.c writable.c write_buf.c \
- write_wait.c strcasecmp.c nvtable.c host_port.c sane_connect.c \
-- dict_sdbm.c sdbm.c
-+ dict_sdbm.c sdbm.c load_lib.c
- OBJS = alldig.o argv.o argv_split.o attr_print0.o attr_print64.o \
- attr_scan0.o attr_scan64.o base64_code.o basename.o binhash.o \
- chroot_uid.o clean_env.o close_on_exec.o concatenate.o ctable.o \
- dict.o dict_alloc.o dict_db.o dict_dbm.o dict_debug.o dict_env.o \
-- dict_ht.o dict_ldap.o dict_mysql.o dict_ni.o dict_nis.o \
-- dict_nisplus.o dict_open.o dict_pcre.o dict_regexp.o dict_static.o \
-+ dict_ht.o dict_ni.o dict_nis.o \
-+ dict_nisplus.o dict_open.o dict_regexp.o dict_static.o \
- dict_tcp.o dict_unix.o dir_forest.o doze.o duplex_pipe.o \
- environ.o events.o exec_command.o fifo_listen.o fifo_trigger.o \
- file_limit.o find_inet.o fsspace.o fullname.o get_domainname.o \
-@@ -56,7 +56,7 @@
- valid_hostname.o vbuf.o vbuf_print.o vstream.o vstream_popen.o \
- vstring.o vstring_vstream.o watchdog.o writable.o write_buf.o \
- write_wait.o nvtable.o host_port.o sane_connect.o $(STRCASE) \
-- dict_sdbm.o sdbm.o
-+ dict_sdbm.o sdbm.o load_lib.o
- HDRS = argv.h attr.h base64_code.h binhash.h chroot_uid.h clean_env.h \
- connect.h ctable.h dict.h dict_db.h dict_dbm.h dict_env.h \
- dict_ht.h dict_ldap.h dict_mysql.h dict_ni.h dict_nis.h \
-@@ -75,7 +75,7 @@
- timed_wait.h trigger.h username.h valid_hostname.h vbuf.h \
- vbuf_print.h vstream.h vstring.h vstring_vstream.h watchdog.h \
- nvtable.h host_port.h sane_connect.h \
-- dict_sdbm.h sdbm.h
-+ dict_sdbm.h sdbm.h load_lib.h
- TESTSRC = fifo_open.c fifo_rdwr_bug.c fifo_rdonly_bug.c select_bug.c \
- stream_test.c dup2_pass_on_exec.c
- WARN = -W -Wformat -Wimplicit -Wmissing-prototypes \
-@@ -84,6 +84,8 @@
- CFLAGS = $(DEBUG) $(OPT) $(DEFS)
- FILES = Makefile $(SRCS) $(HDRS)
- INCL =
-+PCRESO = dict_pcre.so
-+MYSQLSO = dict_mysql.so
- LIB = libutil.a
- TESTPROG= dict_open dup2_pass_on_exec events exec_command fifo_open \
- fifo_rdonly_bug fifo_rdwr_bug fifo_trigger fsspace fullname \
-@@ -96,8 +98,9 @@
-
- LIB_DIR = ../../lib
- INC_DIR = ../../include
-+LIBS = $(LIB_DIR)/$(LIB) $(LIB_DIR)/$(PCRESO) $(LIB_DIR)/$(MYSQLSO)
-
--.c.o:; $(CC) $(CFLAGS) -c $*.c
-+.c.o:; $(CC) -fPIC $(CFLAGS) -c $*.c
-
- all: $(LIB)
-
-@@ -106,15 +109,25 @@
-
- test: $(TESTPROG)
-
-+$(PCRESO): dict_pcre.o
-+ gcc -shared -Wl,-soname,dict_pcre.so -o $@ $? -lpcre -L. -lutil
-+
-+$(MYSQLSO): dict_mysql.o
-+ gcc -shared -Wl,-soname,dict_mysql.so -o $@ $? -lmysqlclient -L. -lutil
-+
- $(LIB): $(OBJS)
-- $(AR) $(ARFL) $(LIB) $?
-- $(RANLIB) $(LIB)
-+ gcc -shared -Wl,-soname,libpostfix-util.so.1 -o $(LIB) $(OBJS) -ldl
-
- $(LIB_DIR)/$(LIB): $(LIB)
- cp $(LIB) $(LIB_DIR)
-- $(RANLIB) $(LIB_DIR)/$(LIB)
-
--update: $(LIB_DIR)/$(LIB) $(HDRS)
-+$(LIB_DIR)/$(PCRESO): $(PCRESO)
-+ cp $(PCRESO) $(LIB_DIR)
-+
-+$(LIB_DIR)/$(MYSQLSO): $(MYSQLSO)
-+ cp $(MYSQLSO) $(LIB_DIR)
-+
-+update: $(LIBS) $(HDRS)
- -for i in $(HDRS); \
- do \
- cmp -s $$i $(INC_DIR)/$$i 2>/dev/null || cp $$i $(INC_DIR); \
-@@ -136,7 +149,8 @@
- lint $(SRCS)
-
- clean:
-- rm -f *.o $(LIB) *core $(TESTPROG) junk $(MAKES) *.tmp
-+ rm -f *.o $(LIB) $(PCRESO) $(MYSQLSO) *core $(TESTPROG) \
-+ junk $(MAKES) *.tmp
- rm -rf printfck
-
- tidy: clean
---- postfix-2.0.16.orig/src/util/sys_defs.h 2003-11-08 19:49:41.000000000 +0100
-+++ postfix-2.0.16/src/util/sys_defs.h 2003-11-08 19:52:14.000000000 +0100
-@@ -501,6 +501,7 @@
+Only in postfix-2.1.3/src/util: load_lib.c
+Only in postfix-2.1.3/src/util: load_lib.h
+diff -dur postfix-2.1.3.orig/src/util/sys_defs.h postfix-2.1.3/src/util/sys_defs.h
+--- postfix-2.1.3.orig/src/util/sys_defs.h 2004-06-22 14:45:16.861730803 +0200
++++ postfix-2.1.3/src/util/sys_defs.h 2004-06-22 14:46:14.494366246 +0200
+@@ -560,6 +560,7 @@
#define UNIX_DOMAIN_CONNECT_BLOCKS_FOR_ACCEPT
#define PREPEND_PLUS_TO_OPTSTRING
#define HAS_POSIX_REGEXP
@@ -679,7 +493,7 @@
#define NATIVE_SENDMAIL_PATH "/usr/sbin/sendmail"
#define NATIVE_MAILQ_PATH "/usr/bin/mailq"
#define NATIVE_NEWALIAS_PATH "/usr/bin/newaliases"
-@@ -529,6 +530,7 @@
+@@ -596,6 +597,7 @@
#define UNIX_DOMAIN_CONNECT_BLOCKS_FOR_ACCEPT /* unverified */
#define PREPEND_PLUS_TO_OPTSTRING
#define HAS_POSIX_REGEXP
@@ -687,7 +501,7 @@
#define NATIVE_SENDMAIL_PATH "/usr/sbin/sendmail"
#define NATIVE_MAILQ_PATH "/usr/bin/mailq"
#define NATIVE_NEWALIAS_PATH "/usr/bin/newaliases"
-@@ -567,6 +569,7 @@
+@@ -638,6 +640,7 @@
#define USE_STATFS
#define STATFS_IN_SYS_VFS_H
#define HAS_POSIX_REGEXP
@@ -695,7 +509,7 @@
#define NATIVE_SENDMAIL_PATH "/usr/sbin/sendmail"
#define NATIVE_MAILQ_PATH "/usr/bin/mailq"
#define NATIVE_NEWALIAS_PATH "/usr/bin/newaliases"
-@@ -602,6 +605,7 @@
+@@ -673,6 +676,7 @@
#define USE_STATFS
#define STATFS_IN_SYS_VFS_H
#define HAS_POSIX_REGEXP
diff --git a/postfix-master.cf_cyrus.patch b/postfix-master.cf_cyrus.patch
index 4e4ca14..f3ea7f4 100644
--- a/postfix-master.cf_cyrus.patch
+++ b/postfix-master.cf_cyrus.patch
@@ -1,12 +1,14 @@
---- postfix-1.1.2/conf/master.cf.old 2002-03-02 20:13:56.000000000 -0300
-+++ postfix-1.1.2/conf/master.cf 2002-05-02 21:44:39.000000000 -0300
-@@ -107,10 +107,10 @@
+diff -dur postfix-2.1.3.orig/conf/master.cf postfix-2.1.3/conf/master.cf
+--- postfix-2.1.3.orig/conf/master.cf 2004-06-22 14:59:49.976722670 +0200
++++ postfix-2.1.3/conf/master.cf 2004-06-22 15:03:29.362874731 +0200
+@@ -116,11 +116,11 @@
# The Cyrus deliver program has changed incompatibly, multiple times.
#
old-cyrus unix - n n - - pipe
- flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
+ flags=R user=cyrus argv=/usr/lib/cyrus/deliver -e -m ${extension} ${user}
# Cyrus 2.1.5 (Amos Gouaux)
+ # Also specify in main.cf: cyrus_destination_recipient_limit=1
cyrus unix - n n - - pipe
- user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
+ user=cyrus argv=/usr/lib/cyrus/deliver -e -r ${sender} -m ${extension} ${user}