summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJacek Konieczny2004-01-07 17:43:10 (GMT)
committercvs2git2012-06-24 12:13:13 (GMT)
commit9e602738f8417d924b2c5fdc0c622a979a4ac7f9 (patch)
tree7ab99fecea302a44b05c12db2cdce6ceba132cd2
parentb6a98e19e93b63a63f3d4d5fd51e71f358b705d5 (diff)
downloadpostfix-9e602738f8417d924b2c5fdc0c622a979a4ac7f9.zip
postfix-9e602738f8417d924b2c5fdc0c622a979a4ac7f9.tar.gz
-"implicit declaration of function" and "assignment makes pointer from integer without a cast" warnings killed - some of them are fatal errors for code compiled on AMD64!!!
Changed files: postfix-ipv6.patch -> 1.25
-rw-r--r--postfix-ipv6.patch249
1 files changed, 146 insertions, 103 deletions
diff --git a/postfix-ipv6.patch b/postfix-ipv6.patch
index 09a00af..f2bff74 100644
--- a/postfix-ipv6.patch
+++ b/postfix-ipv6.patch
@@ -1,5 +1,6 @@
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/makedefs postfix-2.0.16/makedefs
--- postfix-2.0.16.orig/makedefs 2003-01-23 14:45:02.000000000 +0100
-+++ postfix-2.0.16/makedefs 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/makedefs 2005-01-07 18:25:30.197331464 +0100
@@ -52,6 +52,21 @@
SYSTEM=`(uname -s) 2>/dev/null`
RELEASE=`(uname -r) 2>/dev/null`
@@ -49,8 +50,9 @@
export SYSTYPE AR ARFL RANLIB SYSLIBS CC OPT DEBUG AWK OPTS
sed 's/ / /g' <<EOF
---- postfix-2.0.16.orig/src/global/Makefile.in 2003-11-08 20:17:08.000000000 +0100
-+++ postfix-2.0.16/src/global/Makefile.in 2003-11-08 20:22:55.000000000 +0100
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/Makefile.in postfix-2.0.16/src/global/Makefile.in
+--- postfix-2.0.16.orig/src/global/Makefile.in 2005-01-07 18:22:25.286442192 +0100
++++ postfix-2.0.16/src/global/Makefile.in 2005-01-07 18:25:30.198331312 +0100
@@ -19,7 +19,7 @@
timed_ipc.c tok822_find.c tok822_node.c tok822_parse.c \
tok822_resolve.c tok822_rewrite.c tok822_tree.c xtext.c bounce_log.c \
@@ -78,9 +80,10 @@
lex_822.h strip_addr.h virtual8_maps.h hold_message.h dict_proxy.h \
mail_dict.h pfixtls.h
TESTSRC = rec2stream.c stream2rec.c recdump.c
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/mynetworks.c postfix-2.0.16/src/global/mynetworks.c
--- postfix-2.0.16.orig/src/global/mynetworks.c 2001-02-25 02:46:07.000000000 +0100
-+++ postfix-2.0.16/src/global/mynetworks.c 2003-11-08 20:22:55.000000000 +0100
-@@ -50,6 +50,11 @@
++++ postfix-2.0.16/src/global/mynetworks.c 2005-01-07 18:32:30.872379136 +0100
+@@ -50,6 +50,12 @@
#include <vstring.h>
#include <inet_addr_list.h>
#include <name_mask.h>
@@ -89,10 +92,11 @@
+#include <netinet/in.h>
+#include <netdb.h>
+#endif
++#include <string.h>
/* Global library. */
-@@ -75,6 +80,9 @@
+@@ -75,6 +81,9 @@
const char *mynetworks(void)
{
static VSTRING *result;
@@ -102,7 +106,7 @@
if (result == 0) {
char *myname = "mynetworks";
-@@ -87,6 +95,13 @@
+@@ -87,6 +96,13 @@
int junk;
int i;
int mask_style;
@@ -116,7 +120,7 @@
mask_style = name_mask("mynetworks mask style", mask_styles,
var_mynetworks_style);
-@@ -96,8 +111,45 @@
+@@ -96,8 +112,45 @@
my_mask_list = own_inet_mask_list();
for (i = 0; i < my_addr_list->used; i++) {
@@ -162,7 +166,7 @@
switch (mask_style) {
-@@ -119,8 +171,15 @@
+@@ -119,8 +172,15 @@
mask = IN_CLASSD_NET;
shift = IN_CLASSD_NSHIFT;
} else {
@@ -178,7 +182,7 @@
}
break;
-@@ -146,6 +205,18 @@
+@@ -146,6 +206,18 @@
var_mynetworks_style);
}
net.s_addr = htonl(addr & mask);
@@ -197,8 +201,9 @@
vstring_sprintf_append(result, "%s/%d ",
inet_ntoa(net), BITS_PER_ADDR - shift);
}
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/own_inet_addr.c postfix-2.0.16/src/global/own_inet_addr.c
--- postfix-2.0.16.orig/src/global/own_inet_addr.c 2002-10-25 01:19:19.000000000 +0200
-+++ postfix-2.0.16/src/global/own_inet_addr.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/own_inet_addr.c 2005-01-07 18:25:30.198331312 +0100
@@ -50,6 +50,10 @@
#include <netinet/in.h>
#include <arpa/inet.h>
@@ -371,8 +376,9 @@
/* proxy_inet_addr_list - return list of addresses */
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/own_inet_addr.h postfix-2.0.16/src/global/own_inet_addr.h
--- postfix-2.0.16.orig/src/global/own_inet_addr.h 2002-10-25 01:07:05.000000000 +0200
-+++ postfix-2.0.16/src/global/own_inet_addr.h 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/own_inet_addr.h 2005-01-07 18:25:30.199331160 +0100
@@ -15,14 +15,25 @@
* System library.
*/
@@ -399,8 +405,9 @@
extern struct INET_ADDR_LIST *proxy_inet_addr_list(void);
/* LICENSE
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/peer_name.c postfix-2.0.16/src/global/peer_name.c
--- postfix-2.0.16.orig/src/global/peer_name.c 2001-01-28 16:23:02.000000000 +0100
-+++ postfix-2.0.16/src/global/peer_name.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/peer_name.c 2005-01-07 18:25:30.199331160 +0100
@@ -69,12 +69,32 @@
PEER_NAME *peer_name(int sock)
{
@@ -463,8 +470,9 @@
case AF_UNSPEC:
case AF_UNIX:
peer.type = PEER_TYPE_LOCAL;
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/peer_name.h postfix-2.0.16/src/global/peer_name.h
--- postfix-2.0.16.orig/src/global/peer_name.h 1998-12-11 19:55:32.000000000 +0100
-+++ postfix-2.0.16/src/global/peer_name.h 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/peer_name.h 2005-01-07 18:25:30.199331160 +0100
@@ -22,6 +22,9 @@
#define PEER_TYPE_UNKNOWN 0
#define PEER_TYPE_INET 1
@@ -475,8 +483,9 @@
extern PEER_NAME *peer_name(int);
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/resolve_local.c postfix-2.0.16/src/global/resolve_local.c
--- postfix-2.0.16.orig/src/global/resolve_local.c 2002-10-25 01:21:20.000000000 +0200
-+++ postfix-2.0.16/src/global/resolve_local.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/resolve_local.c 2005-01-07 18:25:30.199331160 +0100
@@ -43,6 +43,7 @@
#include <netinet/in.h>
#include <arpa/inet.h>
@@ -524,8 +533,9 @@
}
/*
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/wildcard_inet_addr.c postfix-2.0.16/src/global/wildcard_inet_addr.c
--- postfix-2.0.16.orig/src/global/wildcard_inet_addr.c 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/src/global/wildcard_inet_addr.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/wildcard_inet_addr.c 2005-01-07 18:25:30.200331008 +0100
@@ -0,0 +1,82 @@
+/* System library. */
+
@@ -609,8 +619,9 @@
+
+ return (&addr_list);
+}
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/global/wildcard_inet_addr.h postfix-2.0.16/src/global/wildcard_inet_addr.h
--- postfix-2.0.16.orig/src/global/wildcard_inet_addr.h 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/src/global/wildcard_inet_addr.h 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/global/wildcard_inet_addr.h 2005-01-07 18:25:30.200331008 +0100
@@ -0,0 +1,36 @@
+#ifndef _WILDCARD_INET_ADDR_H_INCLUDED_
+#define _WILDCARD_INET_ADDR_H_INCLUDED_
@@ -648,9 +659,18 @@
+/*--*/
+
+#endif
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/master/master_ent.c postfix-2.0.16/src/master/master_ent.c
--- postfix-2.0.16.orig/src/master/master_ent.c 2003-06-18 21:19:46.000000000 +0200
-+++ postfix-2.0.16/src/master/master_ent.c 2003-11-08 20:22:55.000000000 +0100
-@@ -307,8 +307,13 @@
++++ postfix-2.0.16/src/master/master_ent.c 2005-01-07 18:35:28.571364784 +0100
+@@ -92,6 +92,7 @@
+ #include <mail_proto.h>
+ #include <mail_params.h>
+ #include <own_inet_addr.h>
++#include <wildcard_inet_addr.h>
+
+ /* Local stuff. */
+
+@@ -307,8 +308,13 @@
inet_addr_list_uniq(MASTER_INET_ADDRLIST(serv));
serv->listen_fd_count = MASTER_INET_ADDRLIST(serv)->used;
} else if (strcasecmp(saved_interfaces, DEF_INET_INTERFACES) == 0) {
@@ -664,8 +684,9 @@
} else {
MASTER_INET_ADDRLIST(serv) = own_inet_addr_list(); /* virtual */
inet_addr_list_uniq(MASTER_INET_ADDRLIST(serv));
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/master/master_listen.c postfix-2.0.16/src/master/master_listen.c
--- postfix-2.0.16.orig/src/master/master_listen.c 2001-05-01 00:47:57.000000000 +0200
-+++ postfix-2.0.16/src/master/master_listen.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/master/master_listen.c 2005-01-07 18:25:30.201330856 +0100
@@ -64,13 +64,22 @@
#include "master.h"
@@ -727,8 +748,9 @@
}
break;
default:
---- postfix-2.0.16.orig/src/smtp/Makefile.in 2003-11-08 20:17:08.000000000 +0100
-+++ postfix-2.0.16/src/smtp/Makefile.in 2003-11-08 20:22:55.000000000 +0100
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtp/Makefile.in postfix-2.0.16/src/smtp/Makefile.in
+--- postfix-2.0.16.orig/src/smtp/Makefile.in 2005-01-07 18:22:25.253447208 +0100
++++ postfix-2.0.16/src/smtp/Makefile.in 2005-01-07 18:25:30.201330856 +0100
@@ -144,6 +144,7 @@
smtp_connect.o: ../../include/mail_params.h
smtp_connect.o: ../../include/own_inet_addr.h
@@ -737,8 +759,9 @@
smtp_connect.o: smtp.h
smtp_connect.o: ../../include/argv.h
smtp_connect.o: ../../include/deliver_request.h
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtp/smtp_addr.c postfix-2.0.16/src/smtp/smtp_addr.c
--- postfix-2.0.16.orig/src/smtp/smtp_addr.c 2002-10-25 01:03:11.000000000 +0200
-+++ postfix-2.0.16/src/smtp/smtp_addr.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/smtp/smtp_addr.c 2005-01-07 18:25:30.201330856 +0100
@@ -134,18 +134,68 @@
static void smtp_print_addr(char *what, DNS_RR *addr_list)
{
@@ -769,7 +792,7 @@
+ if (addr->class != C_IN) {
+ msg_warn("skipping unsupported address (class=%u)", addr->class);
+ continue;
-+ }
+ }
+ switch (addr->type) {
+ case T_A:
+ if (addr->data_len != sizeof(sin->sin_addr)) {
@@ -804,7 +827,7 @@
+ default:
+ msg_warn("skipping unsupported address (type=%u)", addr->type);
+ continue;
- }
++ }
+
+#ifdef INET6
+ (void)getnameinfo((struct sockaddr *)&ss, SS_LEN(ss),
@@ -976,8 +999,9 @@
}
/*
---- postfix-2.0.16.orig/src/smtp/smtp_connect.c 2003-11-08 20:17:08.000000000 +0100
-+++ postfix-2.0.16/src/smtp/smtp_connect.c 2003-11-08 20:32:33.000000000 +0100
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtp/smtp_connect.c postfix-2.0.16/src/smtp/smtp_connect.c
+--- postfix-2.0.16.orig/src/smtp/smtp_connect.c 2005-01-07 18:22:25.254447056 +0100
++++ postfix-2.0.16/src/smtp/smtp_connect.c 2005-01-07 18:25:30.202330704 +0100
@@ -81,6 +81,7 @@
/* System library. */
@@ -1272,8 +1296,9 @@
}
/* smtp_connect_host - direct connection to host */
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtp/smtp_unalias.c postfix-2.0.16/src/smtp/smtp_unalias.c
--- postfix-2.0.16.orig/src/smtp/smtp_unalias.c 2000-09-28 19:06:09.000000000 +0200
-+++ postfix-2.0.16/src/smtp/smtp_unalias.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/smtp/smtp_unalias.c 2005-01-07 18:25:30.202330704 +0100
@@ -86,7 +86,11 @@
if ((result = htable_find(cache, name)) == 0) {
fqdn = vstring_alloc(10);
@@ -1287,9 +1312,10 @@
vstring_strcpy(fqdn, name);
htable_enter(cache, name, result = vstring_export(fqdn));
}
---- postfix-2.0.16.orig/src/smtpd/smtpd_check.c 2003-11-08 20:17:08.000000000 +0100
-+++ postfix-2.0.16/src/smtpd/smtpd_check.c 2003-11-08 20:22:55.000000000 +0100
-@@ -1369,6 +1369,49 @@
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtpd/smtpd_check.c postfix-2.0.16/src/smtpd/smtpd_check.c
+--- postfix-2.0.16.orig/src/smtpd/smtpd_check.c 2005-01-07 18:22:25.302439760 +0100
++++ postfix-2.0.16/src/smtpd/smtpd_check.c 2005-01-07 18:25:30.218328272 +0100
+@@ -1393,6 +1393,49 @@
static int has_my_addr(SMTPD_STATE *state, const char *host,
const char *reply_name, const char *reply_class)
{
@@ -1339,7 +1365,7 @@
char *myname = "has_my_addr";
struct in_addr addr;
char **cpp;
-@@ -1407,6 +1450,7 @@
+@@ -1431,6 +1474,7 @@
msg_info("%s: host %s: no match", myname, host);
return (NOPE);
@@ -1347,7 +1373,7 @@
}
/* i_am_mx - is this machine listed as MX relay */
-@@ -1991,11 +2035,28 @@
+@@ -2015,11 +2059,28 @@
#define CHK_ADDR_RETURN(x,y) { *found = y; return(x); }
addr = STR(vstring_strcpy(error_text, address));
@@ -1377,7 +1403,7 @@
if ((value = dict_get(dict, addr)) != 0)
CHK_ADDR_RETURN(check_table_result(state, table, value, address,
reply_name, reply_class,
-@@ -2438,16 +2499,32 @@
+@@ -2579,16 +2640,32 @@
VSTRING *query;
int i;
SMTPD_RBL_STATE *rbl;
@@ -1414,8 +1440,9 @@
#endif
/*
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtpd/smtpd_peer.c postfix-2.0.16/src/smtpd/smtpd_peer.c
--- postfix-2.0.16.orig/src/smtpd/smtpd_peer.c 2002-08-22 19:50:51.000000000 +0200
-+++ postfix-2.0.16/src/smtpd/smtpd_peer.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/smtpd/smtpd_peer.c 2005-01-07 18:25:30.205330248 +0100
@@ -63,6 +63,15 @@
#include <netdb.h>
#include <string.h>
@@ -1603,8 +1630,9 @@
}
}
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/smtpstone/smtp-sink.c postfix-2.0.16/src/smtpstone/smtp-sink.c
--- postfix-2.0.16.orig/src/smtpstone/smtp-sink.c 2003-09-13 02:46:56.000000000 +0200
-+++ postfix-2.0.16/src/smtpstone/smtp-sink.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/smtpstone/smtp-sink.c 2005-01-07 18:25:30.205330248 +0100
@@ -607,7 +607,7 @@
} else {
if (strncmp(argv[optind], "inet:", 5) == 0)
@@ -1614,8 +1642,55 @@
}
/*
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/Makefile.in postfix-2.0.16/src/util/Makefile.in
+--- postfix-2.0.16.orig/src/util/Makefile.in 2005-01-07 18:22:25.293441128 +0100
++++ postfix-2.0.16/src/util/Makefile.in 2005-01-07 18:25:30.209329640 +0100
+@@ -8,7 +8,7 @@
+ dict_tcp.c dict_unix.c dir_forest.c doze.c duplex_pipe.c \
+ environ.c events.c exec_command.c fifo_listen.c fifo_trigger.c \
+ file_limit.c find_inet.c fsspace.c fullname.c get_domainname.c \
+- get_hostname.c hex_quote.c htable.c inet_addr_host.c \
++ get_hostname.c get_port.c hex_quote.c htable.c inet_addr_host.c \
+ inet_addr_list.c inet_addr_local.c inet_connect.c inet_listen.c \
+ inet_trigger.c inet_util.c intv.c line_wrap.c lowercase.c \
+ lstat_as.c mac_expand.c mac_parse.c make_dirs.c match_list.c \
+@@ -37,7 +37,7 @@
+ dict_tcp.o dict_unix.o dir_forest.o doze.o duplex_pipe.o \
+ environ.o events.o exec_command.o fifo_listen.o fifo_trigger.o \
+ file_limit.o find_inet.o fsspace.o fullname.o get_domainname.o \
+- get_hostname.o hex_quote.o htable.o inet_addr_host.o \
++ get_hostname.o get_port.o hex_quote.o htable.o inet_addr_host.o \
+ inet_addr_list.o inet_addr_local.o inet_connect.o inet_listen.o \
+ inet_trigger.o inet_util.o intv.o line_wrap.o lowercase.o \
+ lstat_as.o mac_expand.o mac_parse.o make_dirs.o match_list.o \
+@@ -62,7 +62,7 @@
+ dict_ht.h dict_ldap.h dict_mysql.h dict_ni.h dict_nis.h \
+ dict_nisplus.h dict_pcre.h dict_pgsql.h dict_regexp.h dict_static.h dict_tcp.h \
+ dict_unix.h dir_forest.h events.h exec_command.h find_inet.h \
+- fsspace.h fullname.h get_domainname.h get_hostname.h hex_quote.h \
++ fsspace.h fullname.h get_domainname.h get_hostname.h get_port.h hex_quote.h \
+ htable.h inet_addr_host.h inet_addr_list.h inet_addr_local.h \
+ inet_util.h intv.h iostuff.h line_wrap.h listen.h lstat_as.h \
+ mac_expand.h mac_parse.h make_dirs.h match_list.h match_ops.h \
+@@ -785,6 +785,7 @@
+ get_domainname.o: mymalloc.h
+ get_domainname.o: get_hostname.h
+ get_domainname.o: get_domainname.h
++get_port.o: sys_defs.h
+ get_hostname.o: get_hostname.c
+ get_hostname.o: sys_defs.h
+ get_hostname.o: mymalloc.h
+@@ -911,6 +912,7 @@
+ match_list.o: stringops.h
+ match_list.o: argv.h
+ match_list.o: dict.h
++match_list.o: inet_util.h
+ match_list.o: match_ops.h
+ match_list.o: match_list.h
+ match_ops.o: match_ops.c
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/get_port.c postfix-2.0.16/src/util/get_port.c
--- postfix-2.0.16.orig/src/util/get_port.c 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/src/util/get_port.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/get_port.c 2005-01-07 18:25:30.206330096 +0100
@@ -0,0 +1,65 @@
+/*++
+/* NAME
@@ -1682,8 +1757,9 @@
+ /* return empty string */
+ return NULL;
+}
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/get_port.h postfix-2.0.16/src/util/get_port.h
--- postfix-2.0.16.orig/src/util/get_port.h 1970-01-01 01:00:00.000000000 +0100
-+++ postfix-2.0.16/src/util/get_port.h 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/get_port.h 2005-01-07 18:25:30.206330096 +0100
@@ -0,0 +1,28 @@
+#ifndef _GET_PORT_H_INCLUDED_
+#define _GET_PORT_H_INCLUDED_
@@ -1713,9 +1789,10 @@
+/*--*/
+
+#endif
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/inet_addr_host.c postfix-2.0.16/src/util/inet_addr_host.c
--- postfix-2.0.16.orig/src/util/inet_addr_host.c 1998-12-11 19:55:35.000000000 +0100
-+++ postfix-2.0.16/src/util/inet_addr_host.c 2003-11-08 20:22:55.000000000 +0100
-@@ -38,7 +38,10 @@
++++ postfix-2.0.16/src/util/inet_addr_host.c 2005-01-07 18:28:55.469125408 +0100
+@@ -38,7 +38,11 @@
#include <sys_defs.h>
#include <netinet/in.h>
#include <arpa/inet.h>
@@ -1723,10 +1800,11 @@
#include <netdb.h>
+#include <stdlib.h>
+#include <string.h>
++#include <unistd.h>
#ifndef INADDR_NONE
#define INADDR_NONE 0xffffffff
-@@ -48,15 +51,47 @@
+@@ -48,15 +52,47 @@
#include <inet_addr_list.h>
#include <inet_addr_host.h>
@@ -1774,7 +1852,7 @@
if ((addr.s_addr = inet_addr(hostname)) != INADDR_NONE) {
inet_addr_list_append(addr_list, &addr);
} else {
-@@ -65,9 +100,12 @@
+@@ -65,9 +101,12 @@
inet_addr_list_append(addr_list,
(struct in_addr *) * hp->h_addr_list++);
}
@@ -1787,7 +1865,7 @@
#ifdef TEST
#include <msg.h>
-@@ -78,6 +116,8 @@
+@@ -78,6 +117,8 @@
{
INET_ADDR_LIST addr_list;
int i;
@@ -1796,7 +1874,7 @@
msg_vstream_init(argv[0], VSTREAM_ERR);
-@@ -89,8 +129,12 @@
+@@ -89,8 +130,12 @@
if (inet_addr_host(&addr_list, *argv) == 0)
msg_fatal("not found: %s", *argv);
@@ -1811,8 +1889,9 @@
vstream_fflush(VSTREAM_OUT);
}
inet_addr_list_free(&addr_list);
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/inet_addr_list.c postfix-2.0.16/src/util/inet_addr_list.c
--- postfix-2.0.16.orig/src/util/inet_addr_list.c 2001-07-31 20:13:41.000000000 +0200
-+++ postfix-2.0.16/src/util/inet_addr_list.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/inet_addr_list.c 2005-01-07 18:25:30.207329944 +0100
@@ -51,6 +51,13 @@
#include <arpa/inet.h>
#include <stdlib.h>
@@ -1890,8 +1969,9 @@
}
/* inet_addr_list_uniq - weed out duplicates */
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/inet_addr_list.h postfix-2.0.16/src/util/inet_addr_list.h
--- postfix-2.0.16.orig/src/util/inet_addr_list.h 2001-07-31 19:56:47.000000000 +0200
-+++ postfix-2.0.16/src/util/inet_addr_list.h 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/inet_addr_list.h 2005-01-07 18:25:30.207329944 +0100
@@ -16,19 +16,38 @@
*/
#include <netinet/in.h>
@@ -1931,8 +2011,9 @@
/* LICENSE
/* .ad
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/inet_addr_local.c postfix-2.0.16/src/util/inet_addr_local.c
--- postfix-2.0.16.orig/src/util/inet_addr_local.c 2001-02-25 19:20:19.000000000 +0100
-+++ postfix-2.0.16/src/util/inet_addr_local.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/inet_addr_local.c 2005-01-07 18:25:30.207329944 +0100
@@ -47,6 +47,13 @@
#endif
#include <errno.h>
@@ -2033,12 +2114,12 @@
+ struct addrinfo hints, *res, *res0;
+#endif
+ struct sockaddr_in6 addr6;
-+
+
+- if ((sock = socket(PF_INET, SOCK_DGRAM, 0)) < 0)
+other_socket_type:
+#endif
+ buf = vstring_alloc(1024);
-
-- if ((sock = socket(PF_INET, SOCK_DGRAM, 0)) < 0)
++
+ if ((sock = socket(af, SOCK_DGRAM, 0)) < 0) {
+#ifdef INET6
+ if (af == AF_INET6)
@@ -2171,8 +2252,9 @@
}
vstream_fflush(VSTREAM_OUT);
inet_addr_list_free(&addr_list);
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/inet_connect.c postfix-2.0.16/src/util/inet_connect.c
--- postfix-2.0.16.orig/src/util/inet_connect.c 2003-09-13 03:04:12.000000000 +0200
-+++ postfix-2.0.16/src/util/inet_connect.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/inet_connect.c 2005-01-07 18:25:30.208329792 +0100
@@ -55,6 +55,9 @@
#include <string.h>
#include <unistd.h>
@@ -2261,8 +2343,9 @@
}
+#endif
}
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/inet_listen.c postfix-2.0.16/src/util/inet_listen.c
--- postfix-2.0.16.orig/src/util/inet_listen.c 2003-09-13 01:50:50.000000000 +0200
-+++ postfix-2.0.16/src/util/inet_listen.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/inet_listen.c 2005-01-07 18:25:30.208329792 +0100
@@ -6,7 +6,7 @@
/* SYNOPSIS
/* #include <listen.h>
@@ -2420,8 +2503,9 @@
non_blocking(sock, block_mode);
if (listen(sock, backlog) < 0)
msg_fatal("listen: %m");
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/listen.h postfix-2.0.16/src/util/listen.h
--- postfix-2.0.16.orig/src/util/listen.h 1999-03-22 02:57:11.000000000 +0100
-+++ postfix-2.0.16/src/util/listen.h 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/listen.h 2005-01-07 18:25:30.208329792 +0100
@@ -20,7 +20,7 @@
* Listener external interface.
*/
@@ -2431,53 +2515,9 @@
extern int fifo_listen(const char *, int, int);
extern int stream_listen(const char *, int, int);
---- postfix-2.0.16.orig/src/util/Makefile.in 2003-11-08 20:17:08.000000000 +0100
-+++ postfix-2.0.16/src/util/Makefile.in 2003-11-08 20:22:55.000000000 +0100
-@@ -8,7 +8,7 @@
- dict_tcp.c dict_unix.c dir_forest.c doze.c duplex_pipe.c \
- environ.c events.c exec_command.c fifo_listen.c fifo_trigger.c \
- file_limit.c find_inet.c fsspace.c fullname.c get_domainname.c \
-- get_hostname.c hex_quote.c htable.c inet_addr_host.c \
-+ get_hostname.c get_port.c hex_quote.c htable.c inet_addr_host.c \
- inet_addr_list.c inet_addr_local.c inet_connect.c inet_listen.c \
- inet_trigger.c inet_util.c intv.c line_wrap.c lowercase.c \
- lstat_as.c mac_expand.c mac_parse.c make_dirs.c match_list.c \
-@@ -37,7 +37,7 @@
- dict_tcp.o dict_unix.o dir_forest.o doze.o duplex_pipe.o \
- environ.o events.o exec_command.o fifo_listen.o fifo_trigger.o \
- file_limit.o find_inet.o fsspace.o fullname.o get_domainname.o \
-- get_hostname.o hex_quote.o htable.o inet_addr_host.o \
-+ get_hostname.o get_port.o hex_quote.o htable.o inet_addr_host.o \
- inet_addr_list.o inet_addr_local.o inet_connect.o inet_listen.o \
- inet_trigger.o inet_util.o intv.o line_wrap.o lowercase.o \
- lstat_as.o mac_expand.o mac_parse.o make_dirs.o match_list.o \
-@@ -62,7 +62,7 @@
- dict_ht.h dict_ldap.h dict_mysql.h dict_ni.h dict_nis.h \
- dict_nisplus.h dict_pcre.h dict_pgsql.h dict_regexp.h dict_static.h dict_tcp.h \
- dict_unix.h dir_forest.h events.h exec_command.h find_inet.h \
-- fsspace.h fullname.h get_domainname.h get_hostname.h hex_quote.h \
-+ fsspace.h fullname.h get_domainname.h get_hostname.h get_port.h hex_quote.h \
- htable.h inet_addr_host.h inet_addr_list.h inet_addr_local.h \
- inet_util.h intv.h iostuff.h line_wrap.h listen.h lstat_as.h \
- mac_expand.h mac_parse.h make_dirs.h match_list.h match_ops.h \
-@@ -785,6 +785,7 @@
- get_domainname.o: mymalloc.h
- get_domainname.o: get_hostname.h
- get_domainname.o: get_domainname.h
-+get_port.o: sys_defs.h
- get_hostname.o: get_hostname.c
- get_hostname.o: sys_defs.h
- get_hostname.o: mymalloc.h
-@@ -911,6 +912,7 @@
- match_list.o: stringops.h
- match_list.o: argv.h
- match_list.o: dict.h
-+match_list.o: inet_util.h
- match_list.o: match_ops.h
- match_list.o: match_list.h
- match_ops.o: match_ops.c
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/match_list.c postfix-2.0.16/src/util/match_list.c
--- postfix-2.0.16.orig/src/util/match_list.c 2001-11-20 21:07:15.000000000 +0100
-+++ postfix-2.0.16/src/util/match_list.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/match_list.c 2005-01-07 18:25:30.209329640 +0100
@@ -118,7 +118,7 @@
list = match_list_parse(list, vstring_str(buf));
if (vstream_fclose(fp))
@@ -2487,8 +2527,9 @@
for (cp = pattern; *cp == '!'; cp++)
/* void */ ;
if (dict_handle(pattern) == 0)
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/match_ops.c postfix-2.0.16/src/util/match_ops.c
--- postfix-2.0.16.orig/src/util/match_ops.c 2003-04-14 16:44:19.000000000 +0200
-+++ postfix-2.0.16/src/util/match_ops.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/match_ops.c 2005-01-07 18:25:30.210329488 +0100
@@ -81,6 +81,308 @@
#include <match_ops.h>
#include <stringops.h>
@@ -2904,8 +2945,9 @@
+#endif
return (0);
}
---- postfix-2.0.16.orig/src/util/sys_defs.h 2003-11-08 20:17:08.000000000 +0100
-+++ postfix-2.0.16/src/util/sys_defs.h 2003-11-08 20:22:55.000000000 +0100
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/sys_defs.h postfix-2.0.16/src/util/sys_defs.h
+--- postfix-2.0.16.orig/src/util/sys_defs.h 2005-01-07 18:22:25.289441736 +0100
++++ postfix-2.0.16/src/util/sys_defs.h 2005-01-07 18:25:30.211329336 +0100
@@ -73,6 +73,10 @@
#define DEF_MAILBOX_LOCK "flock, dotlock"
#endif
@@ -2917,8 +2959,9 @@
/*
* UNIX on MAC.
*/
+diff -durN -x '*~' -x '*.orig' postfix-2.0.16.orig/src/util/valid_hostname.c postfix-2.0.16/src/util/valid_hostname.c
--- postfix-2.0.16.orig/src/util/valid_hostname.c 2002-12-20 02:33:41.000000000 +0100
-+++ postfix-2.0.16/src/util/valid_hostname.c 2003-11-08 20:22:55.000000000 +0100
++++ postfix-2.0.16/src/util/valid_hostname.c 2005-01-07 18:25:30.211329336 +0100
@@ -53,6 +53,13 @@
#include <string.h>
#include <ctype.h>