summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--phpToDo.spec46
1 files changed, 46 insertions, 0 deletions
diff --git a/phpToDo.spec b/phpToDo.spec
new file mode 100644
index 0000000..5a0b3f5
--- /dev/null
+++ b/phpToDo.spec
@@ -0,0 +1,46 @@
+Summary: phpToDo - todo list written in PHP with MySQL
+Summary(pl): phpToDo - lista rzeczy do zrobienia napisana w PHP i MySQL-u
+Name: phpToDo
+Version: 0.1.1
+Release: 1
+License: GPL v2
+Group: Applications/Databases/Interfaces
+Source0: ftp://ftp.ftlight.net/pub/phptodo/%{name}-%{version}.tar.gz
+Patch0: %{name}-config.patch
+URL: http://php-todo.sourceforge.net/
+Requires: mysql
+Requires: php-mysql >= 4.1.0
+Requires: webserver
+Buildarch: noarch
+BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define _phptododir /home/httpd/html/phptodo
+
+%description
+phpToDo is a simple todo list written in PHP with a MySQL backend. It provides a very simple and efficient way of keeping track of things to do, and it sorts tasks by their priorities. The user interface is designed to make usage as easy and efficient as possible.
+
+%description -l pl
+phpToDo jest prostą listą rzeczy "ToDo" napisaną w PHP z backendem w MySQL. Posiada bardzo prosty i efektywny sposób na śledzenie rzeczy do zrobienia oraz sortowania zadań według priorytetów. Interfejs jest zrobiony aby być jak najprostszym.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_phptododir}/img
+
+install *.php *.inc *.css $RPM_BUILD_ROOT%{_phptododir}
+install img/*.png $RPM_BUILD_ROOT%{_phptododir}/img
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS ChangeLog INSTALL README TODO sql/*
+%dir %{_phptododir}
+%attr(664,root,http) %config(noreplace) %{_phptododir}/config.inc
+%{_phptododir}/*.php
+%{_phptododir}/*.css
+%{_phptododir}/img/*.png